Outlook Add-in Missing

Copper Contributor

Dear all


I am unable to make the Outlook plugin work for one of our employees. I know where the plugin-in is located on the computer and when I add it manually - nothing happens. I have also reformatted the entire computer but to no avail.


Can other plugins interfere with the proper loading of the Teams plugin? 


Do you have any suggestions on what I can do? 





23 Replies



If a user switched in the Microsoft Teams App to another tenant, the Outlook plugin for Microsoft Teams is hidden. As soon as the user is back in the "home" tenant, the Outlook plugin should be available.

@Achim Bossler Hi Achim


What tenant are you talking about? 


I have even reset this user's computer - yet he is still unable to see the plugin. 






I'm talking about the case, where a user is a member of at least two tenants:

  • member of the "home" tenant
  • external guest of any tenant


@Achim Bossler 


One of our employees is unable to create a Teams Meeting in Outlook as the user does not have (and cannot load) the Teams Meeting Plugin loaded.


This is what it should look like:


Annotation 2020-01-10 163252.png





Have you checked Microsoft Teams for this user (e.g. license, same account for Outlook and Microsoft Teams)? Can the user connect with the Teams Client? If everything is ok, I have no further idea.

@Achim Bossler 


Yes he can connect - he has an Office 365 license from our company.


I have no idea why I cannot make the plugin work for him.

When I load the plugin manually (using the COM Add-in), I get no error message - but also nothing happens


Have a look at this blog post for further ideas.

I assume the user has the Teams Desktop client installed and loaded and logged in? Also make sure your architecture matches (Both Office and Teams is 32bit or 64bit).

Does the user have the ability to schedule a meeting in the Calendar inside of the Teams client? Is the Calendar tab even there?
Another thing to check will be to check the Org Upgrade mode, and also what is this individual user account upgrade mode set too in the admin center. It should be Teams Only or Skype with Meetings/Collab modes.

@mscola The Teams Comm Addin is either disabled or corrupt.

go into options, comm add ins, and enable it,...restart Outloomand it should reappear.

@mscola If retail version of Outlook installed Teams Add-in is not supported and wont appear. Reinstall Office from, Start Teams first, then start Outlook (likely need to setup user profile again).






Your problem is fixed or not?

Tried alot to fix the issue but not succeeded.

Teams add in is not showing in outlook nor in "Com add in"

when i add it manually it gives no error and giving added successfully.

Any help can be appreciated



best response confirmed by ThereseSolimeno (Microsoft)

@Taimur10 This page explains it all


Go to the Troubleshooting part as well


If Teams is installed and you're having all prerequisites for the add-in to show up in the Outlook client, but it doesn't, my experience is that this process will enable it.

- Restart the Teams desktop client.
- Sign out and then sign back in to the Teams desktop client.
- Restart the Outlook desktop client. (Make sure Outlook isn't running in admin mode.)



@mscola   I know this is a late REPLY to your message, but I just had the same symptom occur today.  I closed Outlook and logged out of Teams.  I logged back into Teams, opened Outlook, and the plug was enabled and it shows "Teams Meetings" when I create a new meeting request.


The symptom started right after I tried to install Visio.  The install failed, and I lost all the O365 file extension associations.  I re-loaded O365, then I loaded Visio successfully.  That is when I noticed that the "Teams Meeting" plug was missing.  Teams wasn't even listed as an available add-in.


Also - we are still using Skype For Business, and we are in "Islands" mode in the Teams Org Settings.  


I am running O365, v 16.0.13001.20266 and MS Teams v


...anyhow - just sharing my experience for others.  hope it helps!

@ChristianBergstrom  This worked for me.

Clearing the cache fixed the problem.


We just switched to using Teams only from Island within our organization. The process must of corrupted my files and caused my Outlook to crash. I reinstalled Office365 and still had the problem in Outlook. I opened Outlook in safe mode and was able to turn off all of the add-ons, but Teams was not on the list. After following the instructions on the link you provided and clearing the cache I was able to see the New Teams Meeting Icon in Outlook. Thanks. @Achim Bossler 

@ChristianBergstrom This worked for me. Thx!



When the add-on is installed and still active It most of the time doesn`t mean that the add-on isnt working. 

Check the add-on by going to File - > options -> add-ons if it is on the add-on is there. 


If the icon of Creating a Teams meeting is not showning. 


There is an Easy work around for this. 



press with your right mouse button on the ribbon and click on customisepress with your right mouse button on the ribbon and click on customise

click with right mouse button on the ribbon in Agenda and click on customize ribbon


after that the window will open. 


Add a group to the bar of the ribbon. rename it to TEAMS

adding a group.png



after that choose all commands to show and search for New teams meeting most times its the second one that is working. 

after that select it and add it via the button add to the created group


just to be sure. add both of them because it differs on which version you have of Teams. 


after that press OK. it should look like this. 

end resultend result


you can go back to customize ribbon and remove the one that is not working by selecting it and pressing the remove from ribbon after that press ok. 

its also possible to schedule it next to skype select it and press the up or down buttons in the customise ribbon menu. 



A method which I use to resolve this which generally tends to work is the below:


1. Navigate to C:\Users\*****\AppData\Local\Microsoft

*** Being the user who is having issues

2. Delete the MicrosoftTeamsAddin folder

3. Copy the file from another users account which works

4. Reopen outlook and check to see if Teams addin is within com addins


If this doesn't work I have used the below:


1. Close outlook

2. Open CMD as Admin

3. cd C:\Users\*****\AppData\Local\Microsoft\TeamsMeetingAddin\1.0.20107\x86 (Addin version number may be different)

4. regsvr32 Microsoft.Teams.AddinLoader.dll

5. Restart machine


Now this doesn't work 100% of the time but I have found this to work in most cases.