Document in "Read-only" mode all the time

Frequent Contributor

Hi, I tried to find a solution here but I was not successful. I have SharePoint library and when we want edit word document in desktop application, document is opened as a "Read-only". Do you have any idea what to do with it? I just found that there is problem with OneDrive and synchronization. We have own Content type on this library but I just try to edit document directly from library and it is not possible.

32 Replies
Most of the time documents open read only and you click the edit link in there to edit the document, does this not show at all? What if you try to save over the document is it locked by someone else using a client that doesn't support co-authoring?

As you write the edit button is missing. I work with SharePoint for a long time and I know standard behavior. Anybody else does not work on document. Only I try to edit it. I do not know if there can be issue with OneDrive or Content types… but I have never had this kind of trouble with SharePoint library with co-authoring or even simply editing documents. It is really annoying and uncomfortable for end users when there is only one way to edit document that they have to download it, edit it and then upload back... 

Not sure OneDrive supports content types yet. However you said you can’t edit direct from Sharepoint either thou? Have you tried on a machine without OneDrive sync Setup on the file and it works?
Also other things that will make files read only with Sharepoint and OneDrive client are required fields. Make sure no fields have been made required. Also one of the following settings on the library will cause it to sync read only as well:

Libraries with Checkout, Required columns or metadata, or when Draft Item Security is set to either Only users who can edit or Only users who can approve items in Version Settings of the library.

I tried everything now:

1. I use computer with sync this library

2. I set up a required fields as a optional

3. Check-in and check-out is disabled

4. Version history is set only for major versions

5. I made new "clear" (without content types) in the same tenant and upload document there


without success… Document in desktop app is still read-only. Only in web browser is possible edit document.


I tried to create new library in different tenant and upload document there and everything works. I am able to upload document and then edit it directly from the library in desktop app.

Interesting. At this point sounds like a conditional access policy in place preventing edits via client applications. Do you guys use those at all? It’s accessed via azure portal.

Yes, it is interesting. We do not use any policies at all. I tried to create new libraries on different web sites (within one site collection), upload document there and try to edit it. Success was only in 1 case from 4. I checked all settings of all web sites if there are any differencies and I did not find anything. I am helpless already.


Are you using checkout/checkin?

My files become read-only if I use MS Word Desktop to check the file in and the library is synced to OneDrive.


I experienced this same problem (everything opened in read-only mode) and after I tried all the tips and tricks I  could find, this is the only one that worked for me: I stopped syncing the document library. 


I re-synced the document library, and now the status of the files is clearly "read only":

read only status.PNG

I have never seen this "read-only" status before and I just cannot figure out why these files are locked while other libraries are just fine. 

The only difference between the files is that the locked files are from a communication site and the files that work okay are from team sites. Otherwise the settings are the same and I have full ownership to all of them.

Ugh. This drives me crazy.




have you tried different computer? I know it's not a solution but form my experience:

Computer A

Windows 10, version 1803, build 17134.376, Office 365 - 16.0.10827.20181 64bit (clean installation)

Computer B

Windows 10, version 1809, build 17763.55, Office 365 - 16.0.10827.20181 64bit


On both computers I logged in with the same account with nice result:

Computer A - can create document, edit it, save it, but it's read only when reopened.

Computer B - works normally as expected.


Just two people out of twenty have this problem.

I tried everything from your list + manual reinstallation from 32bit to 64bit Office version + Online repair.

So I does not seems to be a library problem from my point of view. 

I have problem only with recent documents in the library but the newly created have this kind of issue. May be MS fixed that already…..


I also found similar problem in 2016 forum with note "Our engineers are working on the fix" and saving another document copy as a workaround.


Nice :), any idea?


Thank you.



FYI, after the passage of time (and likely automatic updates), this now works correctly for me.  Files are now read-write.  

I could fix this problem by removing all credentials starting with "MicrosoftOffice2016" in Control Panel\User Accounts\Credential Manager.

@Miroslav Novák wrote:

Hi, I tried to find a solution here but I was not successful. I have SharePoint library and when we want edit word document in desktop application, document is opened as a "Read-only". Do you have any idea what to do with it? I just found that there is problem with OneDrive and synchronization. We have own Content type on this library but I just try to edit document directly from library and it is not possible.

I got the same issue before. What I had figured out, it happened after I synced my SharePoint library with the onedrive client in my PC. To solve the problem, I un-sync the library by unticking it from the settings. 


Hope this also works for others.


There used to be a bug that caused MS Word Desktop checkin to lock a file read-only if it was synced with OneDrive.  The workaround was to either unsync the library from OneDrive, or only use checkin from SharePoint via your browser.  


For me, this bug seems to have been fixed.  I can use Word Desktop checkin on synced libraries without issue.  


Another person with this, or certainly a similar problem (I'm working with a document that I've opened via the Browser, not the OneDrive sync client). I'm working on a customer site (using their wifi to connect to their SP Online tenant from my laptop that I've logged into using my organisational account)


Scenario is where I've worked on some documents in my OneDrive and when completed the first draft I've uploaded these Word documents to a SharePoint library on my customers tenant where they have reviewed. 

They've provided feedback and I now need to update the document. I can only edit the document in Word Online. 

Each time I click the "edit in word" button , the document will open in the Word client but only ever as (Read Only).


I can save as and overwrite the server copy but the document in Word still is a (Read-only) document.


My collaborator on the Customer side has closed out of the document and has repeated the same steps as I on his machine. The document opens up on his machine , in Word , for editing. 


I'll have to continue to use Word Online. which is not idea as I want to copy and paste in some screenshots into the document , and Word Online is not allowing me to do this! - advising me that i can only upload image files stored on my machine and not copy and paste :( 


I've heard other people complaining about this issue before.. Any ideas what the solution is or why it's happening? It's hardly "by design" is it?


@Colm Counihan Did you try this fix?


 I could fix this problem by removing all credentials starting with "MicrosoftOffice2016" in Control Panel\User Accounts\Credential Manager.



@Roger Schmidt Thanks!


I have 21 credentials for MicrosoftOffice16 and another 2 for MicrosoftOffice15 (the latter 2 are associated with specific logins I have on a customer tenant)


I removed the 2 Office15 credentials first (I didn't fancy removing all 21 Office16 credentials)... and it worked.


Perhaps the combination of the Office15 and Office16 credentials were the cause of the issue? (I'm only basing this on your suggestion solving the problem.. I wouldn't have even thought to look in "credential manager" tbh)


Thanks again


We have been having a similar problem with SharePoint Online and Office 365.


We have a document library that is configured to require check-out to edit documents.


Workflows send out an email with a link and the user clicks on the link to open a spreadsheet, the spreadsheet is opened in the desktop application with a yellow bar "READ-ONLY We open this workbook read-only from the server. [Edit Workbook]".

If the user clicks on [Edit Workbook]  the file can be edited but can't be saved back to SharePoint because it is not in the check-out state.


If we go to the library in Edge and click on the spreadsheet it opens in the desktop app and presents a yellow bar "CHECK OUT REQUIRED To modify this server workbook, you must check it out [CHECK OUT]".

If the user clicks [CHECK OUT] they can edit the spreadsheet and save it back to SharePoint.


If I get a link for the spreadsheet by right clicking and choosing get link and then send this link to someone, when they click on the link the spreadsheet opens in the online version of Excel.

The library setting is "Use the server default (Open in the client application)" so this behaviour is not the desired behaviour.


This inconsistency is very confusing for people using SharePoint.




@Miroslav Novák 


I fixed this by going into the SharePoint library settings, clicking on versioning settings and under "Require check-out" select No.


@Miroslav Novák 


Hi, I know this problem from a SharePoint 2016 on Prem environment.
Temporarily (at our environment)  the problem can be solved by completely resetting the Internet Explorer settings (important when resetting - select the check box "Delete personal settings").

Unfortunately I haven't found a reason for this yet. I can exclude OneDrive from my list because it affects users who have not even configured it. My previous assumption was that the whole thing happens when users jump back and forth between different WIFIs (it usually hits users who don't have a fixed workstation).

And there is something else. The SharePoint can be reached via https as well as via http (https is the default). If the problem occurs and the user opens the document with http instead of https, the user can edit the document again.



@Miroslav Novák Our issue was on SPO where we had given access directly to a library but not the site.

Limited Access Lockdown site collection feature was the culprit - disabling this allowed users to open excel documents as expected.


I was getting the same issue, all documents and spreadsheets were opening read only with no option to change to edit.


Strangely what worked for me was: Close the OneDrive app, go to the SharePoint Online and open a document from there (but choose to open it in the app not the webpage), it should open fine.

Then close that file and open OneDrive again, all documents now opening fine!


hope this helps! 




@Miroslav Novák 


after looking at the network communication protocol I see only one difference between a client where is working and where is working not. at the client where the documents are only opened read-only/write protected I see that the _vti_bin/cellstorage.svc/CellStorageService is never called there. I think this is because a HTTP OPTIONS  was send from word/excel to the lib before and HTTP 401 was returned.


@Hilla R. 

Thanks for the solution, It reduces my headache.


Hi @Kangee,


thank you for your results of analysis. Do you have any tips how to avoid it or what to do in this case as a workaround?


Thank you,




@Miroslav Novák 


No I have unfortunately no tips the only thing which has brought us something further is this article:


However, our property was already $true and we simply set it to $false. After that it went everywhere with the Office 2013 users who had problems so far. However, a few colleagues simply installed Office 2016 and now we have problems again with these office 2016 user.




@Colm Counihan 

I am also experiencing the same issue and remove the Office credentials.


User is required to sign into the office app again but the issue remains.


File is still read-only in Office app.



@apkoh18 I was able to solve this issue by disabling the "File Check Out" feature on the sharepoint site/library



I had this issue for all documents stored in SharePoint / Teams, opening in the desktop applications always opened files in read only.  On other computers it was fine, and in the browser apps it was fine, just the desktop applications / thick clients.  If you navigate to the Info menu from the File tab, the error message is something to the tune of "something went wrong, file has been opened in read only mode".


The issue occurred after a laptop refresh, and after working with our IT department we determined the issue was due to some sort of corruption with my user profile. re-building my user profile (via the registry) fixed it.  


Just thought I'd pass along for anyone else experiencing the same symptoms as me.


@fakhrula Thank you! :happyface:

This fixed an issue that has been annoying me for some time.


@Hilla R.Same over here. I kept having issues with read-only, unsynced from OneDrive, and now this is no longer an issue.


@Hilla far as I know, the read only mode in the file explorer is set, when the synced list is set to have mandatory file tags. The explorer can't deal with it.