Teams not working on iPhone

Occasional Contributor

Teams works on both my desktop and laptop but stopped working on my iPhone.  It will not accept the credentials I use successfully on other devices.  I have uninstalled the app and reinstalled as well as rebooted the phone.  I have tried to log in using another account with the same problem.

When I look in Settings>Apps and Passwords there is no listing for Teams.


What is the solution?

17 Replies
On the login screen is there and going back button to click?
Any OS updates?
Do you have Microsoft Authentication app?

@adam deltingerYes, it takes me back to the sign in option.

@Jenny8675Yes but weeks before the problem started.


No, I did not need it before. The App worked for over a year.

@Bryan-66 I would try installing it and see if it makes a difference. Makes using all your Microsoft Apps a much more seamless experience with single login. 

@Chris WebbI'll try that later today and get the QBR code from my IT staff.  Thanks.

Shouldn't need to setup any of that. Just install the app, then try login to Teams.

I have had Teams on my Iphone XR for 3 months and it worked great.  Since yesterday, when I open the app, it stills on the screen for 2 seconds and disappears.  Can someone help with this.  I have looked to ensure I have cellar on, it is.  I have deleted 3 times and downloaded again and the same thing keeps happening.  Please help.

@Bryan-66 I have the same issue on my wife's iPhone X. She just installed the app today for the first time. It never worked from the get go. When launching the app from the Apps page, it opens up with the "Teams" logo for 3-5 seconds then it's back to the Apps page. It's definitely crashing. Works on PC & Mac and even Android, but Teams is crashing on iPhone.

I had same issue just now, same phone.  You need to clear your cache for Teams.



scroll all the way down and select TEAMS


Select "clear app data" button.

Close/reopen TEAMS


All good!



On my iPhone XR I keep getting a warning message telling me to talk to my IT admin... it is my personal cell phone so I am my IT admin!

@Chris Webb 

Thanks for the advice. Worked great

Your suggestion cleared my issue.  Thank you so much! @Earlmi595 

I have same issue on my iPhoneX. It worked for more than year and recently changed my password as it was expired from then it stops working. When i login in Teams it is navigating to Microsoft authenticator and then asking to login there once i login it says to approve the request in authenticator itself.. How can i approve in authenticator where am in authenticator.. Same happening in Outlook as well.

@Earlmi595 This issue just began on my iPhone11 this morning.  Yesterday, corp password reset.  This morning, Teams on iPhone just kept repainting the screen (looping). I deleted the app, reinstalled and now I get the error saying I'm not on the internet (I am).   Tried clearing app data, power cycling phone, and still no fix.    This is weird!