Cannot download teams meeting recording

Occasional Visitor

Hi,

 

Our organisation doesn't use Stream. After I recorded the meeting, I got the following message: "Recording failed to upload to Stream:".

 

The Download button doesn't seem to work so I cannot save to my local drive. What are the reasons for this? Is the recording saved somewhere on my local drive?

 

Thank you.

10 Replies

@jkan18 Hey, if you don't have a Stream license the recording is stored in Teams cloud storage (Azure Media Services). See this page for full details https://docs.microsoft.com/en-us/microsoftteams/cloud-recording

@ChristianBergstrom -- this doesn't solve the identical issue we are experiencing. We recorded locally and yet still get the same "Failed to upload to MS Stream" message. The Help article you flagged deals with where data is stored (i.e. what country the data is stored in), not where you can actually find the recording. This is unfortunately going to eat into the rest of my work day. Shame on Microsoft. 

@Tyoung25 Hello, this was a pretty old reply. Things look a bit different now. The link above is rather detailed from many point of views btw, so I don't agree with you.

 

But first things first. What subscription do you use? A1? I suppose you're using the "old" storage location (classic Stream) and have not opted in using OneDrive and SharePoint for teams meetings recording storage.

 

Basically, if you don't have a Stream license the recording will not be uploaded automatically in Stream but will end up in Azure Media. Available for 21 days. Same goes if you're using the new storage location but don't have OneDrive/SharePoint license. When you record a meeting you always get a meeting recording link when finished, look in the chat. If a channel meeting, it's going to be in the channel conversation.

 

So, what exactly are you experiencing and what is the issue to be more precise?

@ChristianBergstrom -- the help article is detailed in every way except for answering the core question of "where is my recording?" I'm experiencing the exact same thing as the original poster. When we did this same thing 2 weeks ago, we simply clicked "Download" and the file appeared in the "Downloads" folder. 

 

I'm not sure what value Streams brings. I simply want my local recording as I've previously been able to download from Teams. I don't believe I even have access to Azure Media. Switching to Zoom for important recordings, because this error just cost us dearly (the opportunity to appear on a nationally televised News channel). 

@Tyoung25 Why dont you read my reply above once more. It's all there. Answer the questions as well. You can't expect people (community folks) to assist when you engage in a conversation with that kind of approach.

 

Use OneDrive for Business and SharePoint for meeting recordings - Microsoft Teams | Microsoft Docs

 

Play and share a meeting recording in Teams - Office Support (microsoft.com)

 

Record a meeting in Teams - Office Support (microsoft.com)

@ChristianBergstrom 

Maksymus_1-1637840559599.png

Did you have a similar issue? With error message: Recording failed to Upload
No possibility to get the video file. Checked in SharePoint, Streams, OneDrive. Is there any other place where the video can be found?

 

Hi, just recently there was an incident that affected Teams meeting recordings. So if this is an isolated issue you know why this happened. Your best shot in this case is to either ask your administrator to use this tool https://docs.microsoft.com/en-us/microsoftteams/troubleshoot/teams-administration/admin-self-help-di... or ask your admin to open a support ticket with Microsoft to get the recording.

@ChristianJBergstrom 

Thanks for the quick reply! We'll try and let you know about the result

Unfortunately, the administrator tried recommendations from the article but without success, asked our IT partner in Switzerland, they checked MS365 tenant for temporary files and stuff but did not find anything... We lost a very important record, as an employee who made a presentation already doesn't work with us and we lost any possibility to recover the information...
You need Microsofts help for this, not the partners. Have your admins or the partner create a support ticket with Microsoft from withing M365 admin center and provide the meeting details and meeting link in that ticket too.