SharePoint Page in custom teams app

Copper Contributor

I've created a custom Teams App to show a SharePoint Site, it worked just fine for a couple of days and all of a sudden it stopped and I only get Timeouts when trying to open it. It works fine in the iOS App but neither on the Desktop App nor in the Web version.

I've added the SharePoint URL and to the valid Domains, but it doesn't help.


Any advice would be welcome!

9 Replies
Hello @jpokorny - Could you please share the repro steps so that we can quickly try to repro your issue.
Also, please let us know if you are getting any error in console.
Hi, I think I found the Issue, the console says that it can't load the page because the X-Frame-Options are set to DENY. I understand that it's a countermeasure against clickjacking, but is there a workaround for Teams Applications? Thanks in advance!

@jpokorny - Ensure that you adhere to the following prerequisites while building your Teams personal and channel or group tab - Prerequisites - Teams | Microsoft Learn

Hi, most of it doesn't apply to my application since all of it is hosted by Microsoft, but I noticed an error in my App Registration and now it works in my Browser, but it's still timing out in the Desktop App. I guess it's the cache but I can't find the files of the "New" Teams App on Mac, the Support article doesn't help since it's written for the old version.
Could you please let us know if you have further questions?

Hi @Meghana-MSFT, could you tell me where I find the Cache Files for the New Teams on MacOS? I've tried the default command, but there is no Teams Folder to delete.



@jpokorny - 

To clear the cache files for the new Teams on MacOS, you can follow these steps:

  1. Quit the Teams application if it is running.
  2. Open Finder and click on the "Go" menu in the top menu bar.
  3. Press and hold the "Option" key on your keyboard to reveal the "Library" option in the dropdown menu.
  4. Click on "Library" to open the Library folder.
  5. Navigate to the following path: Containers/ Support/Microsoft/Teams/Cache.
  6. Delete all the files and folders inside the "Cache" folder.

Please note that the "Library" folder is hidden by default in MacOS. By pressing and holding the "Option" key, you can access it. If you are unable to find the "Teams" folder in the specified path, it is possible that the cache files are stored in a different location or the cache files are managed differently in the new version of Teams. In that case, you may need to refer to the Teams documentation or contact Microsoft support for further assistance.

Additionally, you can also try clearing the Teams cache using the Teams client itself. To do this, follow these steps:

  1. Open the Teams application.
  2. Click on your profile picture in the top right corner.
  3. Select "Settings" from the dropdown menu.
  4. In the "Settings" window, go to the "General" tab.
  5. Scroll down to the "Application" section.
  6. Click on the "Clear Cache" button.

This will clear the cache files for the Teams application on MacOS.

For more information on clearing the Teams cache, you can refer to the Microsoft Teams documentation on Clear the Teams client cache.

Hi @Meghana-MSFT, the error just came up again, it worked for a couple of weeks but now I can't login anymore. I think the SSO is broken, I've set up the App in the Entra Admin Center and put the ID in the Custom Teams App but that doesn't help. Do you have any ideas?
Could you please confirm if you are still facing the issue? If yes, please share the repro steps so that we can quickly try to repro your issue.