Can't open document shared with me in Word desktop application

Steel Contributor

Someone shared a document with me via OneDrive for Business, but this only gives me the option to edit the document online. The option to edit the document in the desktop application is only available to me when working on documents stored in my own OneDrive for Business.  I'm logged in with the correct account in the desktop application and I have tested this in another tenant and can't find a way to enable that option. Is there a setting for this or is this by design? 

27 Replies
Maybe the company of which you received the document set a Device acces policy which doesn`t allow to open/ sync the file outside the browser.

Thanks for the reply. I've tested with a new trial environment and get the same experience. It does work for the consumer version of OneDrive though. Can you confirm that this should work for OneDrive for Business as well? Based on my tests this seems to be by design, but I hope I'm wrong.  

It should definitely work.

I guess you are doing something wrong: can you please detail your steps?


I'm testing in a new trial environment. The settings for external sharing are the least restrictive and I'm using the "only specific people" option when sharing. The invited account is an Office 365 account, the Office installation is O365 pro plus and I'm signed in with my O365 account. Have tried both Chrome and Edge. External sharing itself is working fine, but the button is still missing. 

What do you see when you right-click on the file in Shared with me?



Only the option to open it in Word Online. Noticed that I didn't mention that the document was shared by someone from another organization. The edit in Word button is available when sharing with colleagues. My assumption was that sharing externally also would support editing in the desktop application. 



Adding @Stephen Rice here...I would also expect the user is able to open the Word in Desktop Word even if the user belongs to an external organization, but I also find logical he is not able to do it because for ODFB the user you are sharing the document with is not considered as an external user at all (and for external user I mean a user that has the ability to make things in your ODFB...for instance, a external user in Teams and Office 365 Groups can edit documents using the Delktop Word)

Another test I did in the trial environment was with a document in a team site connected to an O365 group and adding myself as a guest. External access is working there as well, but I'm still not seeing the option to edit the document in the desktop application. 

Are you sharing anonymously, perhaps?

In that case, you don't have the option to edit in Word desktop.

I'm using this option:




Can also see my email address in the top right corner when editing online. 

Let's wait for an answer by @Stephen Rice, then...

best response confirmed by Pooya Obbohat (Steel Contributor)

Hi all,


I think I know what is happening here. @Pooya Obbohat, when you receive the document from your partner, what experience are you seeing when you click on the link? My expectation is that you are seeing the new one time passcode flow (i.e. a code gets sent to your e-mail address, you enter it into the web page and then you get the document in Word Online). If this is the case, then this is expected. Even though you are signed in with an O365 account, your session in this tenant is actually not connected with your O365 account (beyond us verifying that you own that e-mail address). We don't currently have support for opening in the native apps in these cases.


There is work currently in-progress to make this experience better (when you access a OTP link but are signed in with an O365 account) so keep an eye out for that :)


Now, if you were added as a guest user in a Group and attempt to open a file that is stored in the site, you should be able to open that in Word (since you have an account). If that isn't working, please let me know so we can dive deeper there. Thanks!


Stephen Rice

OneDrive Program Manager II

@Stephen Rice


Are you perhaps saying that, in other words, access through one-time passcode is similar to anonymous access (once you have entered the passcode) ?

@Salvatore Biscari, only in that you can't open the document in a rich client. The root of both problems is that Office clients only understand how to authenticate with MSA or AAD accounts and so can't handle users who are verified via the new secure sharing or who are "anonymous". Thanks,


Stephen Rice

OneDrive Program Manager II

Thanks for clearing things out. The issue I was having with the team site connected to an O365 group was temporary. I'm now able to edit the documents in the desktop application. 

@Pooya Obbohat,


Glad to hear it! Let me know if you run into any other issues!


Stephen Rice

OneDrive Program Manager II

@Stephen Rice 

I believe I have a similar issue whereby I applied permissions using Microsoft Azure before sharing it via OneDrive Business to an external recipient. This then have me a OTP passcode but I was not giving the opportunity to open the document in Word thick client. 

Assuming there is no current workaround?


Thanks and regards


Hi @GeorgiaS89,


Is this a brand new word doc? The error message looks related to IRM, not the external user account. Thanks!


Stephen Rice

OneDrive Program Manager II

Hi @Stephen Rice,

Thanks for following up. Yes it's a brand new document with IRM.

What I noticed is if I share the file from O365 E3 license to another O365 E3 license and the recipient can authenticate an "Edit in Word" button is displayed. The same button is not displayed to an external user (Microsoft Personal Account or Gmail) when OTP is used to authenticate. Meaning the document is unable to be opened as IRM restricts it from opening online and there is not option for the external user to download or open in the Native application. Therefore made me think the issue is the external user not being able to validated 100%.