Poly Studio x30 Teams account disconnection

Occasional Contributor

We have a Collaboration Bar (x30 from Poly) and we're experiencing regular account disconnection. 


When the account is logged in, the bar itself works, we can do video/audio calls without issue. However, when it sits idle for a while, it disconnect on its own and make the TV flash in the process, which is very distracting.


I pulled the logs from the device to understand what's going on, but I'm at a loss at what I should be looking at specifically...


In the logs, there's a Teams folder and a cache subfolder with a bunch of .blog files and I attempted to open them with Notepad++ but they're unreadable (see screenshots).


Any idea how we could troubleshoot this?


Teams_logs.PNGOpening the .blog files render as garbage in Notepad++Opening the .blog files render as garbage in Notepad++

60 Replies

@Remi_Solulan if you don't mind, please report here on what happened with this issue. I have not seen this before, so I'd like to know the resolution. 

I will contact Poly support (10 bucks says they'll tell me to contact Microsoft because they don't control the "app experience" on the device)

But in the meatime, is there anybody that would help me read those logs for the Teams app loaded on the x30? Specifically the .blog files which are unreadable for some reasons and Google returns nothing meaningful on how to read them. Is there a special encoding necessary?

Could you send me a video of what is happening? Feel free to send me a private message, if you prefer. They do control the idle experience though, so let's see what they say. My X30 sits idle for days and everything is ok.
No clue on the logs. Let's gather some more info and I will escalate to engineering when necessary.



We have the same issue with Poly X30 and X50. Some devices  logged out and the only way now to reconnect the device is to switch back to Poly mode (for exemple )and then switch to MS Teams. If we try to reconnect the device we recieve the following message on the monitor : 


hier we see that the device for any reason is in Personal mode !!

The blog files are unreadable, but looking at the message files hier :


we find some strange behaviour .. According to the logs it seems that the Teams client is unable to find out his settings in order to try to reconnect. The request was sent to ipphone.teams.skype.microsoft.com with default or false parameters...See below


Can you check if you are seeing the same behaviour ? 



@YamenMjendel @Remi_Solulan 

I have not seen this before. I am asking people on our side why this might happen, but likely we will need to reproduce locally. Thanks for sharing the logs, but a video of what is happening would be really useful as well. Ideally though, would it be possible to get a temporary test account from you to look into this further? 

I've looked inside all messages logs and I'm not seeing this kind of behavior on my end.

@Pavel Yurevich it would be difficult to record a video of this since the issue is random but I'll try to arrange something. 


Could it be related to MFA and compliance policy somehow? I noticed the account we use on the X30 has MFA enabled.

Updated to the latest firmware via TAC. Waiting to see if this fixes the issue.
Yeah, I was going to reply here yesterday, but got busy. We have investigated this issue based on a few similar reports from clients that we work closely with, and it seems that these issues stem from account configuration. Our general guidance for devices is to disable MFA and also have prolonged token lifetime. Could you check this? https://docs.microsoft.com/en-us/azure/active-directory/develop/active-directory-configurable-token-...

It possible it is some other configuration issue as well. Please keep updating the thread when you learn more.
I also have this identical problem, did you make any progress with it?


unfortunately not really. We opened a Ticket with Microsoft support and we still troubleshooting.

No progress on my end.

It seems like something is wrong with the devices itself because when I do a continuous ping to the bar, after about 2 hours it stops pinging back. I have to do a power cycle to restore connectivity.

I eventually called Poly for assistance and they told me the unit is out of warranty and it would cost $500 to open a support ticket... We are evaluating our options now, but needless to say, this is a frustrating expenrience.

@Remi_Solulan @YamenMjendel 
My units seem to be absolutely fine for a couple of days and then randomly disconnect and then leave the units stuck in a loop between the Intune company portal with the screen attached. There is no option but to go back to the Microsoft Teams Sign-in Screen, clicking on 'sign-in' brings me back to this Company Portal and it just loops around.


The only way I've found to fix this is to perform a factory reset of the unit and re-provision it, it is then OK again for another few days before the process is repeated.

Is that the same experience that you are seeing?  It strikes me that it is something to do with Intune, but I can't find a way of stopping these devices going to Intune either?

@andytoner yes absolutely the same issue that we have too... Looking at the screenshot that you sent  … your device has an ownership type corporate..which is not the same for our devices despite that we are using cloud device accounts to register them. We see that the devices are in Personal ownership mode. Any idea what could be the reason for that ?

@YemenMjendel It's a configurable option within Microsoft Endpoint Manager (Intune), you'll find it under "Home > Devices > Android Devices" click on a device to open it, then click on Properties and you will then find this Corporate or Personal option there.
My device started as Personal and had the problem so I've tried it with both options and neither makes any difference to this particular problem.

Do you know what version of software you are running on your Poly units? Is it the latest from Poly ( or the latest Certified version by Microsoft (
@andytoner, thank you .. We tried both versions from MS and from Poly but in vain the issue still there ...How do you register your Poly device ? Since we have to use a 32 character password, we are using the option "sign-in from another device" ? Are you using the same way? I am wondering if this option is causing this problem ?

@YamenMjendel I'm signing in to the devices with a dedicated user account and password. I'm not using the option to sign-in from another device so that doesn't look to be the cause either.

I can't find anything of use in the Poly unit logs, and when I've raised the issue with Poly they just tell me that the X-series devices are not supported with Intune, as per the link below:
Knova Self-Service (polycom.com)
Do you know if all devices registered directly in Azure are forced by MS to register in Endpoint Manager?  That seems to be the information I have read.
I'm wondering whether it is the version of the Company Portal App installed on the Poly units that is causing the problem?

@andytoner we don't get an error message about Intune on our screen. For us it looks like it's hardware related since it loses connectivity completely. I can't even access the web GUI after some times. I'd have to reboot the unit to get it to work again.

Factory reset has been done, but the issue persist. We're on the latest software version supported by MS.