Force Teams desktop client update

Silver Contributor
Hi all,

I've recieved several questions about this and I'm also seeing too many topics about it here in the community.

We all know about the update process for Teams as described here and here for example.

But sometimes you're just stuck as nothing happens when trying to clear the cache, reset the app, update and/or reinstall.

This is an easy way to force an update of the desktop app (even though most updates happen backend).

1. Look for the latest version seen, one place to do it
2. Copy the version number and paste it in the link below and hit enter.

In my example, and at the time of writing, I'm updating to version

I've been struggling with this myself some time ago knowing features being released backend but didn't show up in my desktop client. After this process the client was updated and the features appeared for me as well.

Hope this will prevent some of you going mad.
36 Replies



@IanMurphy48 wrote:


It is *extremely* likely that a specific build would cause the issues I describe. Its called a bug.

However this forum isn't full of people reporting the exact same issue, and from your description no one is going to live with Teams crashing constantly. Microsoft also wouldn't leave people on a version with such an issue when they have newer versions either would they?



By any chance is it a Lenovo L13 Laptop like mentioned over here 


My Laptop shuts down during TEAMS calls - Microsoft Tech Community

@ChristianBergstrom WhatPulse appears to be switching to a subscription model.  Microsoft Teams - Wikipedia lists a recent version, although I'm not sure that it is as up-to-date as WhatPulse.  Do you know of another way of listing the latest version in circulation?



Hey, I suppose you can just google it :) Bear in mind though that this procedure isn't something that you usually have to even think about doing. It's more of a last stop when troubleshooting. I've used it only once on my own account when I knew features had been released for my tenant but no matter what I did to update (sign out, check for updates, clear cache etc. etc.) the new options didn't appear until I forced the update.

@ChristianJBergstrom Thanks for the response.  Yes Google, not quite the usual fountain of knowledge where Teams version information is concerned :) I've found the update process to be pretty flaky from a 'will it, won't it upgrade' point-of-view.  Although if it decides to it seems to be ok.  Ah well, hopefully Wikipedia will keep updating the stable version info.

Thanks again.



:) if it's any consolation you're not alone when it comes to that part by judging from all posts I've seen about it over the recent months.

@StevenC365 Given the long history of MS doing precisely that, my answer is a resounding yes. MS fixes bugs which affect a lot of people or which create a lot of noise. I changed nothing, but the Teams issue disappeared a few weeks later, without so much as a reboot (I rarely reboot)... so, yes, it was a teams bug fixed by a Teams update.... why couldn't I just have installed the latest version? Ah, yes, because the latest version is never available for download.


I currently have an issue at a client who is running office 2010 (still). All of a sudden some users have the Teams Icon in outlook, despite that not being supported in 2010. Some users, but not all, and I can't download the same version for everyone, so some people have the icon, some don't. Those that don't have it of course want to know why their neighbour is able to organise meetings from Outlook and they can't. All online help still says that this functionality does't exist.


Isn't this release policy just great...


This is awesome. In one link you've supplied more information than every other MS or Forum posting I've found on the subject.
Why on earth couldn't MS just have posted this list and let people decide which version to install. Most will just go for the Production build in any case.

Thank you very much.


Hi Christian

I have the update loop problem and was reading your post - it mentions to copy the latest version in the link below and hit enter - cant see the link to paste it in? 



@brendan1000 Hey, the conversation is quite old so some links have been terminated. But you can simply go via this for example and copy one of them to your browser.


Bear in mind this isn't an official way of updating the Teams client but rather to force an installation of another version. From my experience you'll return to your standard update ring after the automatic update interval has been triggered as explained here Teams updates - Microsoft Teams | Microsoft Docs


But for now and for testing purpose go for it.

Microsoft already has an option to retrieve the last version available, on the link


Actually, the last version available is.

You can use a bat script to get the package download link and from that, you can do whatever you want to. 

SET "TeamsURL= curl.exe ""-s"
FOR /F %%R IN ('%TeamsURL%') DO ( SET LINK=%%R )


@Jackson_F_Silva this is excellent, thanks.


Powershell equivalent is:

Invoke-WebRequest -Uri "" | Select-Object -ExpandProperty Content


@Jackson_F_Silva Fair enough. But the above reply was simply an alternative option for installing different versions in troubleshooting purpose, and not necessarily having the latest production build. There are differences when it comes to the update rings and the update process is quite complex, at least I think so.



@Jackson_F_Silva Yes but lacks Electron 16 builds which is quite useful on Windows as Electron 16 has a performance boost

Currently points to Electron 10 builds and already has Electron 16 builds under the exploration section.

I would like to know if the latest version listed on "" refers to the stable or unstable version.

I have tried to download the latest version for macOS following the instructions by modifying the link to "", where I have changed the number "" to the number on "". I got an error message.

Then I started looking for where to download the latest macOS version, and found that if I type "" into the browser and then press Enter, it prints the link to the latest Windows x64 version. But this version number does not match the latest version number listed on "". Here is an older Teams version number. While you can follow the instructions to download the newer version.

Similarly, I tried typing the link "" into the browser, and after pressing Enter, it printed the latest macOS version, which also does not match the version on "". In addition, the version number on page "" starts with "1.00...", and on page "", the number in the link ("") starts with "1.5.00"

From the link, you can see that the latest macOS version is, but I was able to download version by typing in this link ""

So I don't understand which is the latest version.

Is it possible to update the program without anyone logged in? Because I want to install/update the new versions on machines that are used by more people (teachers and students).

I have translated this text using the website "" as I don't know English that well. I speak Hungarian. I hope everything is understandable despite the translation.

Hi ZoltanDecsi1980. I now use this URL as it details the build type.