Outlook (365) Need Password - Issue

Copper Contributor



We are using E3, outlook 365 in our company. Some of our users' outlook stop sync with exchange and ask for password, as shown in below image:


Password Issue - Copy.JPG


to fix the issue, I clear entries in Credential Manager, Delete Temporary Files, unchecked "Use Cached Exchange mode", restart system and check this again.


but after some couple of days, outlook again stop sync and ask for password.


I'll appreciate for any possible support to fix this issue permanently.



120 Replies

I had a similar problem a few days ago! Did the same as you! Nothing worked! I ended up doing an online repair on the installation and the problem was solved..


/ Adam

Hi Muhammed,

There are a number of reasons for this. First I would look inside the Office 365 admin portal to make sure your password expiration policy is not set to only a few days

If this is ok, setting the below registry key to 1 in below path often resolves it

Path: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
Key: DisableADALatopWAMOverride (DWORD)

I would try that on a single user to see if it works before rolling it out. If that doesn't work let us know.

Best, Chris


Thanks for response.


I tried to Path: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, but there is no Key: DisableADALatopWAMOverride (DWORD) 


Please see the screenshot:

Password Issue 365.JPG

best response confirmed by Muhammad Ali Khan (Copper Contributor)
Hi Muhammed,

Add the Registry key as advised in the article

We've been seeing this for more than 6 months sporadically and again same for one computer today. There was no recent password change but suddenly behavior as described here. Adding this key and setting it to 1 fixed the issue with no reboot. We're seeing this reported by a very small number (half or a quarter percent maybe?) of the clients that we manage.

Best, Chris
Thanks Chris, appreciated for your support!

Adding this entry into registry worked like magic, hope it will last now.


I have the same problem, but making this registry change doesn't seem to solve it.  Any advice?  Is the registry entry below correct...?  When editing I set the Value data to 1 Hexadecimal as shown.

It happened a week or so ago, and I eventually solved it by creating a new profile - which was a pain given I have half a dozen email accounts running through this copy of Outlook...  Don't really want to do that once a week...

Perhaps I should also add that this is just one of several O365 accounts being accessed by this installation of Outlook.  I also just deleted all Windows Credentials in Credential Manager - when I rebooted and restarted Outlook, I was asked for passwords for all the accounts except the one with the problem...

Any suggestions welcome.







Hi @Neil Rabbitts,

Did you redo the whole Outlook profile after adding the registry entry as I don't believe it will apply if the existing profile is there (even with a restart of Outlook.

Best, Chris

@Christopher HoardHi Chris,

I'm afraid I can't remember the exact sequencing, but I think I added the registry entry, then when it didn't work, created a new profile as a last resort (may be wrong).  The new profile worked and I thought 'great, I wonder if I can reinstall the account on the existing profile?" (to avoid reinstalling everything below...) which I did, and it worked there too... for a week.  Clearly I don't understand the influence of the registry entry on any given profile, or indeed cause and effect between all this...  So I'm now in the situation where neither profile works for that email address (O365 Business Essentials), so I have one profile just with that mailbox (not working) and the original profile showing mailboxes from:

  • The broken O365 Business Essentials account
  • An O365 Education account (I think EES)
  • A Microsoft 365 account (SBP+EMS)
  • free accounts and
  • an IMAP account.

All are working except the one mentioned.  Perhaps I should also throw into the mix that when I emptied Credential Manager, there were lots of entries from Microsoft Teams, which I use for 4 of the above.  I think I'm working the credentials system quite hard...

Hmmm, that's quite complex.

From experience after applying the registry entry you have to remove every profile on Windows under Mail and then re-add profiles again otherwise it tends to not work. So if you have other profiles there, even legacy ones, you would need to remove them.

I would also look into whether the MSoid CNAME is on the domain you are using Office 365 Business Essentials account as I have heard this can fix it in cases too. You will be able to get this from the Domain section of the Admin Portal.

Best, Chris

Hi @Christopher Hoard , An update.   So, I put off the 'nuclear' option of rebuilding my multi-account profile from scratch due to needing to do some work, spent a couple of days logging onto that email via browser and phone, and.... today, after signing out of the profile on my Android phone (Coincidence?  Possibly), the next time I logged in on my PC I got the magic 'enter password' box, put it in, and all is well again.  Go figure...  Thank you for your patience and guidance, but nothing more to see here! :)

Great, thanks for letting me know @Neil Rabbitts

@Christopher Hoard 



I am facing the same issue again, although registry entry is there, outlook stuck and asking for password.

Please refer to attached screenshot:

@Christopher Hoard 



I am facing the same issue again, although registry entry is there, outlook stuck and asking for password.

Please refer to attached screenshot:


Outlook Password Issue 28-March-2019.JPG

Hi @Muhammad Ali Khan,

In my case, removing my Office 365 account from "Access work or school" (Settings > Accounts > Access work or school) on Windows 10 solved that issue. Then, I connected my Office 365 account again, it worked.

@Satoshi Nishimura wrote:

Hi @Muhammad Ali Khan,

In my case, removing my Office 365 account from "Access work or school" (Settings > Accounts > Access work or school) on Windows 10 solved that issue. Then, I connected my Office 365 account again, it worked.

Thank you so much! We've seen a pretty sizable influx of this issue over the past few weeks and this has worked without fail for us. You are a lifesaver.

Anyone else unable to enter the password when this happens?  In Send/Receive it asks for the Exchange password, when I select that nothing happens.  This happens to me every few months and is very frustrating.  Just got back from a 10 Day vacation and spent 2 hours trying to access my outlook on my laptop. 


Seems silly that there isn't an easier fix.  Removing the account from settings and adding it back in did work. 



I tried everything including several long winded calls with O365 support that went nowhere.

What worked for me was removing all credentials, Office etc. Removing the users product license on the 365 admin portal. Waiting 30 minutes before re-adding the product license and then reinstalling Office on the users PC.

@Clinton van Kampen 


I have a quick fix, the issue is - all of my users are having this issue. Just Outlook 365. The "Need Password" link in Outlook does not work. Can we just get this fixed? I don't want to have to go around to my user base and fix each one every time they change their password.


Teams – log off, then back on (not sure if this is needed)

Open Outlook in safe mode (ctrl+click the icon) it may or may not open, then close it (might not be needed)

Outlook – create a new profile, log in as that profile - close outlook, log back into Outlook as the old profile (feel free to delete the newly created one after verifying it all works)



Nothing beats how quick this is and how easy. It is just a pain in the parts when the "Update Password" button should work.

Hi @Muhammad Ali Khan 


for this issue, i have a solution, i think you can try. 

1st, you should rename old data 


2nd, re-open outlook to check. if not, please repair Office 365 in uninstall explorer.

3rd,re-name .ost file to recover the email, dont need to get all email again.