Windows installer not working

Copper Contributor



Since installing win 11, I have lost the ability to install .msi files.  Everytime I try I get the following error:


This is installing programs like Hugin or Blender. When I try to run as admin, I get the following:


I have tried, starting/stopping in the services.msc,  and unregistering/re-registering the windows installer. My windows is up to date.


Can anyone suggest anything else to try?


4 Replies

Try registry based FIX 3 mentioned here, see if it helps (works with Windows 11):

Hope this helps!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

@Kapil Arya Thanks for the suggestion, turns out I don't have WOW64.

Unsure if this is what is causing the issue, if it is I wouldn't know how to go about fixing it. Just tried google and couldn't really find anything

@notevines same issue

Uninstall windows and look up your product key. Then install it to a external drive then transfer it to the unit for reinstall.