Sound not playing on any device connected to my laptop. What can I do?

Copper Contributor

Hi dear MS Tech Community!
 
After a clean up reinstall of Windows 11, I've gotten sound problems that are driving me crazy.
If you can help me, I will love you forever!

 

Thank you in advance!^^
 

 


SOUND PROBLEM
 
I'm facing sound issues and don't know what to do anymore.
None of my sound devices work. Neither my Realtek processor nor my Bluetooth buds, Bluetooth Bose soundbox, normal headphone-jack devices, HDMI external monitors, or televisions. What surprised me the most, not even my external USB sound card by CLS gives out a beep. All the devices I tested work perfectly on any other Windows computer, tablet, or laptop.
 
And yes, all my drivers are installed correctly. I've also tried the generic Microsoft drivers to be sure instead of the correct ones that came with my device out of the box, but those don't work either. I doubt it is a driver problem, in the first place, though, because my external card, like I said, doesn't work either. So it probably isn't an issue with the Realtek processor itself; it probably isn't a driver problem either. What else can it be?!
 
 
DEVICE
- Laptop model: MSI WS75 9TK:
- RTX Quadro 3000 with 6GB VRAM GDDR5 SDRAM
- Board GPU: Intel UHD Graphics 630
- CPU: Intel Core i7-9750H - 2.60 GHz, 12 cores
- RAM: 32GB DDR4 SDRAM
- Sound processor: Realtek(R) Audio - 2W Stereo Speaker
- Audio hardware ID: HD Audio\FUNC_01&VEN_10EC&DEV_1220&SUBSYS_1462128D&REV_1001 (don't know if that helps, it's all I could find)
- Mainboard: Mobile Intel HM370
- OS: Windows 11
 
 
THINGS I TESTED
 
1. Audio Troubleshooter:
In the Windows search bar, I typed "Troubleshoot audio" and clicked on "Playing Audio - fix and find problems with playing sound." In the list, I clicked on the device I want to resolve the issue with. I tried to troubleshoot three different devices:
 
- Speaker - Realtek Audio Processor
- Bluetooth Buds
- External USB audio card
 
Here I used both options with and without audio enhancements and ran the Realtek one manually once as well. No results.
 
In all variants of the troubleshooter, it tells me "Problems found - Audio services not responding - Not fixed" and can't do anything about it aside from sending feedback.
 
 
 
2. Services Panel:
I opened up the services by clicking Windows + R and writing out "services.msc," confirmed it with "OK." Here I checked if the services "Realtek Audio Universal Services," "RPC," "Windows Audio," and "Windows Audio Endpoint Builder" were running and set to automatic startup correctly. Of course, they were, or I wouldn't be here asking stupid questions... :p
 
Here I tested restarting the services and changing the Log On permissions and nothing.
 
 
3. Update in the Device Manager and rolling back updates of drivers:
 
Solution a)
First of all I checked if there were any problems or devices not working in the manager list by opening the device manager: Start button right-click > Device Manager. Easy peasy, and no yellow warning signs whatsoever. So far so good. I also checked for hardware changes under the "Action" tab just to be sure.
 
In the list under "Sound, video, and game controllers" as well as "Audio inputs and outputs", I right-clicked on all devices singularly and selected "Update driver." No luck. So I went back into the manager, right-clicked on all devices one by one again, and used "Roll Back Drivers." Nothing again.
 
Solution b)
Under Settings > Update & Security > Check for updates. Here I installed all pending updates, including optional ones just to be safe. There's still no sound. I do not feel safe.
 
 
4. Manually installed drivers:
I once again went into the device manager (look up point 3a on how) and uninstalled everything audio-related by right-clicking and uninstalling all devices manually. When finished, I googled the driver list of my laptop device, went to the official factory pages, and downloaded the generic Microsoft drivers.
 
Afterwards, I went through the installation processes on-screen of the Realtek(R) installer, and it went smoothly. Aside from not producing any sound whatsoever, that is. So I uninstalled them again and tried the generic ones, and no luck again once more.
 

 


5. CCleaner:
After trying the manual process, I went out of my way using a third-party program. Personally, I don't like the idea; I think those are outdated solutions and don't bring anything to the table that Windows 11 hasn't natively already. BUT, I'm desperate, so give me a break, please!^^'
 
The Professional package of CCleaner comes with a "Driver Update" tab. After re-re-reinstalling the correct newest driver from the factory list, oh wonder! There were 62 up-to-date drivers of 62. If you are using this desperate move and that shouldn't be the case, just click on scan again, let it do what it does, and then click on "update all."
 
(There are for sure other 3re party options, and this is a premium one, on top but it's the program I was the most familiar with.)
 
Now click on "Fix problems" > select "Sound" > select your driver (in my case the "Realtek(R) Audio") > click on the blue button "Revert selected drivers" and pray. My prayers were not answered.
 
 
 
6. Check Sound Settings:
This should have been step one really... 🤷 Anyway...
 
I opened the option panel by simply right-clicking on the sound icon in the taskbar > sound setting. Here I ensure the correct playback device was set as default, changed the volumes, enabled/disabled enhancements, and so on.
 
Btw, in the taskbar sound menu right of the volume bar, you'll find a device symbol - standard being your speakers normally. By clicking on it, you can change the device. Always check that your devices are plugged in correctly or connected correctly in the Bluetooth device list and if the device you want to test is actually selected.
 
In my case, it was, but maybe my suffering can help someone else at least.
 
 
 
7. Restart in Safe Mode:
By holding shift while clicking on "Restart" and then holding F4 while the machine was booting, I entered in the Recovery Mode. In the option screen, I went with Troubleshoot > Advanced Options > Startup setting > Restart > 4) Enable Safe Mode.
 
Not even here a sound aside from my spinning fans.
 
- - - 
 
I, for sure, tested other solutions out, but I can't even remember them honestly. Absolute desperation!
 
PS.: When I run the command "DxDiag," it gives me an error "Problem getting extra sound infos."
PPS.: Sorry for the long wall of text, but I wanted to give you all the steps I tried already, and those were a lot how you can see!
 
 
 
I NEED YOUR HELP!
So now what? What else could it be? What can I do to solve this issue?! HELP! 🥲
PPPS.: I'm pretty new here, so I hope this is the correct section or such questions and descriptions in first place. If not, let me know! Thank you for your patience!
 

0 Replies