Widgets don't work

Occasional Contributor

I've just installed Windows 11 and it's so annoying. Messenger and WhatsApp apps do not work (that's a topic for another thread) and widgets work only if I disable the display driver and then turn it on again. Which wouldn't be a problem, except that I have to repeat it every single time I start the computer.

13 Replies

@tatianalarina

Resetting the apps is faster, but repair will retain the App's data (it's really up to you.)

 

Reset:

1.) Start Powershell -> Start Menu -> Run -> taskmgr -> File -> Run new Task -> %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -> Select "Create this task with administrative privileges." -> Click OK.

Set-ExecutionPolicy -ExecutionPolicy Bypass -Scope LocalMachine -Force
Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"};
Get-AppxPackage | Reset-AppxPackage;

Reset / Repair Apps:

1.) Settings -> System -> Other troubleshooters -> Windows Store Apps (Run)

2.) Settings -> Apps -> Default Apps -> Scroll To Bottom (Reset Default Apps)

3.) Settings -> Apps -> Apps & Features -> <Insert App Name Here> -> 3 Verticle Dots On The Right Side Of The Pane -> Advanced Options -> Repair

 

@tatianalarina 

This is if you ONLY want to reinstall and reset Widgets and nothing else (in Powershell)

Set-ExecutionPolicy -ExecutionPolicy Bypass -Scope LocalMachine -Force
Get-AppxPackage -allusers MicrosoftWindows.Client.WebExperience | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"};
Get-AppxPackage -allusers MicrosoftWindows.Client.WebExperience | Reset-AppxPackage;

You can get a full list of the app names using this command...

Get-AppxPackage | Sort Name | Format-Table Name, InstallLocation

"System apps installed with the Windows client OS" -> https://docs.microsoft.com/en-us/windows/application-management/system-apps-windows-client-os

"Troubleshooting packaging, deployment, and query of Windows apps" -> https://docs.microsoft.com/en-us/windows/win32/appxpkg/troubleshooting

"Microsoft Store Apps fail to start if default registry or file permissions modified" -> https://docs.microsoft.com/en-us/troubleshoot/windows-client/shell-experience/microsoft-store-apps-f...

 

For the time being, I want to focus just on fixing widgets. Unfortunately neither of your solutions worked. When I tried the latter, i.e. just reinstall widgets, it seemed to run smoothly, but it didn't do anything. When I tried the former, i.e. resetting all apps, it generated a long error log (I can send it or post it if you want) and still didn't help.

@tatianalarina

TRIPLE EDIT: Default Service setup: 64-bit Windows 10/11 Workstation without modifying protected processes (Windows Feature Experience Pack)

./sc config AxInstSV start= demand;./sc config AJRouter start= demand;./sc config AppReadiness start= demand;
./sc config Appinfo start= demand;./sc config ALG start= demand;./sc config AppMgmt start= demand;
./sc config tzautoupdate start= disabled;./sc config BITS start= demand;./sc config bthserv start= demand;
./sc config CertPropSvc start= demand;./sc config KeyIso start= demand;./sc config EventSystem start= auto;
./sc config COMSysApp start= demand;./sc config Browser start= disabled;./sc config CDPSvc start= auto;
./sc config DiagTrack start= auto;./sc config VaultSvc start= demand;./sc config CryptSvc start= auto;
./sc config DsSvc start= demand;./sc config DcpSvc start= demand;./sc config DeviceAssociationService start= demand;
./sc config DeviceInstall start= demand;./sc config DmEnrollmentSvc start= demand;./sc config DsmSvc start= demand;
./sc config DevQueryBroker start= demand;./sc config Dhcp start= auto;./sc config DPS start= auto;
./sc config WdiServiceHost start= demand;./sc config WdiSystemHost start= demand;./sc config TrkWks start= auto;
./sc config MSDTC start= demand;./sc config dmwappushservice start= demand;./sc config MapsBroker start= auto;
./sc config EFS start= demand;./sc config EapHost start= demand;./sc config fdPHost start= demand;
./sc config FDResPub start= demand;./sc config lfsvc start= demand;./sc config hidserv start= demand;
./sc config HvHost start= demand;./sc config vmickvpexchange start= demand;./sc config vmicguestinterface start= demand;
./sc config vmicshutdown start= demand;./sc config vmicheartbeat start= demand;./sc config vmicvmsession start= demand;
./sc config vmicrdv start= demand;./sc config vmictimesync start= demand;./sc config vmicvss start= demand;
./sc config IKEEXT start= demand;./sc config UI0Detect start= demand;./sc config SharedAccess start= demand;
./sc config iphlpsvc start= auto;./sc config PolicyAgent start= demand;./sc config KPSSVC start= demand;
./sc config KtmRm start= demand;./sc config lltdsvc start= demand;./sc config diagnosticshub.standardcollector.service start= demand;
./sc config wlidsvc start= demand;./sc config AppVClient start= disabled;./sc config MSiSCSI start= demand;
./sc config swprv start= demand;./sc config smphost start= demand;./sc config NetTcpPortSharing start= disabled;
./sc config Netlogon start= demand;./sc config NcbService start= demand;./sc config Netman start= demand;
./sc config NcaSvc start= demand;./sc config netprofm start= demand;./sc config NlaSvc start= auto;
./sc config NetSetupSvc start= demand;./sc config nsi start= auto;./sc config CscService start= disabled;
./sc config defragsvc start= demand;./sc config PerfHost start= demand;./sc config pla start= demand;
./sc config PhoneSvc start= demand;./sc config PlugPlay start= demand;./sc config WPDBusEnum start= demand;
./sc config Power start= auto;./sc config Spooler start= auto;./sc config PrintNotify start= demand;
./sc config wercplsupport start= demand;./sc config PcaSvc start= auto;./sc config QWAVE start= demand;
./sc config RmSvc start= demand;./sc config RasAuto start= demand;./sc config RasMan start= demand;
./sc config SessionEnv start= demand;./sc config TermService start= demand;./sc config UmRdpService start= demand;
./sc config RpcLocator start= demand;./sc config RemoteRegistry start= auto;./sc config RSoPProv start= demand;
./sc config RemoteAccess start= disabled;./sc config seclogon start= demand;./sc config SstpSvc start= demand;
./sc config SamSs start= auto;./sc config SensorDataService start= demand;./sc config SensrSvc start= demand;
./sc config SensorService start= demand;./sc config LanmanServer start= disabled;./sc config ShellHWDetection start= auto;
./sc config SCardSvr start= disabled;./sc config ScDeviceEnum start= demand;./sc config SCPolicySvc start= demand;
./sc config SNMPTRAP start= demand;./sc config sacsvr start= demand;./sc config svsvc start= demand;
./sc config SSDPSRV start= demand;./sc config WiaRpc start= demand;./sc config StorSvc start= demand;
./sc config TieringEngineService start= demand;./sc config SysMain start= demand;./sc config SENS start= auto;
./sc config lmhosts start= demand;./sc config TapiSrv start= demand;./sc config Themes start= auto;
./sc config tiledatamodelsvc start= auto;./sc config TabletInputService start= demand;./sc config UsoSvc start= demand;
./sc config upnphost start= demand;./sc config UALSVC start= auto;./sc config UevAgentService start= disabled;
./sc config UserManager start= auto;./sc config ProfSvc start= auto;./sc config vds start= demand;
./sc config VSS start= demand;./sc config WalletService start= demand;./sc config Audiosrv start= auto;
./sc config AudioEndpointBuilder start= auto;./sc config WbioSrvc start= demand;./sc config FrameServer start= demand;
./sc config Wcmsvc start= auto;./sc config WEPHOSTSVC start= demand;./sc config Wecsvc start= demand;
./sc config EventLog start= auto;./sc config FontCache start= auto;./sc config stisvc start= demand;
./sc config wisvc start= demand;./sc config LicenseManager start= demand;./sc config Winmgmt start= auto;
./sc config icssvc start= demand;./sc config TrustedInstaller start= demand;./sc config WpnService start= auto;
./sc config WinRM start= disabled;./sc config WSearch start= auto;./sc config W32Time start= auto;
./sc config wuauserv start= demand;./sc config dot3svc start= demand;./sc config wmiApSrv start= demand;
./sc config LanmanWorkstation start= auto;./sc config XblAuthManager start= demand;./sc config XblGameSave start= demand;
./sc config BcastDVRUserService start= demand;./sc config BluetoothUserService start= demand;./sc config CaptureService start= demand;
./sc config CDPUserSvc start= disabled;./sc config DevicePickerUserSvc start= demand;./sc config DevicesFlowUserSvc start= demand;
./sc config MessagingService start= demand;./sc config OneSyncSvc start= delayed-auto;./sc config PimIndexMaintenanceSvc start= disabled;
./sc config PrintWorkflowUserSvc start= demand;./sc config UnistoreSvc start= demand;
./sc config UserDataSvc start= demand;./sc config WpnUserService start= demand;

 

 

@tatianalarina 

This *should* work on every consumer-grade SKU for Windows 10 / 11 (although the services need to be cold started like this.) You would have to restart your PC to get full functionality (with services) after executing both Powershell scripts (basically have to copy-paste them.)

 

./net start EventLog;./net start UsoSvc;./net start wuauserv;./net start AppXSvc;./net start BITS;./net start BFE;./net start MpsSvc;
./net start AppXSvc;./net start AppReadiness;./net start DcpSvc;./net start DevQueryBroker;./net start MapsBroker;./net start lfsvc;
./net start NgcSvc;./net start NcbService;./net start PhoneSvc;./net start ScDeviceEnum;./net start SystemEventsBroker;./net start TimeBrokerSvc;
./net start UserDataSvc;./net start UnistoreSvc;./net start ProfSvc;

 

 

 

@tatianalarina 

You need this service below to be working at the absolute minimum to be able to install the apps (to run them you also need practically ALL the other apps set up as well, due to many of them being service dependencies / sub-components of another service.) Even if you were only to configure this one service, you need to configure the other services to be able to USE the apps. A lot of people ignore this. You can edit that list as well (based on recommendations on this page and also the default template in the Microsoft Security Compliance Toolkit 1.0, and also your personal needs.)

 

"AppX Deployment Service (AppXSVC)" -> https://docs.microsoft.com/en-us/windows-server/security/windows-services/security-guidelines-for-di...

 

"Per-user services in Windows 10 and Windows Server" -> https://docs.microsoft.com/en-us/windows/application-management/per-user-services-in-windows

 

I ran in Power Shell both scripts you posted, restarting the computer after each of them. Still no luck. As for your last answer, I think you're overrating my computer expertise. Where do I find these services and what should I do with them? I can only tell you that there are two instances of wsappx in my Task Manager and both of them seem to be running fine.

@tatianalarina 

At the minimum, you're supposed to be able to install / remove apps with ease, utilizing Powershell, so your operating system image is most likely corrupt (Follow these steps on this link here.)

 

https://techcommunity.microsoft.com/t5/windows-11/windows-11-explorer-and-taskbar-issues/m-p/2906811...

@tatianalarina 

Even after following that step, you also have to check for missing Access Control Entries (a corrupted root DACL / discretionary access control list, often can be the cause with a major revision update.) These are all issues you would see on Windows 10, not just Windows 11 btw...

 

"Microsoft Store Apps fail to start if default registry or file permissions modified: Fix file system permissions that's changed manually" -> https://docs.microsoft.com/en-us/troubleshoot/windows-client/shell-experience/microsoft-store-apps-f...

 

 

@tatianalarina 

"As for your last answer, I think you're overrating my computer expertise. Where do I find these services and what should I do with them?"

 

I posted the links so you could read about the scripts to see what the names mean (so you can edit them if you are interested.) All you have to do is just copy paste the scripts (one big blob of text,) into Powershell.

 

The semicolon placed at the end of each command, is so you can copy paste the ENTIRE text all at once, and then hit enter (two step process practically, unless the text only partially fits, and then you have to copy paste the rest.) That script above could be slow because it's restoring the ENTIRE image from an offline ISO image. You have to make sure to select the index based on your edition of Windows (or it will restore the wrong one, and you have to start the process OVER again.)

 

I went through this whole process to upgrade one of my computers, but I have it entirely automated at this point (aside from needing my service configuration script to match the Microsoft Security Compliance Toolkit 1.x templates, as well as the official NIST checklists for Windows Server 2019/2022. It's not the most perfect script, it doesn't harden the Operating System services, though I could make it do that, but it does return it to a default state.)

 

@tatianalarina 

If you want to actually list the services in powershell, so you can view the settings in the registry editor...

dir "HKLM:\SYSTEM\CurrentControlSet\Services" | Format-Table -Property Name

The script just speeds up the process of having to edit a ridiculous amount of keys all at once (it does not restore damaged entries or fix missing service entries.) If you just upgraded, they should already exist in the registry anyways.

 

I could create a script that refreshes the entire registry hive, but I haven't thought about doing that at this point (would be slow, would have to be quite selective as to not destroy anyone's configuration.) Process protection (PPL) typically is good enough to stop any modification to those keys, unless someone intentionally disables it, along with the ELAM driver (Early Launch Anti-Malware.) It couldn't actually get that bad, unless someone deliberately went in and deleted a lot of critical registry entries and files. It's very difficult to achieve this even with administrator privileges (DISM / SFC can restore it in almost all cases. It's a very lengthy process to disable all the file protection features I mean. It's almost illogical to assume that that's what happened in this case / scenario.)

 

@Mousefluff Again, I think you're overestimating my computer expertise :) I tried running the procedure of restoring the system from the image file, but I ended up with the following message:
"cmdlet Add-AppxPackage at command pipeline position 1
Supply values for the following parameters:"
And I had no idea what to do. Since my version of Windows is Windows Pro, I tried typing 6, but that didn't do anything.

@tatianalarina 

My list shows nearly every possible outcome, regardless of where you get stuck, given the myriad of possibilities (so you have to copy paste all the text from one particular box.) It doesn't matter how it resolves itself, or if it resolves itself early on due to a mistake you made previously being corrected (not figuring out how to select the entire text box, use the scroll bars, CTRL+C to copy, CTRL+V to paste, etc.)

 

Eventually it will resolve itself if you follow all the instructions. It doesn't matter if you solve it part way through (you don't have to complete all the steps if you have it solved part-way through.) That's actually good. I deliberately wrote it so it's workable no matter what the outcome (sequential order too.) You just have to inch your way through this one step at a time. Of course you can also look up these instructions to see what they do. It's very good to learn what each step is for. It doesn't matter how long it takes you either. Go at your own pace.