Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Snip & sketch freezes windows

Copper Contributor

I've set my print screen button to start snip & sketch instead of just taking a screenshot of everything. It worked like a charm for quite a while but then all of a sudden whenever I opened it and selected what I want to take a screenshot of it freezes my whole desktop except my mouse for about 10 seconds. It doesn't actually freeze the pc, I can still hear a song I'm playing, or sounds from programs, but I can't do anything except move my mouse. I don't have any third party antivirus installed except MalwareBytes but I don't have it running and it still happens.

18 Replies
Which version of Windows 10 are you using?
I used to have 1809 and then I upgraded to 1903 but I'm pretty sure the problem didn't happen right after I upgraded.
Could it be because od the upgrade?
It is possible yeah, try updating to latest version, 1909

@HotCakeXI upgraded  to 1909 and have the latest update, but the problem still persists. It works fine with a regular print scree (it doesn't freeze), and I also tried turning off windows defender to see if it was checking the screenshots for a virus and it didn't change anything.

Strange, I would attempt a clean install of the Windows 10 to fix the issue

@HotCakeXyeah was thinking the same...just had some hope there would be an easier fix


Thanks for the help ^^

No problem, wish i could be more helpful tho :)

p.s don't forget to backup important stuff on C drive ;)

@Lionile @HotCakeX I had the same issue and the fix was to change the version of the NVIDIA video driver that was installed. See

Thanks, I don't experience it anymore on the fast ring though (19582)
hi there ,,

I have the same problem. but what if I don't use NVIDIA? whether the cause is the same: VGA Driver ??

@edhan2195 You may want to follow up on Twitter, replying to my tweet link above. Jen will probably pipe in with a useful tip.

@Lionile  This just happened to me as well this morning. I was taking screen caps fine all day yesterday, then I boot up this morning and try to take a screen cap and.....the selection won't go away. It just stays up on screen forever and makes the display non interactive. I can't back out of the screen cap, I can't alt+tab to go to another program, the windows button doesn't work. I try to call up the task manager with ctrl+alt+delete, and the blue screen pops up with the options to Lock, restart, log out or task Manager, but when I click on task manager it just brings me to the screen cap. The only way for me to get out of it is to alt+f4, and when I do, the screen cap goes away and shows me my other open programs and the task manager that were stuck beneath it.

I am a moderator and help desk member of a Discord channel for a Minecraft Rendering Tool called Chunky, so being able to take screenshots to guide and direct people to solutions to their problems is ESSENTIAL. As it is now, I had to take a photo with my phone to show what I mean, since I can't take a screenshot to show my screenshot problem. *sigh* I used the freeform selection for this one. The selection stays up and won't save, keeping my laptop locked in screenshot mode indefinitely until I alt+f4 out.



@Lionile I'm struggling with something similar - once i snip an image and go to mark it up (sketch) the sketching process hangs like crazy - making it very hard to edit or erase or switch tools while marking something up... it hangs over an over again - it eventually will "catch up" but it is painful...


I have noticed this issue plagues my upper mid-range custom PC more than my pre-built laptop - differences are as follows (both running same version of windows 19041):


Laptop: Intel I7 10510U_UMA processor w/ integrated intel graphics / 16g ddr4 & nvme m.2 x3.0 ssd

Desktop: is Ryzen7 3700x w/ 32g ddr4@3200 & ASUS ROG STRIX RX 5700 OC running on an nvme m.2 x3.0 ssd 

Wondering if this has something to do with hardware acceleration - i've had issues with other AMD GPUs in the past but not with this one elsewhere...


Check for updates in Microsoft Store and may be there is new update for Snip & Sketch app and if that is the case make sure update it.

Also update graphic card driver.

Check for Windows Update too.

In case problem persist, open start and search for feedback and open Feedback Hub app and report this issue.

Facing the same with Windows 10 20H2 in a non-persistent VDI using Nvidia T4 Grid Graphics.

Im opening the App, can do my Snip and once I try to draw on the snip it crashes and eventually comes back after a few minutes.

please file a feedback for it in feedback hub,
and then check Windows store for app updates for snip & sketch
Thanks to redditor bignoselawnchair for pointing out there's a reset function: Settings > Apps & features > Snip & Sketch > Advanced options > Reset. Worked for me!

I also had this problem after updating to 20H2 for both an in place upgrade from 1909 and a fresh install of 20H2. For me it turned out to be a Group Policy causing the problem.

I posted this answer here originally "Windows 10 20H2 Snip & Sketch problem - Microsoft Community"


I don't know if this will apply for everyone, but I also had this problem and tried all the sfc, dism, and add-appxpackage registration fixes to no avail.

What turned out to fix it for me was setting a group policy called "Download missing COM components" to "Not Configured". I previously had it enabled.

It is available under "Computer Configuration\Administrative Templates\System". In my case, this was an AD environment and I had access to fix this at the network level, but on an individual computer with admin rights running win 10 pro or a higher version, you should theoretically be able to set his using gpedit.msc 

Also in theory you could look in the registry for 

HKCU\Software\Policies\Microsoft\Windows\App Management!COMClassStore


HKLM\Software\Policies\Microsoft\Windows\App Management!COMClassStore

and delete those keys if they exist (backing them up first by exporting the keys of course)

Hope this helps somebody. This also fixed problems I had with the Your Phone app auto closing.


I imagine setting this to disabled in group policy or a Dword of '0' in the registry may also work (that's untested though, I don't know exactly what it looks like in the registry), but sometimes that causes unexpected behavior vs. Not Configured. I think it's just an old policy (came around for Windows 2000) and it causes an incompatibility with the newest version.