Error Message: Could not complete that action Name cannot be blank

%3CLINGO-SUB%20id%3D%22lingo-sub-2215581%22%20slang%3D%22en-US%22%3EError%20Message%3A%20Could%20not%20complete%20that%20action%20Name%20cannot%20be%20blank%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2215581%22%20slang%3D%22en-US%22%3E%3CP%3EI%20created%20a%20new%20page%20and%20within%20that%20page%20I%20am%20embedding%20an%20iframe%20only%20using%20widht%3Dx%20height%3Dx%20and%20then%20the%20URL.%20When%20I%20go%20to%20publish%20the%20page%2C%20this%20error%20message%20shows%20up.%20Any%20help%20is%20much%20appreciated.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Error.PNG%22%20style%3D%22width%3A%20306px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F264617i633D012C345CEEF2%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Error.PNG%22%20alt%3D%22Error.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2215581%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2587981%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Message%3A%20Could%20not%20complete%20that%20action%20Name%20cannot%20be%20blank%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2587981%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F976274%22%20target%3D%22_blank%22%3E%40dan8090%3C%2FA%3E%26nbsp%3BI%20ran%20into%20this%20error%20message%20as%20well%20in%20a%20slightly%20different%20scenario%20but%20this%20is%20how%20I%20was%20able%20to%20resolve%20it.%20I%20am%20curious%20if%20this%20helps%20you%20if%20you%20get%20to%20try%20it.%26nbsp%3B%20I%20looked%20all%20over%20the%20place%20for%20what%20%22Name%20cannot%20be%20blank%22%20could%20mean.%26nbsp%3B%20Finally%2C%20while%20reviewing%20Site%20Pages%20for%20that%20Site%2C%20I%20landed%20on%20the%20Page%20Properties%20and%20the%20%22Title%22%20(not%20a%20required%20field)%20below%20the%20select%20URL%20was%20empty.%20I%20added%20a%20matching%20Title%20to%20the%20page%20and%20saved.%26nbsp%3B%20When%20I%20went%20to%20republish%20the%20page%20with%20my%20latest%20edits%20-%20I%20no%20longer%20encountered%20this%20frustrating%20and%20vague%20error.%26nbsp%3B%20It%20has%20been%20working%20for%20me%20since!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I created a new page and within that page I am embedding an iframe only using widht=x height=x and then the URL. When I go to publish the page, this error message shows up. Any help is much appreciated.

Error.PNG

2 Replies

@dan8090 I ran into this error message as well in a slightly different scenario but this is how I was able to resolve it. I am curious if this helps you if you get to try it.  I looked all over the place for what "Name cannot be blank" could mean.  Finally, while reviewing Site Pages for that Site, I landed on the Page Properties and the "Title" (not a required field) below the select URL was empty. I added a matching Title to the page and saved.  When I went to republish the page with my latest edits - I no longer encountered this frustrating and vague error.  It has been working for me since!

E-KAY, Thank you for posting this. You saved me tons of time!