One Drive for business stopped working on Windows 7

New Contributor

Dear Sirs,

Looks like One Drive application stopped working on Windows 7. Logging to company account is not possible and I receive error 0x8004de40

Server error: NoTeamSitePermissions

Received 403 while calling TeamSite Permissions API

Status code: 'Forbidden'

Problem is the same on many machines.

Please let me know if this is only temporary problem or One Drive service will no longer be available on Windows 7.


19 Replies



Hi Marek,


I also have this same issue. Since Thursday last week I haven't been able to get into the OneDrive app. Any advice would be greatly appreciate from MS!


Still not a word from MS. They don't care about customers at all.



Same here, in some cases, we are running Windows 7 x86 Pro and have been contacted by these users to say they get the same error message. We tried an uninstall and reinstall, did windows updates and closed teams and managed to get logged in. It was short lived, a few hours later it dropped and now it's not working and the same method fails.


How are you checking the status is forbidden?

@KyotoUK @MarekCmikiewicz 

Hi both,


I managed to fix mine shortly after I made this post. Hopefully it works for you.


So, it seems that Microsoft accidentally removed support for TLS 1.0 and 1.1 earlier than communicated. While they fixed it, some updates don't seem to have gone through and so they launched a fix for TLS 1.2 that works. My process, in case you get it elsewhere is:
1: Uninstall Windows Update KB3140245
2: Download and install Windows Update KB3140245 from here:
3: Restart the machine
5: Make following registry changes (I couldn't find TLS 1.1 or 1.2 in either location so changed the same DWORD key under the SSL 2.0 folder in the same location to 0):
For TLS 1.1

Registry location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client
DWORD name: DisabledByDefault
DWORD value: 0

For TLS 1.2

Registry location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client
DWORD name: DisabledByDefault
DWORD value: 0

6: Restart machine
7: Try logging in again



Thanks for this, we will check it early next week and let you know how it goes

The solution doesn't work. I have all TLS (1.0, 1.1, 1.2) enabled and OneDrive still doesn't work. Are you planning to fix this?
clutching at straws, i'll give it a go.

Our Connectwise has a script that should run to force TLS 1.2 but one of the users had a new machine this week so it might be that the script hasn't run yet.

Only 2% of our Win7 users have reported the issue so far, I'll update once I know more.

I carried out some tests based on what @EpicTriffid wrote on Apr 16th.
The outcome is that the only thing which is necessary for One Drive to work again in Windows 7 is to install Easy Fix from this location
It is not necessary to uninstall KB3140245. It is not needed and not safe to change the value in registry under SSL 2.0.
Just Easy Fix which enables TLS 1.1 and TLS 1.2 as default secure protocols in WinHTTP, then reboot and THAT'S IT.
Works like a charm :)



I also had machines without KB3140245 initially installed. In those cases it was necessary to install KB and then proceed to Easy Fix.

Quick update,
The two issues we had with Win7 x86 were new laptops that hadn't fired the auto script off. I edited the registry with the fix it tool linked above and all is working now.

Strangely had similar issues with a few android mobiles but a quick update of the app sorted these out.



It seems this page is being cached by Google so am adding to the solution here.


I have just had this same issue and what is described above is part of the process. You also need to consider this page where it explains the steps to control which protocols are permitted within Windows 7: -


Once you run the Easy Fix Tool, you would want to go back and change the entry in both paths: -

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp\DefaultSecureProtocols


HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp\DefaultSecureProtocols





As is said in the KB: -


By default in Windows, this value is 0x0A0 to enable SSL 3.0 and TLS 1.0 for WinHTTP. The above example keeps these defaults, and also enables TLS 1.1 and TLS 1.2 for WinHTTP. This configuration ensures that the change doesn't break any other application that might still rely on SSL 3.0 or TLS 1.0. You can use the value of 0xA00 to only enable TLS 1.1 and TLS 1.2.




I found an easy workaround changing OneDrive Web to classic view.

This enables both OneDrive Sync and OneNote Sync that stopped also.


OneDrive view changes back to the new view automatically, so you have to manually change it.

There is an option to set the classic view as default, but it doesn't seems to work.


With this trick we can wait until a stable solution is found.




I have downloaded and run the fix (  ) and this solved my OneDrive 0x8004de40 connect probleem on my Windows 7 home PC. Thanx!

@popolou Thank you this solved my issue (without having to run the "easyfix" that did not want get installed on my computer.

I had the same error 0x8004de40 only with OneDrive business account (on Win7pro). (I had checked already other things too: running network list service, KB3140245, TLS1.2 checked).
Using just "Easy Fix" did the trick :) , shame that google won't put this topic (& solution) in top results.
Thanks @MarekCmikiewicz and @EpicTriffid for figuring this out.

@MarekCmikiewiczI solved by removing onedrive program and then installing it again

Had to uninstall update, then install updated update, then apply Easy Fix: everything works! Thank you!
1. Update Windows; 2. Reinstall Onedrive; 3. Follow other opinions from this thread. Finally, I already fixed this error. Thanks!
Thanks @nvtrungvn and @GeertsJ, my Onedrive is working again on Windows 7. Great job!

Yes, finally, the dead OneDrive for business on Windows 7 back to work

simple two  steps: no need to run "easytool"

1. Install the Windows Update KB3140245

2. change registry 
"[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]


you can copy and paste to a reg file, one click to inject your registry 

Reboot, done


it also resolves my PowerShell connection issues on Windows 7.

Special credit to @popolou to make it possible  resolve the issue