'Copy Link' for Folder/Files does not work in Teams

%3CLINGO-SUB%20id%3D%22lingo-sub-1419976%22%20slang%3D%22en-US%22%3E'Copy%20Link'%20for%20Folder%2FFiles%20does%20not%20work%20in%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1419976%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20you%20access%20a%20document%20library%20using%20the%20website%2FSharePoint%20tab%20and%20click%20on%20'copy%20Link'%20the%20dialog%20opens%20up%20and%20has%20a%20spinning%20circle%20constantly%2C%20doesn't%20load.%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Teams-CopyLink.gif%22%20style%3D%22width%3A%20567px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F194717i1604BC0196471EAA%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22Teams-CopyLink.gif%22%20alt%3D%22Teams-CopyLink.gif%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1419976%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1420455%22%20slang%3D%22en-US%22%3ERe%3A%20'Copy%20Link'%20for%20Folder%2FFiles%20does%20not%20work%20in%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1420455%22%20slang%3D%22en-US%22%3EThat's%20totally%20unexpected...have%20you%20tried%20to%20access%20the%20document%20library%20on%20different%20browsers%20and%2For%20using%20an%20inprivate%20session%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1420483%22%20slang%3D%22en-US%22%3ERe%3A%20'Copy%20Link'%20for%20Folder%2FFiles%20does%20not%20work%20in%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1420483%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60%22%20target%3D%22_blank%22%3E%40Juan%20Carlos%20Gonz%C3%A1lez%20Mart%C3%ADn%3C%2FA%3E%26nbsp%3BSo%20the%20above%20is%20using%20the%20desktop%20application%20and%20have%20tried%20it%20in%20a%20browser%20too%20(Edge%20Chromium).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20clarify%2C%20this%20is%20a%20SharePoint%20webpage%2C%20with%20a%20quick%20link%20to%20a%20document%20library%20then%20viewing%20the%20document%20library%20that%20way.%20Is%20it%20a%20limitation%20of%20viewing%20it%20via%20a%20'website'%20tab%20in%20Teams%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

When you access a document library using the website/SharePoint tab and click on 'copy Link' the dialog opens up and has a spinning circle constantly, doesn't load.Teams-CopyLink.gif

 

4 Replies
That's totally unexpected...have you tried to access the document library on different browsers and/or using an inprivate session?

@Juan Carlos González Martín So the above is using the desktop application and have tried it in a browser too (Edge Chromium).

 

To clarify, this is a SharePoint webpage, with a quick link to a document library then viewing the document library that way. Is it a limitation of viewing it via a 'website' tab in Teams? 

@Henry Edwards @Juan Carlos González Martín Did you ever find a resolution (or cause) for this? I have a user experiencing this issue for a Team/SharePoint library.

@JamesKearns We started seeing this problem on the week starting 5th July. There appears to be an issue obtaining sharing links from SharePoint Online via the Document Library tab in Teams. Our workaround was to swap out the Document Library tabs for Website tabs. After that the Copy Link functionality worked as expected.