Dev Channel update to 110.0.1587.6 is live


1/10/23: Hi Insiders! Thanks for bringing the update issue to our attention. We've released the Dev build 110.0.1587.6 today, which fixes the problem. Thank you again for your help and patience.


Hello Insiders! We are excited to kick off the new year with the release of Dev build 110.0.1587.1 to the Dev channel to all platforms except Mac. Mac users will receive the Dev build at a later date. This build includes a range of fixes, new policies, new API, and new features for Android. For more details on the changes, check out the highlights below. Additionally, we got a new blog post about WebView2 Runtine below.


Delivering Microsoft Edge WebView2 Runtime to managed Windows 10 devices - Microsoft Edge Blog


Added features:  

  • Android:
    • New Ad blocker feature now allows you to block ads with a long press.
    • Now you can change the wallpaper on the New Tab Page.
  • WebView2:
    • Added experimental Permission management API.
  • Enterprise:
    • New policy (Note: Updates to documentation and administrative templates may not have occurred yet)
      • Print preview sticky setting policy.
      • Touch Mode policy.
      • Policy for disabling Immersive Reader’s Grammar Tools.



Improved reliability:  

  • Fixed browser crash related to out of memory condition when visiting certain shopping sites.
  • Fixed browser crash related to invalid access in a vector on webpages. 
  • Fixed browser crash related to McAfee Drive Encryption.
  • Fixed browser crash by disabling WebAuthn autofill functionality due to issue.
  • macOS:
    • Fixed browser crash when activating Fullscreen mode.
  • iOS:
    • Fixed browser crash when using the translator.
    • Fixed browser crash when viewing New Tab Page.
  • Android:
    • Fixed browser crash when downloading a file.
  • Enterprise:
    • Fixed browser crash due to Conditional Access workflow retries too many times when remediation fails on Android.


Changed behavior: 

  • Fixed URLs not being added to the allow list when the flyout is dismissed on Website Typos protection.
  • Fixed favicon not loading properly when installing a site as an app.
  • Prevented browser window from staying open if it only contains a blank tab opened by ClickOnce interaction.
  • Removed recently closed suggestions from the address bar so they will now persist instead only on the current browser session. 
  • Fixed can’t expand or collapse Tab group while the Tab group menu is showing.
  • ALT + S shortcut no longer triggers the screenshot functionality.
  • Workspace sharing prompt will now close when clicking outside of the UI.
  • Fixed Visual search button appearing outside the image when scrolling.
  • iOS:
    • Fixed can’t swipe up on New Tab Page.
    • Fixed page getting squished when using Split View on iPad.
    • Fixed automatic profile switching issue where it keeps switching back to a Work profile from a personal profile.
    • Fixed the issue when trying to sign in from Add account displaying a circle.
  • Android:
    • Fixed Add current page to Favorites button not showing after editing a favorite. 
  • WebView2:
    • WebResourceResquested API promoted from experimental stage to public.  
    • Fixed DPI mismatch.
    • Disabled native Windows Share option due to not working as expected on HoloLens and in UWP apps.
    • Fixed custom rasterization scale bug. (#2918)
  • Enterprise:
    • Removed the ShadowStackCrashRollbackBehavior policy. 
    • Fixed focus fails to work involving showModalDialog and in IE Mode workflows.
    • Fixed an issue where visiting a URL that is on AllowListUrls policy causes to open a New InPrivate tab to a URL that is not on the AllowList on iOS.



Thanks again for sending us feedback and helping us improve our Insider builds.


Edited (1/10/23): Updated title and added update.

69 Replies
Caught in a restart loop. Edge Dev.

@asdy4 I confirm. Same effect on 2 machines.


same here

@asdy4 @g_keramidas Thanks for the report! We're already aware and working on it. Are you able to install Dev directly from the Edge Insider website? I am unsure if this will resolve y'all or if you have tried, so I wanted to check in just to be sure. I can let the team know the situation either way. :)


Missy Quarry (she/they)
Community Manager - Microsoft Edge
Join us on Twitter, or over on Reddit in r/MicrosoftEdge or r/edge

Have reported it on the feedback icon on Edge. I will wait for a fix from the team before i reinstall. Many Thanks.

@asdy4 I have been able to run the Dev channel after updating manually, it's why I ask y'all to give it a shot. Please try reinstalling from the website so that I can let the team know if that helps or not. :3


Missy Quarry (she/they)
Community Manager - Microsoft Edge
Join us on Twitter, or over on Reddit in r/MicrosoftEdge or r/edge


Even though it's updated, it asks to restart.




I have D/L and installed Edge Dev but still in To finish updating, restart Microsoft Edge. loop, just for info i can still use Edge Dev.



@asdy4 I appreciate you trying it out! I will let the team know that isn't helping y'all. I'll follow back up once I know that the restart loop has been resolved. Thanks again!


Missy Quarry (she/they)
Community Manager - Microsoft Edge
Join us on Twitter, or over on Reddit in r/MicrosoftEdge or r/edge

Downloaded Dev. from the Edge Insider website & manually installed it but I see 'Restart' too.
Same here, manually replace xxx.yyy with new_xxx.yyy in app dir solved the issue.



@Jeffz9527 wrote:
Same here, manually replace xxx.yyy with new_xxx.yyy in app dir solved the issue.

That worked for me too! Thanks!

I uninstalled and reinstalled it has worked this time.
So all good for now.
Many Thanks.

Uninstalling and reinstalling from the Edge Insider website solved it for me as well. I was a bit nervous to do this, but fortunately, all my tabs restored.

i tried installing from the website, same result.



i clicked modify in the windows apps and features, clicked repair. it now shows the correct edge.PNGversion there, but still 1556 in edge itself, with the restart loop.


Is macOS edge canary not updating yet?
Restart loop bug.. already reported as well.. seems like i am not the only one having this issue..

@Tenero We had an issue with Canary builds on the macOS side, but our engineers were able to resolve it. Today, we released a new Canary build (111.0.1603.0) for macOS and other platforms.

1 best response

Accepted Solutions
best response confirmed by MissyQ (Microsoft)

@Ryan Buckwalter To be clear, y'all can just use the browser without updating consistently. It works just fine without the update right now, the issue is simply the browser won't update when you go to update it.


We're still working on pushing out a fix. As stated, we will follow up once we know when the fix is rolled out. Appreciate everyone's patience and diligence keeping us honest! :3


EDIT - 4PM PACIFIC TIME, JAN 6TH: We had hoped we would be able to fix this for y'all by this afternoon, however it is looking like we will roll out the fix on Monday. Again, thanks for everyone's patience!


Missy Quarry (she/they)
Community Manager - Microsoft Edge
Join us on Twitter, or over on Reddit in r/MicrosoftEdge or r/edge

View solution in original post