SOLVED

Dev Channel update to 110.0.1587.6 is live

Microsoft

1/10/23: Hi Insiders! Thanks for bringing the update issue to our attention. We've released the Dev build 110.0.1587.6 today, which fixes the problem. Thank you again for your help and patience.

 

Hello Insiders! We are excited to kick off the new year with the release of Dev build 110.0.1587.1 to the Dev channel to all platforms except Mac. Mac users will receive the Dev build at a later date. This build includes a range of fixes, new policies, new API, and new features for Android. For more details on the changes, check out the highlights below. Additionally, we got a new blog post about WebView2 Runtine below.

 

Delivering Microsoft Edge WebView2 Runtime to managed Windows 10 devices - Microsoft Edge Blog

 

Added features:  

  • Android:
    • New Ad blocker feature now allows you to block ads with a long press.
    • Now you can change the wallpaper on the New Tab Page.
  • WebView2:
    • Added experimental Permission management API.
  • Enterprise:
    • New policy (Note: Updates to documentation and administrative templates may not have occurred yet)
      • Print preview sticky setting policy.
      • Touch Mode policy.
      • Policy for disabling Immersive Reader’s Grammar Tools.

 

 

Improved reliability:  

  • Fixed browser crash related to out of memory condition when visiting certain shopping sites.
  • Fixed browser crash related to invalid access in a vector on webpages. 
  • Fixed browser crash related to McAfee Drive Encryption.
  • Fixed browser crash by disabling WebAuthn autofill functionality due to issue.
  • macOS:
    • Fixed browser crash when activating Fullscreen mode.
  • iOS:
    • Fixed browser crash when using the translator.
    • Fixed browser crash when viewing New Tab Page.
  • Android:
    • Fixed browser crash when downloading a file.
  • Enterprise:
    • Fixed browser crash due to Conditional Access workflow retries too many times when remediation fails on Android.

 

Changed behavior: 

  • Fixed URLs not being added to the allow list when the flyout is dismissed on Website Typos protection.
  • Fixed favicon not loading properly when installing a site as an app.
  • Prevented browser window from staying open if it only contains a blank tab opened by ClickOnce interaction.
  • Removed recently closed suggestions from the address bar so they will now persist instead only on the current browser session. 
  • Fixed can’t expand or collapse Tab group while the Tab group menu is showing.
  • ALT + S shortcut no longer triggers the screenshot functionality.
  • Workspace sharing prompt will now close when clicking outside of the UI.
  • Fixed Visual search button appearing outside the image when scrolling.
  • iOS:
    • Fixed can’t swipe up on New Tab Page.
    • Fixed page getting squished when using Split View on iPad.
    • Fixed automatic profile switching issue where it keeps switching back to a Work profile from a personal profile.
    • Fixed the issue when trying to sign in from Add account displaying a circle.
  • Android:
    • Fixed Add current page to Favorites button not showing after editing a favorite. 
  • WebView2:
    • WebResourceResquested API promoted from experimental stage to public.  
    • Fixed DPI mismatch.
    • Disabled native Windows Share option due to not working as expected on HoloLens and in UWP apps.
    • Fixed custom rasterization scale bug. (#2918)
  • Enterprise:
    • Removed the ShadowStackCrashRollbackBehavior policy. 
    • Fixed focus fails to work involving showModalDialog and window.open in IE Mode workflows.
    • Fixed an issue where visiting a URL that is on AllowListUrls policy causes to open a New InPrivate tab to a URL that is not on the AllowList on iOS.

 

 

Thanks again for sending us feedback and helping us improve our Insider builds.

 

Edited (1/10/23): Updated title and added update.

69 Replies
still restart loop
Thank you. This is what has fixed it. Just replace "msedge_new.exe" with "msedge.exe" in this folder and then everything works again and you can delete the old folder 110.0.1556.0 in "C:\Program Files (x86)\Microsoft\Edge Dev\Application"
For me it was enough to open "msedge_new.exe" in the folder C:\Program Files (x86)\Microsoft\Edge Dev\Application and edge fixed it by itself without having to rename folders!
not better

@maisondasilva Ah nice, this worked for me. Glad I didn't have to delete or replace anything. I force quit, clicked on the "new msedge" application, and it updated and cleared the folder correctly. YouTube hover descriptions are back for me too haha.

Any update on the fix for the Restart loop?
Just received an update, on Edge Dev which i am guessing is to make sure the caught in restart loop is solved.
Many Thanks.

@Eric_E @MissyQ 

 

Hello, I have been seeing this: When signed into outlook com and I click "Show blocked content" , it doesn't unblock the content. I have to re load the page. I see this on 2 of my pc's and on my MacBook Pro Apple Silicon running Edge Dev too.

 

Thanks

After the latest update, when Edge Dev restarted, all my tab groups were duplicated, and no longer associated with the correct window. In trying to place the tab groups in the correct windows, I noticed that if I dragged the tab group out of the window, it caused Edge to become non-responsive, consuming maximum CPU, and eventually crashing.

@BobD68 Thank you for reporting this problem. In order to assist you further, could you please provide me with additional information?

Did this start after updating to Dev build 110.0.1587.6? Also, what setting is your "Enhance your security on the web" option set to? Additionally, are you experiencing this issue on other websites as well or just on outlook.com?

Hello, thanks for the reply. It's been going on for a month now. My Enhance your security on the web" is set to Basic. It should be Balanced though correct? I only use outlook.com with Edge. Oh, I did just try it with Chrome and it works fine there.

@BoydB Thanks for letting us know about the Group tab causing the browser to crash. To assist our engineering team in their investigation, please follow these steps to provide us with additional diagnostic data.

  1. Type edge://crashes in the address bar and press enter.
  2. Locate the crash event that matches the date and time when this happened.
  3. Click on Submit feedback button.
  4. In the Describe what's happening, put "Dragging a tab out of Group Tab causes the browser to crash" and any additional information you want to provide.
  5. Set Allow (recommended) for send diagnostic data to Microsoft.
  6. Click on Send.

@BobD68 If you have Microsoft Edge Canary installed, please check to see if the issue persists. Basic is the default setting when turning on Enhance your security on the web. 

merci pour l'information

Hello, I don't know what you guys doing, but this release fixes sudden crash that happen in previous release, also it's operating more smoothly with no lagging perhaps better memory management?

Anyway, thank you for this release that improve reliability and performance.

 

One more thing it's now no longer lagging when premiere/shutter encoder is encoding.

Thanks. I do not run the Canary build. Dev is as crazy as I get :)
msoft ha url black list in its suvers
Yes, this current build is more stable. Dev build has always been solid for me. But the past month or so on Apple Silicon build it crashes every so often. But still way way better than Chrome, I love the fingerprint integration!!

@Eric_E  Not sure why and nothing has changed on my end but this current build of Edge Dev on my MacBook Pro running Apple Silicon crashes often. Like once every 30 min or so.   I am hoping Edge in the background is sending the crash reports to help.

I have crashes around every 15 minutes on two Macs with Intel CPUs so this is not limited to Apple silicone Macs