Dev Channel update to 110.0.1587.6 is live


1/10/23: Hi Insiders! Thanks for bringing the update issue to our attention. We've released the Dev build 110.0.1587.6 today, which fixes the problem. Thank you again for your help and patience.


Hello Insiders! We are excited to kick off the new year with the release of Dev build 110.0.1587.1 to the Dev channel to all platforms except Mac. Mac users will receive the Dev build at a later date. This build includes a range of fixes, new policies, new API, and new features for Android. For more details on the changes, check out the highlights below. Additionally, we got a new blog post about WebView2 Runtine below.


Delivering Microsoft Edge WebView2 Runtime to managed Windows 10 devices - Microsoft Edge Blog


Added features:  

  • Android:
    • New Ad blocker feature now allows you to block ads with a long press.
    • Now you can change the wallpaper on the New Tab Page.
  • WebView2:
    • Added experimental Permission management API.
  • Enterprise:
    • New policy (Note: Updates to documentation and administrative templates may not have occurred yet)
      • Print preview sticky setting policy.
      • Touch Mode policy.
      • Policy for disabling Immersive Reader’s Grammar Tools.



Improved reliability:  

  • Fixed browser crash related to out of memory condition when visiting certain shopping sites.
  • Fixed browser crash related to invalid access in a vector on webpages. 
  • Fixed browser crash related to McAfee Drive Encryption.
  • Fixed browser crash by disabling WebAuthn autofill functionality due to issue.
  • macOS:
    • Fixed browser crash when activating Fullscreen mode.
  • iOS:
    • Fixed browser crash when using the translator.
    • Fixed browser crash when viewing New Tab Page.
  • Android:
    • Fixed browser crash when downloading a file.
  • Enterprise:
    • Fixed browser crash due to Conditional Access workflow retries too many times when remediation fails on Android.


Changed behavior: 

  • Fixed URLs not being added to the allow list when the flyout is dismissed on Website Typos protection.
  • Fixed favicon not loading properly when installing a site as an app.
  • Prevented browser window from staying open if it only contains a blank tab opened by ClickOnce interaction.
  • Removed recently closed suggestions from the address bar so they will now persist instead only on the current browser session. 
  • Fixed can’t expand or collapse Tab group while the Tab group menu is showing.
  • ALT + S shortcut no longer triggers the screenshot functionality.
  • Workspace sharing prompt will now close when clicking outside of the UI.
  • Fixed Visual search button appearing outside the image when scrolling.
  • iOS:
    • Fixed can’t swipe up on New Tab Page.
    • Fixed page getting squished when using Split View on iPad.
    • Fixed automatic profile switching issue where it keeps switching back to a Work profile from a personal profile.
    • Fixed the issue when trying to sign in from Add account displaying a circle.
  • Android:
    • Fixed Add current page to Favorites button not showing after editing a favorite. 
  • WebView2:
    • WebResourceResquested API promoted from experimental stage to public.  
    • Fixed DPI mismatch.
    • Disabled native Windows Share option due to not working as expected on HoloLens and in UWP apps.
    • Fixed custom rasterization scale bug. (#2918)
  • Enterprise:
    • Removed the ShadowStackCrashRollbackBehavior policy. 
    • Fixed focus fails to work involving showModalDialog and in IE Mode workflows.
    • Fixed an issue where visiting a URL that is on AllowListUrls policy causes to open a New InPrivate tab to a URL that is not on the AllowList on iOS.



Thanks again for sending us feedback and helping us improve our Insider builds.


Edited (1/10/23): Updated title and added update.

69 Replies
Thank you, I have used the Canary build (111.0.1603.0), but found a problem - there is a new extension in the extension folder, but I can't see this extension in the extension management of the browser, I don't know this extension What is the role of.The ID of this extension is "jmjflgjpcpepeafmmgdpfkogkghcpiha"


There's a newer build on web Installer page that fixed the reboot issue.


Monday, ‎December ‎19, ‎2022 3:03:19 PM
CRC32: 755E05CA


Caught in a restart loop also.

Thanks for your advice, my browser works again : )

@MissyQ Is there going to be an update pushed out that resolves the update loop for everyone? Forcing everyone to uninstall and reinstall seems less than ideal.

This is very irritating. Can you please update and fix this problem with the restart loop ?

@Eric_E There are no floating hints on YouTube when hovering over a video title in edge dev starting from 110.0.1556.0.

Current stable MS Edge:



The last edge dev:



best response confirmed by MissyQ (Microsoft)

@Ryan Buckwalter To be clear, y'all can just use the browser without updating consistently. It works just fine without the update right now, the issue is simply the browser won't update when you go to update it.


We're still working on pushing out a fix. As stated, we will follow up once we know when the fix is rolled out. Appreciate everyone's patience and diligence keeping us honest! :3


EDIT - 4PM PACIFIC TIME, JAN 6TH: We had hoped we would be able to fix this for y'all by this afternoon, however it is looking like we will roll out the fix on Monday. Again, thanks for everyone's patience!


Missy Quarry (she/they)
Community Manager - Microsoft Edge
Join us on Twitter, or over on Reddit in r/MicrosoftEdge or r/edge

@dmitrymyl Thanks for reporting this issue. I apologize for the inconvenience, but I am unable to reproduce the issue on my end. In order to help our engineers investigate this issue, please follow the steps below to submit feedback with the necessary diagnostic data.

  1. Click on the three dots menu button.
  2. Go to Help and feedback.
  3. Click on Send feedback.
  4. Fill out the form.
  5. Include your email address and make sure Allow (recommended) is selected for Send diagnostic data to Microsoft.
  6. Click on Record my problem button.
  7. Agree to the terms and click on Start recording.  
  8. Record the issue and then click on Stop recording.
  9. Click on Save and include.
  10. Click on Send.


la version nouvelle mise a jour et déjà disponible sur Microsoft edge
Mais cela empêche pas que je reste sur la version précédente et mon ordinateur rame
La mise à jour du canal de développement vers la version 110.0.1587.1 est en ligne

@Eric_E I have confirmed at Dev Version 110.0.1556.0 which I currently at that all websites are unable to show the tooltip. However, in Canary Version 111.0.1605.0 the tooltips are display properly. 











Agreed, it's a problem.
Had to uninstall and then reinstall from website to get current build.
> Restart loop
I tried to open "new_msedge.exe" (110.0.1587.1) in app directory and Dev updated. It works for me, but I haven't tried another machine.

@Eric_E I solved the update problem by uninstalling Dev and installing the download from the website. All is ok now, I'm on version .1, nothing is lost.

Thanks for the suggestion, it works as long you don't chick the box to remove Edge data.

In App folder I had 2 folders - one 110.0.1587.1 and old 110.0.1556.0.

I was able to fix Edge by renaming *1587.1 folder to 110.0.1556.0 and then start Edge - that fixed it to me - I got the new version - 110.0.1587.1, no issues with not updating.

Hi, where is this folder located ? Thank you very much!
C:\Program Files (x86)\Microsoft\Edge Dev\Application

There are no tooltips anywhere in the browser, and it started for me with the 110.x releases as well. Y'all need to figure out what's causing it, before you push 110.x to Beta and to Release.


Scratch that. Updating to 110.0.1587.1 did actually fix it, I now have working tooltips again, but did not on 1556, just like @Limyx826 


Also like everyone else, I had to forcibly close all running msedge.exe processes, and then run MicrosoftEdgeSetupDev.exe manually. I also had both the 110.0.1587.1 and 110.0.1556.0 folders visible in "C:\Program Files (x86)\Microsoft\Edge Dev\Application" with the "msedge.exe" hard link and all the other ones still pointing at the versions in 110.0.1556.0. If running MicrosoftEdgeSetupDev.exe didn't work, I was just going to manually replace them all and delete the 1556 folder.