An error occurred. (Error code: 9) (Extra code: 0)

Brass Contributor

Hi All 


I tried to update my EDGE, and got error as picture below. Could you help me how to fix it? I am using EDGE on Mac




45 Replies

Hi @daibt,


exact same issue here, on macOS, together with some other macOS weirdness related to some Microsoft apps. Seems Microsoft may have done something to break it for us.


Microsoft Edge also no longer shows up in the Microsoft AutoUpdate (MAU) app. I tried to reinstall manually, but still the same error message.


Guess we have to wait for Microsoft to fix this.

I have the same issue here! But my code is not the same.
An error occurred. (Error code: -5000) (Extra code: 0)
Got the same issue here with macOS 13.6
I solved the problem by uninstalling Microsoft Edge for Mac from the Applications folder of my MacBook Pro then I deleted the Microsoft folder in the Library folder and deleting the EdgeUpdater folder which is in the Microsoft folder in the Application Support folder of my MacBook Pro. As a result, the "An error occurred. (Error code: 9) (Extra code:0)" error message no longer appears and a message that says "Microsoft Edge is now up to date" message appears.

@beetlemanptm I followed these steps. Didn't work for me. I still get the error code 9 on Edge Version 117.0.2045.55 when checking for updates. 


On the update page it offers a learn more link which I clicked where it says to check if is reachable. 


When I try to reach this URL it receive the following error:

This page can’t be found

No webpage was found for the web address:

Maybe the problem is somewhere here. 


I have submitted a ticket to Microsoft Edge team, but the solution they gave to me was useless and the problem still exists. Do you think if it is a bug that v117.0.2045.55 created? I wish developers would attach importance to this problem and solve it ASAP, because it is so annoying.



I just installed 118.0.2088.46. I guess it was just released minutes ago. When I try to check for updates I still get the Error code:9. 


I am starting to think that it is a backend issue. Not a client side problem. 

Same here on my M1 MacBook Pro running Sonoma. Microsoft should fix this very simple error. So bad they just left it to occur
I have the exact same issue with version 118.2088.46. Looks like more of a backend issue as the client tries to connect to a URL to check for updates but fails.

Steps taken by me so far:
1. Uninstall MS Edge on MacOs Sonoma 14.1 23B5067a (using app cleaner)
2. download the latest build for Mac M1 (Apple silicon) from Micrsoft website
3. Install, and i still get this error.

Also with Microsoft Autoupdate, i can only update MS suite teams and onedrive. There is no "MS edge" in the list.

I attempted to download the "Beta" version but noticed that it was identical to the official build, exhibiting the same behaviour. As a temporary measure, I have uninstalled Edge. I'm hopeful that this issue will be resolved soon.

@Feejus Same here. Error occur both with release and beta build. Uninstall and reinstall does not help. Only Microsoft can fix this

Same issue here. Is any from Edge team on it???

@anders1231645 Seems that Microsoft Edge team don’t care. Man users care minority lol

I went into system settings and under general there is a box called login items, in this box there are a number of boxes that can be checked. I unchecked a box called Microsoft Corporation, and this fixed the problem.



Hmm, tried it. Disabled it, closed Edge, and restarted it. No difference.. :sad:

Same here.
Have uninstalled, reinstalled. No change
Ya same here when I first unchecked the box and went back to the update page it told me to restart to complete the update so I restarted the laptop and now I am back to receiving the same message again.
There is no items in my Login items list that name Microsoft Xorporation as you stated. Mine is M1 MacBook Pro. The problem still persist. Wait for Microsoft to fix it

Same issue here. I haven't tried any fixes yet. MacBook Pro M1, MacOS Sohoma 14.0 (23A344).

1 best response

Accepted Solutions
best response confirmed by daibt (Brass Contributor)

@CyrilYu run these commands would resolve the problem

sudo rm -rfv /Library/LaunchDaemons/*
sudo "/Applications/Microsoft Edge Framework.framework/Versions/118.0.2088.46/Helpers/" --install --system --v=2


then restart edge browser, open `edge://settings/help`, problem should resolved


(found solution after extract MicrosoftEdge-118.0.2088.46.pkg and read scripts/postinstall)

View solution in original post