Access privleges

Copper Contributor

I wrote a book chapter in an earlier version of Word for Mac.  When I try to access via Field Code { R "location" } it gives "user does not have access privileges."  Other chapters written at the same time appear normally.   I have never set any limits on access.  "Properties" shows no restrictions.  I have Renamed it and Saved it in the newer version (Word 365, version 16.69) and still cannot access. How might I get access?

11 Replies


Thanks for your reply.  Looks like #5 is appropriate for my case.  Will try in the morning.

I tried #5 this morning. I could see that the sudo worked as the font's were changed in the document. However, it still gives me that I don't have access privileges. Ownership of Word and document author match. I am using a Mac with the M1 chip.
Wondering if the file privileges have been altered by chip change?
Although I'm not a Terminal user, nonetheless, I'm wondering if there might be a command to reset privileges using Terminal?

 Here are some things you could try:

  1. Check the field code for errors: Make sure the location specified in the field code is correct and that there are no typographical errors.
  2. Update the field code: If you are using an older version of Word, the field code may not be compatible with the newer version. Try updating the field code to the current version's syntax with the Latest nutrition information.
  3. Try to remove the field code and re-insert it: Select the field code, press "Delete" and then go to "Insert" -> "Quick Parts" -> "Field" and re-insert the field.
  4. Try to open the document in compatibility mode: Go to "File" -> "Open" and select the document, then click on "Options" -> "Advanced" and tick on "Confirm file format conversion on open" and then open the document in "Word 97-2003" mode.
If you upload a copy of the file, I will see if I can open it.
Good suggestions all, 1. Location is fine, I've used both relative and absolute paths. 2. I've done it. 3. and 4. I suspect that you are not using a Mac as my sequence is 3. Insert>Field>select code and 4. Open>gives 2 options (Original and Repair). There used to be a compatibility mode on the Mac, but that has long disappeared. Maybe I should try a PC version and put it in compatibility mode and see if that solves the problem.
My one discordant item is that when I go into properties, under "Content" it say "Title" "Chapter 3" and that I can't seem to edit and is not part of any text.
I will do that. Perhaps it might help if I explain my purpose. This is one of 26 chapters in a book. I was successfully using Field {RD "file"} on chapters one, two and three before I ran into this problem. I'll also upload the file I was using to check my indexing (three separate indices)
How do I upload the files? Reply only gives me a text option.

@Sowat Click on the "Open full text editor" link and you will see a facility for adding attachments to your response.


Again thanks!

I finally found the problem. On Mac, the file extensions are hidden and the link can't be opened. Solution: File>Get Info>Name and Extension>Uncheck Hide Extension. Add extension to file name in the path. I posted an example of the successful update.