Windows 11 XBOX app update bug

Copper Contributor

The latest update from app store for Xbox is bugged. it's stuck download at 1.02 mb and never want to go futher. I have tried to reboot,  logout of my account and login , wsreset, Repair, Reset, run the powershell command to remove and re-install the microsoft store there is just nothing that will make the update go through. Does anyone else have that issue

5 Replies

@FrancoisRoussel I'm running into the same issue as well. 


Everything else seems to update fine, but XBox and the Microsoft Store both just get stuck and don't download anything beyond the first MB or so.

@FrancoisRousselI just purchased 3 laptops and none of them are able to update (or install XBOX) along with several Microsoft specific applications including an update for Microsoft store. Has anyone had any luck with fixing Microsoft store?


Just as a side note I attempted to just install the XBOX app outside of Microsoft Store and still run into the issue where it timeout about 1/3 to halfway through. Dissapointed.

I can confirm this bug; I am experiencing the exact same issue as described in the original post.
I'm having the same issue with a new laptop. Also tried all the steps you mentioned to no effect. Frustrating!
WOW... ok thx guys.... so it is really a Microsoft bug.
as an f.y.i ... I did install latest update of windows 11 (23h2) and ran all those command again, the reset and so on... still no luck... how do we get Microsoft to fix it?