Microsoft Tech Community Live: Surface Edition
February 15, 2022, 08:00 AM - 12:00 PM (PST)

Can't load PDF via OneDrive - Hangs on 'Downloading...'

New Contributor

Hey, having some trouble loading PDF's in the latest version of OneDrive (17.25) for the Surface Hub - just hangs with the spinning dot circle reading 'Downloading...', and am not prompted to open in any application (we use Drawboard, however not even Edge loads to preview). Anybody else encountering the same issue? Tried escalating it with Microsoft and not having much luck.


Have put the device on both the fast and slow ring of Windows Insiders with similarly no luck.  If we copy the PDF onto a USB it loads fine - seems to be confined to OneDrive.  We are now running the latest CU (2017-09) yet the issue persists.

22 Replies
Hi Timothy

I'm back in the office tomorrow so I'll give this a test for you and let you know what I see.

Hi Timothy

Yup, same behaviour here. Tried opening a PDF from OneDrive, it sits on downloading... then asks for an internet connection.

Surface Hub is on 10.0.15063.608 (Windows 10 1703 17-09 CU)
OneDrive app is

I'll raise a ticket with premier support.

Hi Timothy

I've just had the following response from one of the Surface Hub Support Engineers (thanks Steve!):

"The symptoms you are reporting are actually due to a bug that has been identified and that is being worked on by our development team. We do not yet have an ETA, however I will place your case in Pending status and will let you know as soon as have an ETA for a fix.

As a workaround, you should be able to open OneDrive for Business via the Edge browser to access the PDF files with no issue."

So the product group are aware and working on a fix. When I get an ETA I'll post that here too.

Cheers - glad to know it's not just me. Thanks Dan!
Quick update as promised. MS released an app update last week to iOS and Android to fix a similar problem, so I expect a fix to have gone to Windows 10 platforms too.

I'm back in Monday so will check the app version and test again.

Still seems the same on 17.26 for me - any luck?

Really starting to a show stopper... we more or less deal exclusively in PDF's and Word documents.  Only getting half the functionality.

Latest I've now heard is this is looking likely to be included in the November CU for Windows 10 Team, which suggests this may not be a OneDrive app issue but an issue with Windows 10 Team itself.

Hi Timothy


Looks like this may have been fixed. November CU is out and just spotted this:


  • Addressed issue where the PDF download progress bar stops when opening a PDF file from a cloud-backed web services site.

As my test Hub is now on the Insider Fast Ring, and my other Hubs in the UK won't get it for 7 days, I'll have to wait a week before I can test myself.

We're still experiencing this.

I've tested this again on our Surface Hubs and we are still experiencing the same issue. I've reported back to Premier Support who are continuing to look into this with the product groups.

Another update for you all. I've passed logs from several Surface Hubs and a video capture to Premier Support. We've corroborated the issue with another customer in Japan who are also still experiencing this. A bug report has been filed to the product group to look into the issue and provide a fix.
Interestingly I did get an update just an hour before you posted! However there’s currently no news. The team is still working on the bug and I’m continuing to assist with logs and testing. No ETA for a fix yet.


Just experienced this issue on my Surface Hub. Any further updates from the Microsoft ticket? Appreciate you following up with it Daniel.

Hi Benjamin. Latest update I've had from Premier Support was on 28 February:


"Just wanted to touch base and let you know that we are still awaiting word from the Problem Group on this bug. I’ll let you know as soon as we have something."


@Nydia Cavazos Is there any possibility of getting this escalated within the product group? My case was raised on 27 September 2017! Despite having raised this through PSS it doesn't appear that a fix is incoming. I can provide my case number privately if it's of use?




We're having the same trouble with all our Surface Hubs. Here's some more info:

  1. When opening a program, using the File -> Open command of that app, and selecting OneDrive, navigating and opening a file, it says that it has downloaded the file, it doesn't open directly from OneDrive. The download is to the AppData folder, so when you try to simply save, it fails because it doesn't have permission to the AppData path and forces a Save As command. The Save As allows you to go to OneDrive and save, but only as a new file, no overriding works, and each consecutive save causes a " 1" to be appended to the file name, making lots of fun duplicates of that one file.
  2. If you open OneDrive, download to a local acceptable location (documents, downloads), and work on the file, it works perfectly fine, with no duplicates. But now you must remember to save as to OneDrive before your session is ended, or else you lose the work altogether.

Seems like the OS on the Surface Hub should have seamless file management between the apps and OneDrive as a file location, with the consideration of SSO being established with the device.

Hi Victoria

I believe what you're describing is a separate issue, but one that was introduced at the same time as the issue we're seeing (where trying to open PDF's from the OneDrive app causes it to get stuck at the 'Downloading...' phase).

The latest update I've had states that there are multiple teams working together on this issue, which is making progress, and that this is a high-visibility and high-priority bug for the problem group. However, they're still trying to determine the actual cause of the issue.


Thank you, Dan, for your reply and clarification.

Hi Dan,


I was just wondering if you ever heard anything back from your support case on this?


I've just come across the same issue myself and put in a ticket for it.