"From" address when inviting users to SharePoint online

%3CLINGO-SUB%20id%3D%22lingo-sub-1402270%22%20slang%3D%22en-US%22%3E%22From%22%20address%20when%20inviting%20users%20to%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1402270%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20invite%20a%20guest%20users%20to%20SharePoint%2C%20sometimes%20the%20email%20received%20by%20that%20users%20is%20%22From%22%20the%20person%20who%20sent%20the%20invite%2C%20and%20other%20times%20it%20is%20%22From%22%20the%20email%20address%20of%20the%20O365%20group%20that%20the%20modern%20site%20is%20linked%20to%20-%20does%20anyone%20know%20why%20this%20is%2C%20and%20if%20it%20is%20configurable%3F%20I've%20had%20a%20good%20look%20round%2C%20but%20can't%20seem%20to%20spot%20anything.%26nbsp%3B%20Cheers!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1402270%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1402369%22%20slang%3D%22en-US%22%3ERe%3A%20%22From%22%20address%20when%20inviting%20users%20to%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1402369%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F461778%22%20target%3D%22_blank%22%3E%40calamityjen%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20haven't%20noticed%20this%20myself%20but%20I%20would%20have%20thought%20it%20is%20the%20difference%20between%20adding%20them%20as%20a%20member%20to%20the%20group%20or%20adding%20them%20to%20the%20SharePoint%20permission%20structure.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20below%20is%20adding%20a%20user%20at%20the%20site%2Fgroup%20level%20in%20SharePoint.%20If%20you%20Share%20a%20link%20to%20a%20file%20this%20will%20come%20from%20the%20user%20and%20not%20add%20the%20person%20to%20the%20group.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22site%20or%20grou%5Bp.PNG%22%20style%3D%22width%3A%20442px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F193016iB84179A3343A0B6B%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22site%20or%20grou%5Bp.PNG%22%20alt%3D%22site%20or%20grou%5Bp.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1402411%22%20slang%3D%22en-US%22%3ERe%3A%20%22From%22%20address%20when%20inviting%20users%20to%20SharePoint%20online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1402411%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F214649%22%20target%3D%22_blank%22%3E%40Andrew%20Hodges%3C%2FA%3E%26nbsp%3BI'm%20doing%20this%2C%20by%20inviting%20external%20users%20through%20adding%20them%20to%20the%20group%20via%20Outlook.%26nbsp%3B%20I%20guess%20if%20it%20was%20consistently%20using%20the%20same%20%22from%22%20user%2C%20i'd%20be%20a%20bit%20less%20confused...%20but%20it%20seems%20to%20be%20a%20bit%20of%20a%20mix%2C%20which%20is%20rather%20annoying!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20the%20%22Share%20Site%20Only%22%20option%2C%20that%20you%20have%20in%20your%20image...%20but%20that%20comes%20from%20%3CA%20href%3D%22mailto%3Ano-replay%40sharepointonline.com..%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eno-reply%40sharepointonline.com..%3C%2FA%3E.%20so%20neither%20the%20O365%20group%2C%20or%20the%20person%20that%20shared%20the%20site.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%2C%20my%20tests%20have%20been%20(on%20a%20modern%20Team%20site)%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Invite%20external%20gmail%20account%20to%20site%2C%20from%20Outlook....%20send%20from%20is%20my%20email%20address%20(done%20for%202%20different%20gmail%20accounts%2C%20same%20in%20both%20instances)%3C%2FP%3E%3CP%3E2.%20Invite%20external%20protonmail%20account%20to%20the%20site%2C%20from%20Outlook.....%20sent%20from%20O365%20group%20email%20address%26nbsp%3B(done%20for%202%20different%20protonmail%20accounts%2C%20same%20in%20both%20instances)%3C%2FP%3E%3CP%3E3.%20Share%20site%20only%20to%20a%20gmail%20account...%20sent%20from%20-ERR%3AREF-NOT-FOUND-no-reply%40sharepointonline.com%26nbsp%3B(reply%20to%20is%20my%20email%20address)%3C%2FP%3E%3CP%3E4.%20Add%20member%20(gmail%20account)%20to%20a%20SharePoint%20members%20group%20..%26nbsp%3Bsent%20from%20%3CA%20href%3D%22mailto%3Ano-reply%40sharepointonline.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eno-reply%40sharepointonline.com%3C%2FA%3E%26nbsp%3B(reply%20to%20is%20my%20email%20address)%3C%2FP%3E%3CP%3E5.%20Add%20gmail%20account%20directly%20to%20an%20O365%20group%20in%20Azure%20AD..%20send%20from%20is%20the%20address%20of%20the%20O365%20group%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

When I invite a guest users to SharePoint, sometimes the email received by that users is "From" the person who sent the invite, and other times it is "From" the email address of the O365 group that the modern site is linked to - does anyone know why this is, and if it is configurable? I've had a good look round, but can't seem to spot anything.  Cheers!

2 Replies
Highlighted

Hi @calamityjen ,

 

I haven't noticed this myself but I would have thought it is the difference between adding them as a member to the group or adding them to the SharePoint permission structure. 

 

The below is adding a user at the site/group level in SharePoint. If you Share a link to a file this will come from the user and not add the person to the group. 

 

site or grou[p.PNG

 

Highlighted

@Andrew Hodges I'm doing this, by inviting external users through adding them to the group via Outlook.  I guess if it was consistently using the same "from" user, i'd be a bit less confused... but it seems to be a bit of a mix, which is rather annoying!

 

I have tried the "Share Site Only" option, that you have in your image... but that comes from no-reply@sharepointonline.com... so neither the O365 group, or the person that shared the site.

 

So, my tests have been (on a modern Team site):

 

1. Invite external gmail account to site, from Outlook.... send from is my email address (done for 2 different gmail accounts, same in both instances)

2. Invite external protonmail account to the site, from Outlook..... sent from O365 group email address (done for 2 different protonmail accounts, same in both instances)

3. Share site only to a gmail account... sent from no-reply@sharepointonline.com (reply to is my email address)

4. Add member (gmail account) to a SharePoint members group .. sent from no-reply@sharepointonline.com (reply to is my email address)

5. Add gmail account directly to an O365 group in Azure AD.. send from is the address of the O365 group