Comments on Planner stopped working

Copper Contributor

My Team switched from Trello to Planner about 6 weeks ago and everything was working fine....until a problem with comments about 2 weeks ago.


The comments seem to get added to the card and notification emails are revceived - however after closing the card and going back in there is no sign of the comment.


It's as if closing the card removes the comment or a problem with the display prevents comments being displayed after a specific point in time.


We've tried this for new and current cards, we've tried across mutliple planners and teams and tried on different browsers as well as the Teams App.


I've been advised by our IT suppliers they have referred this to Microsoft but so far we've lost this function for 2 weeks and its getting very frustrating.


Our O365 instance is all off site.


Any with similar experience recently or ideas

10 Replies
I recommend you open a support ticket...comments in Planner is just a feature provided out of the box and it should simply work

Thanks our Admin has raised a ticket.

Some of our users have the issue as well, after a task has been completed to comments are not visible. I raised a support ticket too.

Are you in a hybrid exchange or fully online exchange? Ask your IT if you’re insure of the difference. Planner will exhibit this behaviour if in an hybrid exchange. So far, there isn’t a fix for it other than go fully online exchange

Yes we are in a fully on-line environment.


Our 3rd party suppliers have escalated to Microsoft in March/April.


As well as this in the last 2 weeks I've now engaged directly with a Microsoft Engineer we are working with to support of Windows 10 build/deployment and sent him various logs - he's also remoted on to witness the issue and in his words "wow - I didn't expect that to happen - I need to take this away".


I'm fairly certain the comments are being saved but not being returned - we get emails confirming a comment has been added and for a period 2-3 weeks ago the problem disappeared and all our comments returned - great - only for our hopes to be dashed a few days later when its re-occurred.






Does anyone know the reason for this Problem or have a solution?  We have the same issue in one of our planner. It is not reproducible in other an other planner.

@Heike Theim Not on my side. I was not able to reproduce the case, so O365 Support told me they cannot help. I should open the case again if we can reproduce it.
In our case the comments never appeared again, they were lost. The affected team has lost confidence to Planner. They are using Trello again. 

@Peter Davies Having the same issue.  It is very frustrating. 


I even get an email that the comments has been added to the task.

I noticed that if I type in a comment, it seems to stay. If I cut and paste anything into a planner comment, it tends to disappear (even thought I get an email that it has been posted, with the contents of what I posted).  And no, I am not cutting and pasting an image (although this feature would be amazing).

@gkelway  We've started using Planner on our team and noticed a similar behavior.  I'm not sure if we are hybrid or full-online but Comments were not being displayed after adding them to Tasks.  I thought it might be a character limit be we disproved that theory.  What we did find is that when pasting emails chains into Comments, if the content includes the email header with From/To/Sent info then that could be a cause.  If we removed "From:" and left everything else the Comments content showed up.  If we added text to the header so that "From:" was NOT the first line, the only content displayed in Comments would be that portion BEFORE the "From:" line.  We took another long post, 1500+ characters, and added it to Comments.  That would show successfully EVEN AFTER adding "From:" as the very first line/character.  In all cases we still received email notifications with all content posted, it just didn't always show up in the Task's Comments history.  Strange for sure.