OneDrive for Business SharePoint Library link missing form File Explorer


My customer is running OneDrive client 17.3.6743.1212 (latest version) and synced a few SharePoint libraries (SP Online/ Office 365). 
Last week his password expires, so changed his password, entered his password on every local application on his Windows 10 computer and everything is still running fine. Expect that he is now missing his OneDrive for Business link from the left menu in File Explorer. The one with a icoon looks like a building, mine is called Interchange UC shown below:

ODFB SharePoint library link.png

He is still able to open his synced files, access the synced folders etc.

Anybody seen this behaviour as well, after changing his password? 

15 Replies

IMO that behaviour is not directly connected with the password change.

In fact, in the latest OneDrive previews, you tipically have three "trees" in the left bar of File Explorer: one with the little building at the root, under which you find SPO doclibs, one with the blue cloud, under which you find the ODfB doclib and one with the white icon, under which you find the personal OneDrive doclib.

For more details give a look to this:

Hi Peter - i also changed the password about a week ago, don't remember such issue. Same configuration, the only with ADFS but i guess that doesn't matter.

I guess you speak about the link in Quick access zone of File explorer. You may add synced SPO folders to Quick access manually, they shall be under the user profile folder (C:\Users\<name>\<Synced Folder name>).

The one with the little building icon is missing. Strange behavior. It`s not just a shortcut under Quick Access, unfortunately. So have no idea to get it back, probably by stop the sync and start the sync again, but it takes hours to sync the files again.

Sorry, yes, that's shortcut is not within the Quick access, it's right under it. With 'building icon'. And the folder itself is in user profile folder, here is without 'building icon' (but with sync status icon).

You may try to add another folder on your SPO site, add couple of files and add this folder to sync in OneDrive client settings. Did you try to make any changes in your main SPO folder (e.g add/update/edit files)?

One more way you may try to follow this instruction, but not literally - find the key by the name of tenant. In my case it looks like


@Sergei BaklanThanks for that, already searched the registry for this key, but for the SPO library it is not there anymore.

Peter, try to search not by registry key, but by your tenant name. It shall be two entries under CLSDI like

"OneDrive - <tenantName>" for OneDrive

"<tenantName>" for SPO


I believe it shall be the record in the registry if your ODFB client works and you have synced folder under the user profile.


Also tried that, searching the registry on the tenant name. It looks like it is completely gone.
Have not received a response from my customer to do a remote session and add a test library to see if the link returns.

Sorry to hear... Waiting for remote session you may ask him to add any file to SPO library online. 

Just adding a file made no difference.
But I added an test site to sync and the link was back in File Explorer!
Just for the information of others:
More users of this customer have this issue. Don`t know what is causing this.
Glad it is just a small org, so fixed fast by adding a test site.

I just changed my password yesterday and I have this exact same problem.



I had this happen to me - the only "anomaly" on my Windows 10 Pro system was that a major update was pending for the OS, and I was having issues with explorer's behaviour. SharePoint and OneDrive for Business both disappeared from Explorer but the files were accessible from the Quick Links folders!


After the upgrade installed and desktop was back SharePoint and OneDrive for Business were still missing.



I went to online SharePoint then to Documents, and clicked the "sync" link. I had to log into OneDrive for Business dialog box and PRESTO! SharePoint and OneDrive are listed in Explorer's left column again.


Hope this helps someone else!

I've tried every trick mentioned but no success.

Registry looks good. Re-install of OneDrive, unlinking, adding other doc.libraries, no matter what I try, the Sharepoint library link does not reappear in the File Explorer Navigation pane.

Is this a known problem in Win10?