Spell check not working on Microsoft Teams desktop

Copper Contributor

I have an office365 account and I am running the desktop version of Microsoft Teams on Windows 10.  Spell check is not working.  I have read through many items on the community and internet posts and haven't found anything of help.  I am hoping someone has resolved this issue.


When I say that it isn't working, I mean that it doesn't underline misspelled words as you can see in the screen shot.  The app on my phone works fine.



In one of the posts that I read I heard that someone said it wasn't supported on the desktop version.  I really hope that isn't the case, if it is, it is a huge oversight. However on some other posts I have seen people state that it was working for them on the desktop client.


I have followed the suggestions of exiting the client, deleting the language file found in the C:\Users\<USERPROFILE>\appdata\roaming\Microsoft\teams\dictionaries location.  I have verified that it is recreated when teams starts back up and that it has the correct size.  I am hoping someone has solved this and can help me.

21 Replies
Mine works here in desktop client after typing a word and hitting space or typing other words assuming they don't have a match.
From what I've seen under settings > languages is it set to English US? It used to only work on that language not sure if they expanded or not yet.
best response confirmed by ThereseSolimeno (Microsoft)

Dear @jharmon , hope you are doing well.

I had the same problem - i.e. spell check is not working in teams. I deleted the content of the C:\Users\appdata\roaming\Microsoft\teams\dictionaries folder, restarted Teams, but the issue persisted.

This is how I solved the problem: 

# I opened the log.txt file located in "C:\Users\[user]\AppData\Roaming\Microsoft\Teams" folder.

# I found the following error "error -- spellCheckerService initialization failed: Message: es-419 is not a valid language code"

Which means es-49 (Spanish - Latin America) is not supported by the spellCheckerService.

# I removed Spanish - Latin America configuration from the preferred languages in Windows (I am using Windows 10): Windows Settings -> Time & Language -> Language -> Preferred Languages

# Restarted the computer (just to be on the safe side)

# Logged in on Teams --> and it worked.


Note: English-US is the default language in my computer. Yet, Teams tried to set the Spell Check service to Spanish Latin America for some reason.

Note2: In your case, the spellCheckerService may be trying to initialize using a different language. 


Hope it helps,




My issues were correct words being marked as misspelled and few correct suggestions for other misspelled words. But reading your post helped point me in the right direction, and maybe it could resolve your issue as well.
I went to C:\Users\<USERPROFILE>\appdata\roaming\Microsoft\teams\dictionaries as you mentioned and hoped there was a way to get a better dictionary file.  All research said no way to update what comes with Teams. But when I tried to find more about *.bdic files in general I discovered that it is the format created by google for the chrome browser.  Since deleting the old one does not harm Teams because it can just regenerate a new one, I figured what harm could it do to use my chrome one.  Copied the chrome one into the teams folder and renamed it to the Teams name and voila! My misspelled words now have correct suggestions and my correctly spelled words are showing as correctly spelled. path to other dictioanry file is: C:\Users\<USERPROFILE>\appdata\roaming\chrome\data\ (look for the *.bdic file)
Not the same thing as you, I know, but I thought it could be related or help anyone else who lands here in their search for spell check problems.  

@fabiortthank you very much for sharing this solution with us. It really saved my day. I also had two preferred languages and no natter English was default Teams failed to initialize spell checker. Hope they will fix this soon.

Thanks, man! I had this problem for a long time. Thanks for the accurate steps!

@AndrewClark I just deleted the file located at C:\Users\user\AppData\Roaming\Microsoft\Teams\dictionaries\en-US.bdic and restarted Teams.. all is well

@AndrewClark   Thanks for the great lead on changing dictionaries!


In my case I found all the en-US-?-?.bdic google dictionaries here:

%LocalAppData%\Google\Chrome\User Data

and all the teams dictionaries here:



Also I found the dictionaries can be edited

@jharmon I tried all of the methods below and none work. What I did was uninstall Teams from the computer then deleted the Microsoft Teams folder from C:\Users\<USERPROFILE>\appdata\roaming and the Teams folder from C:\Users\<USERPROFILE>\appdata\roaming\Microsoft.  Once I deleted those 2 folders I reinstalled office and the issue was resolved. It worked!!!!! Also noting that just uninstalling and reinstalling does work unless you delete the folders before the reinstall. 



I hope Microsoft figures out a fix for this lol. I don't want to have to disable my other languages,

I have the same problem, and I use Teams in both languages. I really don't know how to fix that, I don't need it for Spanish, and everything on my laptop is set in English. Can you help?

Hi @fabiort, I did everything you said, and is still not working any help?

@AndrewClark thanks for the inputs. I had exactly the same issue as you have described in your post. Instead of copying chrome's dictionary *.bdic file, what I did was, just took a backup of these files (for some reasons I had 2 files) and deleted them from C:\Users\{your user}\AppData\Roaming\Microsoft\Teams\Dictionaries.


As soon I restarted teams again, it auto generated a fresh file and the error was gone. But your method did the trick and now I get proper suggestions. 


Thank you.

Thank you @jharmon
This helped solving my problem too. Although my windows and office 365 have English as preferred language teams was still using a mix. Channel posts are using English, Wiki pages are using Dutch which was installed as 2nd language. The Wiki had no possibility to switch the language. Deleting the Dutch .bdic file solved this problem. Hope this helps others too!

@Hridesh Hello! I opened the C:\Users\{user}\AppData\Roaming\Microsoft\Teams\dictionaries and i even do not have English dictionary there. 

My colleagues and I are having issues with the spell check in Teams. The issue being that it is enabled in the settings but still doesn't work. I have tried the 'remove the tick and add it again' trick but didn't work. I also saw something that said to delete the 'US.bdic file' which I did but it also didn't work. Is there anything else that can be done?

From a very stressed bad speller...
I am having the exact same problem! Been using Teams for 3 years and this came out of nowhere. Incredibly annoying. I have tried everything to fix it but nothing seems to work. Only way to to uninstall/reinstall and still, it stops working after a few hours or next day. I have no clue what causes it to stop working. It's fine one minute and then it stops.

I posted my own case:

Hopefully someone has a resolution because I've just about had it with Teams!

Whether there is a dictionary file or not seems to make no difference. If you completely uninstall and reinstall Teams, it does not even create a Dictionary folder and yet, spell check works. Then it mysteriously stops working. Also, if you reinstall Teams, the spell check works but if you reboot your computer, it stops working. Even if you delete the entire %AppData%\Microsoft\Teams folder and restart Teams, spell check still doesn't work.

My spellcheck works except if I type "teh" instead of "the". There isn't a dictionary either. the only thing I can think of is in Word, I set "teh" to autocorrect to "the", but I wouldn't think that should make a difference since Teams doesn't have that autocorrect option.