Problems with Native Teams desk phones as Common Area Phones

Steel Contributor

Has anyone gotten this to work? I've provisioned several user accounts to assign CAP license to as follows (and waited more than 48 hours):


1. Common Area Phone License
2. Microsoft 365 Domestic Calling Plan


Trying to sign-into a Poly CCX and a Yealink T58 native teams phone, and wind up in an endless device registration device/sign-in loop. At first we thought it was limited to just the Poly CCX devices, but so far we haven't been able to get this to work on any of our native Teams phones, including phones from Yealink (T5Xs).


If I use the same user account on a 3PIP phone (Polycom VVXs, for example), it works as expected.


Would love it if anyone could tell me what we might be doing wrong, or reproduce this issue for me before I go through the issue submission process.




5 Replies
Has your org been upgraded to Teams Only mode or are you still in a hybrid mode of some sorts? Have you gotten phones to work for normal users yet?
best response confirmed by ThereseSolimeno (Microsoft)

@Chris Webb 


We're having the same issue as the OP.

The common area phone accounts in question are in Teams Only mode.

Some persons are still in Hybrid, but this shouldn't matter as the CAP is Teams Only, licensed, and configured properly.

The problem comes when the device is trying to register with the tenant and InTune it will loop and eventually go back to the sign in screen.


There are logs in the Azure tenant where the initial log in is a success, but registration is a failure due to "a change by your administrator, or you need to register for MFA". The account is exempted from MFA in conditional access, and has enrollment restrictions enabled for device administrator as well as been added as a Corporate managed device with serial number. Trying to log in with a normal account on the phone is a success with no MFA. Conditional Access "What If" testing shows no policies applied with the current scenario.


Very interesting issue.

Teams only, across the board. @Chris Webb 

Phones for regular users have "worked" otherwise for a couple years now.

Thanks for confirming! @RMLee 

@Bob Manjoney : We had something similar issue with Multifactor. Our workaround was to sign onto as the user account then when fully signed on open another tab and go to and complete the process. Note: even though the broker window says you can close the window do not until the setup has completed. This solved the endless sign-on issue for us.