SOLVED

Shared Channels not showing up in Teams

Copper Contributor

I'm hoping someone can confirm a behavior I'm seen in the Microsoft Teams Admin Center.

 

  1. Login to the Teams Admin Center with and Global/Teams Admin Account.
  2. Navigate to Teams->Manage Teams
  3. Use an existing test team or create a new team for this test. 
  4. Select the Team and when displayed make sure the Admin Account is NOT an Owner or Member of the team. (If you remove the account, you may have to wait a while before continuing as remove permissions aren't always immediate) The Owner/Members should be other users in your org.
  5. Click the Channels Tab
  6. Click on Add
  7. Give the Channel a name, change the Type to Shared, add one of the Teams site members as the channel owner (do not use the Admin account)
  8. Click on Apply to create the Shared channel.

I'm curious to see what happens. In my Org and Dev Tenant the Shared channel is not added to the list of channels and does not appear anywhere in Teams. Yet if you navigate to the SharePoint Admin Center locate the team in the list of sites and under the sites link you can see that the underlying SharePoint site was created for the Shared Channel.  This does not happen with Private Channels they are created even if the Admin account is an owner of the Team or not.  Shared channels work for me when the Admin account is added an Owner of the Team.

8 Replies
Where did you find this documentation. It seems new to me I also checked in my tenant where I could not find a setting like that.

@howeian Has yours changed at all since posting? This thread also highlighted the same issue with mixed experiences: Administering Shared Channels - Microsoft Community Hub

 

It's worth reporting to Microsoft. I've tried the same thing on my tenant and have the same issue. Definitely an issue if shared channels can't be seen by admins.

@paul keijzers No documentation, just going through the Teams Admin Center and performing the options available to me. Not sure which setting you're not seeing. Maybe shared channels are not enabled for you?

Thanks for the link. I did search but didn't see any relevant results. The Shared Channels have never shown up for me. Been weeks since creating them.

I've had a ticket open with MS Support for 4 weeks regarding the issue. From the date on that post looks like the issue has been around for at least a year.

At least I know how to get around the issue just seems dumb that I need to add the admin account as a Team Owner to create the channels through the Admin Center.

@howeian now that you mention it, shared channels have only been around for about a year in General Availability. This may not have been working since the start.

best response confirmed by howeian (Copper Contributor)
Solution
Finally finished discussing with MS support. The resolution is that this is working as designed. They referred to this link https://learn.microsoft.com/en-us/microsoftteams/shared-channels which indicates that only the Team owner can create Shared Channel. Even though the Admin Center allows you to create a Shared Channel as a Teams Administrator, that is not the correct process and the Admin account must be an owner of the Team it is creating the channel in. I personally think this is a bug in the UI and it should not give the user the option to do it in the first place.

@howeian I encountered exactly the same error and of course saw the post afterwards. Have you managed a way to delete those shared channels properly? 

@MarcinTrojanski 

 

I couldn't find a way to delete these sites through the Admin Center UI.  Had to use PowerShell. Connection method may be different depending on your tenant settings.  Deleted sites also do not get added to the Deleted sites list in the SharePoint Admin center but can be handled through PowerShell.

 

Import-Module Microsoft.Online.Sharepoint.PowerShell
 
#Variables for processing
$AdminSiteURL = "https://<sharepoint admin url>"
$SiteCollURL = "https://<site to delete path>"

  
#Connect to SharePoint Online
Connect-SPOService -url $AdminSiteURL 
 
#delete sharepoint online site collection using powershell
Remove-SPOSite -Identity $SiteCollURL -NoWait -Confirm:$false

 

1 best response

Accepted Solutions
best response confirmed by howeian (Copper Contributor)
Solution
Finally finished discussing with MS support. The resolution is that this is working as designed. They referred to this link https://learn.microsoft.com/en-us/microsoftteams/shared-channels which indicates that only the Team owner can create Shared Channel. Even though the Admin Center allows you to create a Shared Channel as a Teams Administrator, that is not the correct process and the Admin account must be an owner of the Team it is creating the channel in. I personally think this is a bug in the UI and it should not give the user the option to do it in the first place.

View solution in original post