No Join Button - Teams Outlook Add-in


Hi All,


We recently discovered an issue with the Teams outlook add-in, where there is no Join button for Teams meetings on the Outlook calendar reminder. 


We are currently in islands mode, and there is a Join button for Skype meetings in the Outlook calendar reminder. Any ideas?



29 Replies
Are you logged in to a guest tenant?

If so, change tenant to your own within the client, restart outlook.

Hi @Erwin Bierens thanks for your reply.


No I am not currently logged into a guest tenant.

Did you check your add-ins in Outlook? Maybe its inactive.

File > options > Add-in

Here you should see: "Microsoft Teams Meeting Add-in for Microsoft Office"

Did you already try to launch outlook as Administrator?

@Erwin Bierens 


The Teams Add-in is active and working, I can create a new Teams meeting in the calendar etc which all works fine, however when the calendar reminder pops up, there is no option to "Join Online".


This button is present in another tenant, but I cant find out why - very strange.

Do you see the join link when creating the meeting from your outlook client?

@Erwin Bierens Yes, the join link is present in the email, and works fine, even the "Join Teams Meeting" button is present when you double click and open the calendar event and works. For some reason, that is not translating to that button being available on the calendar reminder.

Pretty sure this will not activate until you go to Teams Only mode. Being in Islands, your primary meeting tool is still technically Skype for Business until you switch over.
Yeah, just confirmed with my islands test user. You do not get the buttons available in Outlook unless you are signed into a Teams Only account in your Teams client when starting Outlook.

Hi @Chris Webb, I have just tested this with our testing tenant with an islands user and this works fine? Seemingly this does not seem to be what is causing this issue.

How did you test it? I can reproduce every time. Make sure you have outlook shut down. Log into teams with island user then open outlook (make sure Outlook was 100% closed) then open outlook. If you had outlook open then just log into the island user to test it will still work.

@Chris Webb I had 2 test users, one on islands mode and the other Teams only. I created meetings for each of the users and they both had the join online button on the calendar reminder. Just seems very strange that this is not happening for our org.

Make sure your org is setup for Modern Authentication. That could be the cause here. I don't remember if I setup my Test tenant to use it. Going to check.

Modern Auth docs. for Exchange where this might be the issue


Skype for Business Modern Auth:



Anyway, just a hunch, going to see why mine doesn't have join in islands assuming it's possible...


This isn't the case in my situation since I have it enabled, but I would check your tenant since it's a good idea to have that enabled if not. (Required for MFA etc.)
one Question, Does your Teams Meeting add-in show up at all? Or is it just no join button? What Office / Outlook version are you on / release ring? I know it's a newer build option.
To confirm, mind is working on my Islands user now. Not sure what I had done to reproduce it previously. Maybe I signed into my Skype only user on accident or something. Anyway, the things I know at this point to check are the Modern Auth as pointed out above and then Office client versions.

Are you not getting the join button on the "reminder window?" or if you select the meeting in the calendar, does it show the Join button in the Teams Meeting heading?
Well, apparently I'm an idiot, my test user was set to Skype Only for some reason even those it's my islands designated user..... explains my odd test result. Anyway, report back about Modern auth. if you could, and if you see the add in but just not the Join button on the reminder or if it's no add-in at all. thanks!
I had the exact same issue and although the instructions are funky, it worked for me.

-Sign out and close Outlook (and when running, do not run with elevated permissions).
-Download, install, and sign into Teams Desktop App.
-After signing in, restart the app.
-Restart Outlook after restarting Teams.
(worked, hopefully for you too)

@Chris Webb 


Yes our org uses modern auth, and the teams meeting add-in shows up fine, we can schedule Teams meetings through the Outlook calendar absolutely fine. Its just purely the join button on the Outlook calendar reminder that ins't working. I have attached an image.