MTR Poly GC8 screen blank when joining Teams Meetings

New Contributor

Teams Room with Windows runing 20H2, no updates available.


When we join a Teams meeting the touch panel goes blank, so we cannot control or leave the meeting. The participants are shown on the connected TV and the camera works in that the participants can see the room. The only way to end the meeting in the Meeting Room and restore the touch panel is to reboot the system.


Similarly, if we select the call function, the screen goes blank until it times out and returns to the dashboard.


The MTR is running and Windows is 20H2.


We have tested the MTR device wtha a Zoom Meeting and the panel works fine.


Any suggestions?

12 Replies
We have the same issue with 2 of our meeting rooms , MTR Poly GC8 today. we tried following but no luck:

- reset teams app
-rest mtr device to factory setup


We are experiencing the same issue with 3 of our MTR@neilrw 

@Suvriz  and @lionheart85 - thanks for the responses.


Our VC supplier says this is also affecting their customers with the the Crestron version.

Has your Teams version also recently been updated to ?

@neilrw Yes we had and update, but the MTR that are affected is

Already try completely wiping the device and reinstalling windows with Teams Room, swapping out the touch screen and attempting the various PowerShell fix scripts. nothing works. We are totally screwed because of this with a few big upcoming meetings happening in the coming days.
Hi @neilrw,

Just logged on with another account from a working MTR and that worked. Now comparing accounts to see if anything is different.
Interesting. Will try the same now and let you know. Thanks!

Also experiancing the same issue with a crestron system. pulling my hair out! manually updated to latest version on crestrons advice via powershell but still the same. It could not have happened at a worst time. right in the middle of a 2 day exec meeting!


Ive also tried logging in with a different account but that didnt do anything for me.


what a pain

We are experiencing the same issue on about 5 of our meeting rooms this morning. These were all working as of yesterday afternoon (We've been doing spot checks on all meeting rooms for a return to office currently in progress). Call function does not work and the panel disappears if you direct join a meeting.

@Seanie_D   - we tried with the account that was setup in the working MTR GC8 and it worked.  


Thought it is to do with the account , did a comparison between working and non working account but we are unable to find any difference.  

best response confirmed by neilrw (New Contributor)
Had the same issue as @neilrw - just tried to sign in with another account (which failed) - then signed in with the original account and restarted the device. After the restart, the account signed in as expected and then I was able to use the 'Call' button successfully and also 'join a meeting' without the blank panel issue.

The version is still with Windows 20H2
So we change the password on the room account a few times and rebooted the MTR with the updated auth. this seems to have resolved the issue. will be looking out tomorrow to see if this issue affects our other systems and apply updated auth info.