Forms - can not add question

Copper Contributor

Starting yesterday my forms app will not allow me to add a question to a new (or existing) form.  I select 'add question' to type of question menu appears, I select a question type and nothing appears.  Menu goes away and I'm left back at the 'add question'.  I am on a Mac, I've tried both Safari and Firefox, same problem.  


Any help would be appreciated.  

6 Replies
I'm moving your question to the Microsoft Forms community for better visibility.

Same issue here, Safari, Chrome and Firefox. 



I actually figured out the problem.  Forms site was not recognizing the left click on my apple mouse.  "Tab-ing" thru the website gave me access to questions. 

Still didn't work for me, trying to create a question. Tabbing just takes me to the address bar of the browser. 

Same issue for me. I know it worked on my Mac back on February 24 or so as I created an Excel Form that day for the Oscars. Going back and trying with Firefox and Safari on Mac are not working since that time. It does work fine on Windows (Firefox). I have not tried the tab option, but I will give that a try. We had a faculty member report it to us and realized it was not working. A change made by programmers that broke it for Mac browsers but not Windows browser? Odd!




I had changed one of the color styles to white in my case, which wasn't showing up with a white background. Once I turned that BG color to gray, I could see the buttons. @Matthew_Given