Copilot for Microsoft 365 Tech Accelerator
Feb 28 2024 07:00 AM - Feb 29 2024 10:30 AM (PST)
Microsoft Tech Community

Rows keep hiding themselves.

Copper Contributor

I received an excel file with some rows hidden.  After unhinding them, every time I filter for a certain value in a column the rows hide themselves again, even though they were showing and I saved the document again.  How do I get them to stay unhidden?

13 Replies
Hello,

I guess that may be an Outline.. Kindly upload a screenshot to see

 

SNip of excel screen.JPG

@Abiola1 

To unhide all rows, select all the spreadsheet using CTRL + A. Then, in the Home tab, click on Format > Hide & Unhide > Unhide Rows
Thanks, I'll try that. Unfortunately the rows are still hidden. I can manually bring them back, only to have them hide again every time I filter.
Hello, if possible kindly upload your file and let me see
Hello,

I have see that Freeze Panes is added to the Excel file.

To Remove it: in the View tab, click on Freeze Panes and select Unfreeze panes.


Aside from that, I can't see any row that hides itself
Hello,

I think I understand the challenge, when you apply filter to a column, definitely the rows hide to only show the data you want. To remove ALL filter, in the Sort & Filter group of the Data tab, click on Clear..

All your data will be back without any rows hidden

@shannonjeffriesI am having the same issue - so frustrating. Every time i filter (in my case an employee name), after unfiltering to see all, many rows are automatically hidden. I have to manually unhide EVERY TIME! Have you found a solution yet?

@amymarie I had the same problem and is currently fixed for now. Remove filter then unhide the rows then Apply Filter.

 

Hope it helps.

@amymarie 

I keep having the same problem, instead of mannually doing it, you can highlight the whole spreadsheet, do format and hide everything first, then do format cells and unhide them.   that will bring them back faster but i still have not heard how to keep it from hiding the cells period.   It did not do this int he past.

 

Thank you! Looks like this may have resolved the problem. Appreciate you taking the time to assist.

Look in all of your filters and make sure that blanks are selected. If there is one that is not selected, select it and your issue should be resolved.