Copper Contributor

Up until a few weeks ago, I have been downloading a CSV file from a web-site. The file consisted several rows of a DATE field, text field and 2 numeric fields.
EG: 08/14/2023,ABCD-1 ,005161,100.00
When I opened the CSV file (just by double-clicking ) on my Windows-10 PC, Excel-365 directly opened this file with the DATE field formatted as a DATE. That simple.

When my Windows-10 computer DIED a few weeks ago, I replaced it with a brand new Windows-11 desktop. Now when I double-click that exact same CSV file, Excel-365 opens the DATE field formatted as TEXT. I know I can play around with the Excel 'Get-Data' feature to import the CSV, and after 5-6 operations later get a date-formatted field. But why was this SO EASY under Windows-10 and a real pain under Windows-11. Given the SAME Excel-365.

Do I FIX Windows-11, of FIX Excel-365...??

6 Replies


Do you use a different system date format on the new computer than on the old one?

If you used mm/dd/yyyy on the old computer, 08/14/2023 would be recognized as the 14th of August.

If the new computer uses dd/mm/yyyy, 08/14/2023 is not a valid date, so Excel will import it as text.

both my Windows-10 old system and the new Windows-11, have their dates set as yyyy/mm/dd.
I made a small error in my last replay. More correctly the computer's date format is set to: yyyy-mm-dd.
As well, I tried changing it to: mm/dd/yyyy on my Win-11 computer (then rebooted). I then tried to open my CSV file by double-clicking. Again, that DATE field opened in Excel-365 as TEXT (not as a date).


Is that both for Short and Long date?


OK... I found a solution (That I do not like).
I live in Canada so I had set my "Preferred languages as English (Canada) first, and English (United States) as second. I set the Country or Region to Canada, and finally the Regional format to English (Canada). THEN, I change all of these things to United States - first, and change the short date to mm/dd/yyyy. THEN, my csv opens with the date as a date (not TEXT). Changing just the short date (and not the others) --- does NOT work.
by the way... I am not moving to the United States (even if my computer thinks we did).