Favicon Edge not working

%3CLINGO-SUB%20id%3D%22lingo-sub-2290601%22%20slang%3D%22en-US%22%3EFavicon%20Edge%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2290601%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20hope%20you%20are%20well%20!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20favicon%20for%20our%20intranet%20which%20is%20not%20working%20on%20Microsoft%20Edge%20Chromium.%20This%20site%20is%20in%20IE%20Mode.%20The%20FavIcon%20works%20well%20on%20other%20browsers%20such%20as%20Internet%20Explorer%20or%20Firefox.%20Can%20you%20tell%20me%20why%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEdge%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Jerem_Pas72_0-1619424861034.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F275524i58D7476BFB70F902%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Jerem_Pas72_0-1619424861034.png%22%20alt%3D%22Jerem_Pas72_0-1619424861034.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIE%20Works%20%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Jerem_Pas72_2-1619424911430.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F275526i5E16DF6CB2F90847%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Jerem_Pas72_2-1619424911430.png%22%20alt%3D%22Jerem_Pas72_2-1619424911430.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EFirefox%20Works%20%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Jerem_Pas72_3-1619424939759.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F275527iE2F140DF6E2F1711%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Jerem_Pas72_3-1619424939759.png%22%20alt%3D%22Jerem_Pas72_3-1619424939759.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECode%20HTML%20%3A%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CTITLE%3EPage%20d%E2%80%99accueil%20Akiolis%3C%2FTITLE%3E%3CBR%20%2F%3E%26lt%3Bmeta%20http-equiv%3D%22%22Content-Type%22%22%20content%3D%22%22text%2Fhtml%3B%22%20charset%3D%22UTF-8%22%22%20%2F%26gt%3B%3CBR%20%2F%3E%26lt%3Bmeta%20http-equiv%3D%22%22expires%22%22%20content%3D%22%220%22%22%20%2F%26gt%3B%3CBR%20%2F%3E%26lt%3Bmeta%20http-equiv%3D%22%22pragma%22%22%20content%3D%22%22no-cache%22%22%20%2F%26gt%3B%3CBR%20%2F%3E%26lt%3Bmeta%20http-equiv%3D%22%22cache-control%22%22%20content%3D%22%22no-cache%2C%22%20must-revalidate%3D%22%22%20%2F%26gt%3B%3CBR%20%2F%3E%3CLINK%20rel%3D%22%26quot%3Bshortcut%22%20icon%3D%22%22%20%2F%3E%3CBR%20%2F%3E%3CLINK%20rel%3D%22%26quot%3Bicon%26quot%3B%22%20type%3D%22%26quot%3Bimage%2Fx-icon%26quot%3B%22%20href%3D%22%26quot%3B.%2Fimgs%2Ffavicon.ico%26quot%3B%22%20%2F%3E%3CBR%20%2F%3E%3CLINK%20rel%3D%22%26quot%3Bicon%26quot%3B%22%20type%3D%22%26quot%3Bimage%2Fpng%26quot%3B%22%20href%3D%22%26quot%3B.%2Fimgs%2Ffavicon.png%26quot%3B%22%20%2F%3E%3CBR%20%2F%3E%3CLINK%20rel%3D%22%26quot%3Bstylesheet%26quot%3B%22%20type%3D%22%26quot%3Btext%2Fcss%26quot%3B%22%20href%3D%22%26quot%3B.%2Fstyles%2Fbase.css%26quot%3B%22%20media%3D%22%26quot%3Ball%26quot%3B%22%20%2F%3E%3CBR%20%2F%3E%3CLINK%20rel%3D%22%26quot%3Bstylesheet%26quot%3B%22%20type%3D%22%26quot%3Btext%2Fcss%26quot%3B%22%20href%3D%22%26quot%3B.%2Fstyles%2Fdesigntest1.css%3Fv%3D3%26quot%3B%22%20media%3D%22%26quot%3Bscreen%26quot%3B%22%20%2F%3E%3CBR%20%2F%3E%3C!--%5Bif%20lt%20IE%209%5D%3E%3Clink%20rel%3D%26quot%3Bstylesheet%26quot%3B%20type%3D%26quot%3Btext%2Fcss%26quot%3B%20href%3D%26quot%3B.%2Fstyles%2FIE.css%26quot%3B%20media%3D%26quot%3Bscreen%26quot%3B%20%2F%3E%3C!%5Bendif%5D--%3E%3CBR%20%2F%3E%3CSCRIPT%20type%3D%22%26quot%3Btext%2Fjavascript%26quot%3B%22%20src%3D%22%26quot%3B.%2Fscripts%2Fjquery-1.10.2.min.js%26quot%3B%22%3E%3C%2FSCRIPT%3E%3CBR%20%2F%3E%3CSCRIPT%20type%3D%22%26quot%3Btext%2Fjavascript%26quot%3B%22%20src%3D%22%26quot%3B.%2Fscripts%2Fglobal.js%26quot%3B%22%3E%3C%2FSCRIPT%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20a%20lot.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2293867%22%20slang%3D%22en-US%22%3ERe%3A%20Favicon%20Edge%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2293867%22%20slang%3D%22en-US%22%3EHello%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20had%20reports%20of%20this%20as%20well%20at%20my%20organization.%20I%20created%20this%20thread%20a%20while%20back%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fenterprise%2Fie-mode-favicons-do-not-load-for-new-ie-mode-favorites%2Fm-p%2F1886465%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fenterprise%2Fie-mode-favicons-do-not-load-for-new-ie-mode-favorites%2Fm-p%2F1886465%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EAndrew%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2295399%22%20slang%3D%22en-US%22%3ERe%3A%20Favicon%20Edge%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2295399%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1036669%22%20target%3D%22_blank%22%3E%40Jerem_Pas72%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F458117%22%20target%3D%22_blank%22%3E%40AndrewSAIF%3C%2FA%3E%26nbsp%3BHi%20to%20you%20both!%26nbsp%3B%20Can%20you%20share%20what%20version%20of%20MS%20Edge%20you%20are%20running%20into%20this%20issue%20on%3F%26nbsp%3B%20I%20do%20see%20some%20work%20was%20done%20recently%20for%20IE%20mode%20favicons%20and%20builds%20greater%20than%26nbsp%3B90.0.811.0%20should%20have%20the%20improvements.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20you%20are%20reproducing%20on%20newer%20builds%20please%20let%20us%20know%20and%20I%20can%20reach%20out%20to%20the%20IE%20mode%20team.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2298206%22%20slang%3D%22en-US%22%3ERe%3A%20Favicon%20Edge%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2298206%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20version%20of%20Microsoft%20Edge%20is%20%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Jerem_Pas72_0-1619538223257.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F275886iEA635F129109BA86%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Jerem_Pas72_0-1619538223257.png%22%20alt%3D%22Jerem_Pas72_0-1619538223257.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20a%20lot%26nbsp%3Bfor%20your%20quick%20answer%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello,

 

I hope you are well !

 

I have the favicon for our intranet which is not working on Microsoft Edge Chromium. This site is in IE Mode. The FavIcon works well on other browsers such as Internet Explorer or Firefox. Can you tell me why ?

 

Edge :

 

Jerem_Pas72_0-1619424861034.png

 

IE Works :

Jerem_Pas72_2-1619424911430.png

Firefox Works :

Jerem_Pas72_3-1619424939759.png

 

Code HTML :

<head>
<title>Page d’accueil Akiolis</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="expires" content="0">
<meta http-equiv="pragma" content="no-cache">
<meta http-equiv="cache-control" content="no-cache, must-revalidate">
<link rel="shortcut icon" href="./imgs/favicon.ico" />
<link rel="icon" type="image/x-icon" href="./imgs/favicon.ico" />
<link rel="icon" type="image/png" href="./imgs/favicon.png" />
<link rel="stylesheet" type="text/css" href="./styles/base.css" media="all" />
<link rel="stylesheet" type="text/css" href="./styles/designtest1.css?v=3" media="screen" />
<!--[if lt IE 9]><link rel="stylesheet" type="text/css" href="./styles/IE.css" media="screen" /><![endif]-->
<script type="text/javascript" src="./scripts/jquery-1.10.2.min.js"></script>
<script type="text/javascript" src="./scripts/global.js"></script>
</head>

 

 

Thanks a lot.

8 Replies
Hello,

I've had reports of this as well at my organization. I created this thread a while back:

https://techcommunity.microsoft.com/t5/enterprise/ie-mode-favicons-do-not-load-for-new-ie-mode-favor...

Andrew

@Jerem_Pas72 @AndrewSAIF Hi to you both!  Can you share what version of MS Edge you are running into this issue on?  I do see some work was done recently for IE mode favicons and builds greater than 90.0.811.0 should have the improvements. 

 

If you are reproducing on newer builds please let us know and I can reach out to the IE mode team. 

 

Thanks! 

 

-Kelly 

Hi all,

 

My version of Microsoft Edge is :

Jerem_Pas72_0-1619538223257.png

 

Thanks a lot for your quick answer

@Jerem_Pas72 @AndrewSAIF Quick update, I've reached out to the team and they were not able to reproduce but they would like to try and investigate further.  

 

Would you please submit diagnostic data through the browser? ("..." menu > Help and feedback > Send feedback)  When you send the feedback, our developers are hoping you can include the following information and answers to some of their questions: 

  • Specific repro steps
  • Is this a consistent repro or is there anything you've noticed that will prompt the issue to happen?
  • Are you adding the favorite from somewhere other than the address bar? 
  • Does the favorite you’re adding not match the final URL of the page that loads in IE mode? (For example, the page redirects)

Also, if you include "FaviconIEmode-TC" in the feedback somewhere and we will be able to track it down easier.  

 

@AndrewSAIF - I'm not sure if you submitted feedback previously but would be great if you can file feedback again with the information above :smile: 

 

Thanks! 

 

-Kelly

Hi Kelly,

Thanks for the info. I retested with V89 and V90 again after reading this. It looks like this is indeed fixed as of V90, at least for the sites I was testing with. Thanks!

I did notice while I was testing that after v90 does load the favicon from an IE Mode site that hadn't been visited yet, the browser will hang for about 30 seconds a good portion of the time. I noticed this more reliably on a low-resource virtual machine and only occasionally on a more powerful system.

Andrew
Hello,

I just submitted the comment directly with the FaviconIEmode-TC tag. I confirm that this problem is is consistent. This is our home page that opens when Edge starts, it is not redirected.

@Jerem_Pas72 Hi!  Thanks!  I was able to locate your feedback.  

 

Is your homepage the only site with the issue or are you seeing issues with other sites in IE mode as well?  Is this reproducing on multiple machines in your organization?  

 

Also, did you add the URL to your favorites from the Address Bar?  Or was it added to your favorites using another method like imported to MS Edge? 

 

The more information you can provide the better :) as it will help the team try to reproduce and investigate your issue.  

 

-Kelly

Hi !
Yes it happens in everyone ..
I discovered the source of the problem. If I switch to https it doesn't work for this site. If it is in http I have the icon.