Microsoft Edge

%3CLINGO-SUB%20id%3D%22lingo-sub-2753888%22%20slang%3D%22en-US%22%3EMicrosoft%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2753888%22%20slang%3D%22en-US%22%3E%3CP%3EMicrosoft%20Edge%20displays%20in%20Hebrew%20instead%20of%20English.%26nbsp%3B%20My%20settings%20for%20language%20is%20set%20to%20English.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2757262%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2757262%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20there%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1156950%22%20target%3D%22_blank%22%3E%40montymontyblakeston%3C%2FA%3E!%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIs%20this%20happening%20in%20all%20of%20Edge%2C%20your%20New%20Tab%20Page%2C%20your%20searches%2C%20or%20only%20other%20specific%20pages%3F%20If%20it's%20all%20of%20Edge%2C%20I%20know%20you%20said%20your%20language%20is%20set%20to%20English%20but%20can%20you%20confirm%20if%20Hebrew%20or%20any%20other%20languages%20are%20present%20at%26nbsp%3Bedge%3A%2F%2Fsettings%2Flanguages%20%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EAlex%20Rowell%20(she%2Fher)%3CBR%20%2F%3ECommunity%20Manager%20-%20Microsoft%20Edge%3CBR%20%2F%3EJoin%20us%20on%20%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2170823%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3ETwitter%3C%2FA%3E%2C%20or%20over%20on%20Reddit%20in%20%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2170824%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Er%2FMicrosoftEdge%3C%2FA%3E%20or%20%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2170926%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Er%2Fedge%3C%2FA%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2757429%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2757429%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F858070%22%20target%3D%22_blank%22%3E%40Alexandra-R%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%2C%20on%20the%20edge%20language%20page%20both%20settings%20are%20set%20to%20English%20(U.S.).%26nbsp%3B%20When%20I%20tap%20the%20Edge%20icon%20the%20page%20comes%20up%20in%20Hebrew%20although%20I%20can%20enter%20in%20English%20and%20go%20from%20there.%20It%20appears%20that%20the%20screen%20wants%20to%20come%20up%20in%20Hebrew%20because%20that's%20where%20I%20am%20now...in%20Jerusalem...but%20I%20want%20it%20to%20come%20up%20totally%20in%20English%20as%20if%20I%20were%20in%20the%20United%20States.%26nbsp%3B%20Thank%20you.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Microsoft Edge displays in Hebrew instead of English.  My settings for language is set to English.

8 Replies

Hey there @montymontyblakeston!

 

Is this happening in all of Edge, your New Tab Page, your searches, or only other specific pages? If it's all of Edge, I know you said your language is set to English but can you confirm if Hebrew or any other languages are present at edge://settings/languages ?

 

Alex Rowell (she/her)
Community Manager - Microsoft Edge
Join us on Twitter, or over on Reddit in r/MicrosoftEdge or r/edge

@Alexandra-R 

Yes, on the edge language page both settings are set to English (U.S.).  When I tap the Edge icon the page comes up in Hebrew although I can enter in English and go from there. It appears that the screen wants to come up in Hebrew because that's where I am now...in Jerusalem...but I want it to come up totally in English as if I were in the United States.  Thank you.

It sounds like the New Tab Page is specifically coming up in Hebrew, but if you navigate to other pages are those also displaying in Hebrew? What about your settings pages? (Trying to confirm because the New Tab Page has a different settings flow!)
Also can you confirm your Edge Version?
Yes, the only time I see the Hebrew, and only on selected portions of the screen, is when I select the Edge icon and the initial screen comes up. My favorites are in English and I can type in English. The Edge version is 93.0.961.52 (Official Build) (64-bit). Thank you.

Thanks for confirming! It sounds like the language on your New Tab Page specifically is changing to Hebrew. There are two places to check if the incorrect language setting is being applied there, but the second one only may not appear depending on your settings.

 

First, the gear icon on the top right of the New Tab page is your go-to. Advanced Settings should have the option to change your language, check if that one is set to Hebrew. 

 

If only the News is displaying incorrectly, and you're on a device managed by your organization, there will be another setting to check. Click the 'Personalize' button and navigate to 'Experience Settings'. If you're not on a device managed by your org, you likely will not see this setting. That's totally fine. 

 

If the step(s) above, depending on which you can do, don't get you resolved just let me know =)

The gear icon for settings is also displayed in Hebrew. I am not on a device managed by an organization. My PC is for personal use.

Aha! Sounds like the gear settings are what you'll need to change =)

 

I'll drop a few pictures so you can navigate the settings, if that works for you! Note that your options may look a little different as I'm on a device managed by an organization, but hopefully this'll give you the spots you need to click at least! 

 

AlexandraR_0-1631907255692.png

AlexandraR_1-1631907310730.png

 

 

I assume you are going to send the Hebrew version of what I should look for in the settings gear?