Windows Admin Center 1809 Generally Available!

This is our first GA refresh since Windows Admin Center version 1804.25, and it's packed with new features.
Check out the official announcement blog post for more information and download or update today!
29 Replies

The upgrade doesn't seem to work.

We use a working installation of v1804 on a Server 2016.

Simply installed the v1809 msi, everything worked fine, but after the update the website isn't reachable anymore. Any idea?

Check out the troubleshooting guide for common issues and resolution steps. If nothing there solves your issue, please reply back here with the answers to the troubleshooting common questions

And it still pushes US date format everywhere. Can you not pick the date up from the host OS? It's annoying having to work out of 10/1 is the 10th January or 1st October! Better yet just use whole dates.

@Gary Williams did you set the regional settings?

If so, please let us know which language and regional setting that you have selected and where you aren't seeing it applied correctly.

@Jeff Woolslayer

Yes I set the regional settings. The Date is fine on the main screen but wrong in other places. 


Did you see the screenshot I posted? that's a prime example right there.

No sorry, I don't see an attachment on either of your posts.

Thanks! I've created a bug for this occurrence. If you notice it anywhere else, please let me know!

Hi @Jeff Woolslayer I have the same issue as @Elke Endörfer after installation site is either not reachable or if it manages to connect it throws ajax error 0 when trying to display any information (I ran PS script for connecition testing and there was no issues). Any news on that?


Thank You! 

I also posted some problems in regards of insider version 1808. Has any of these issue been addressed?


@Artur Schneider please check out the troubleshooting guide for common issues and resolution steps. If nothing there solves your issue, please reply back here with the answers to the troubleshooting common questions. Ajax error 0 is generally seen if the Windows Admin Center service is not running. 


I'll reply on the other thread as well.

Version:1.0 StartHTML:000000266 EndHTML:000002633 StartFragment:000002016 EndFragment:000002601 StartSelection:000002016 EndSelection:000002597 SourceURL:

Thank you for replying. I tried to apply suggested changes. WAC v.1809 Win Server 2016. Initially after accessing site I was indeed getting error message websocket/powershell could not connect. I checked features on Server 2016 and added WebSocket feature. Now I am not able to connect to server even locally getting connection refused message. As for Ajax error I checked the service and it was running.

I get this error every time I run the upgrade. 

I upgraded from 1808 to 1809 and now when i try to use remote desktop it just keeps spinning and never loads, same thing happens when i try to console in to a vm from wac, i tried uninstalling and reinstalling, and looked through troubleshooting steps and couldn't find anything. It worked fine on all of my server before 1809


  • Platform where Windows Admin Center is installed (Windows 10 or Windows Server):
    • If installed on Server, what is the Windows version of the machine running the browser to access Windows Admin Center: Windows Server 2016 Std
    • Are you using the self-signed certificate created by the installer? No
    • If you are using your own certificate, does the subject name match the machine? Yes
    • If you are using your own certificate, does it specify an alternate subject name? no
  • Did you install with the default port setting?
    • If not, which port did you specify? 4433
  • Is the machine where Windows Admin Center is installed joined to a domain? yes
  • Windows version where Windows Admin Center is installedServer 2016 Core
  • Is the machine that you are trying to manage joined to a domain? yes, except my hyper v host it is not domain joined
  • Windows version of the machine that you are trying to manageserver 2016
  • What browser are you using?  Google Chrome 69.0.3497.100 

Kinda bummed because i was really stoked for the hyper-v console feature

Hi again @Jeff Woolslayer


A strange new development occured with v.1809 installation. Although I can access gateway locally I get error 500 trying to access it from anywhere else. That doesn't happen with other servers that have v.1808 installed. (The setup is: Wn Server 2016, valid certificate (not self signed). I did the most common steps like clearing cache on client machine, refreshing dns etc still the error remains. As I said I know the service is running cause I can access gateway locally. Any ideas?

Thank You

We are tracking a known issue that can cause the firewall rule to be deleted, which would causes this.


To check of the firewall rule exists -

Get-NetFirewallRule -DisplayName "SmeInboundOpenException"

If the rule is missing, use this to recreate it replacing <port> with the port configured for Windows Admin Center (default 443.) -

New-NetFirewallRule -DisplayName "SmeInboundOpenException" -Description "Windows Admin Center inbound port exception" -LocalPort <port> -RemoteAddress Any -Protocol TCP



@Deleted - Will you please try Microsoft Edge and see if the RDP tool works for you there?


In the Virtual machine tool - if you choose to download the RDP file, are you able to successfully connect to the VM's console?

@Jeff Woolslayer Just tried in Edge and it does the same thing. And yes i can connect to my vm's just fine when i download the RDP file. 

@Deleted, what about the PowerShell & Events tools? are they working correctly for you?


The Remote Desktop webclient, PowerShell and Events tools all requires support in your enviorment for websockets