Cannot login into Widgets

Copper Contributor

Hi, together! Every time I try to open Widgets (in the screen's left lower corner I can see the current weather status), I get a login window, after giving my login data and confirming 2-step-verification with my phone the login window closes, but I am still not logged in. This happens for new user, I created some weeks ago, the new user is logged in with MS account, everything works fine, all apps can use account information - except Widgets. I tried to re-install Widgets, the problem remains. For other user Widgets works fine. 



I tried also to logout from MS account and login again, no change. I reported this to Feedback Hub, no results. 


Is there any place in Registry, which could be checked or changed?


sfc shows no errors, dism shows no errors. 


I know, this isn't very important feature, but it goes on my nerves, when I cannot use something, what should work. Thx in advance.

3 Replies

Hello @ZedKay,


Not sure which method you tried to reinstall widgets. I recommend to reinstall widgets with method shown in this video:



Let us know if this helps!

@Kapil Arya This is exactly the way, I did it. So, I do it once again. First uninstall:


then I looked for the Windows Web Experience Pack in MS Store, nothing found:


Then I used the given link:


and got it from Store (seems to be a Win10 app?):


After installing I tried to login into Widgets, it is still the same problem, your method did not help, sorry.


I tried also to logout from Windows (login with the local account instead). Nothing. Then I tried to login with my MS account, it failed with a message " sorry, it is our fault, try later" or so. Then I re-booted my computer and I could login with my MS account again. I allowed my wife (via MS Family) to login into my computer with her MS account, Widgets worked fine. Also for my another MS account on the same computer Widgets works fine. As my Account is relatively new (some few weeks), so I suppose, there is a problem with my MS account maybe?

best response confirmed by ZedKay (Copper Contributor)
Finally, I deleted the user with Widget problem and created a new one, where Widgets works fine. Copied data from the previous account and the most of apps seem to work.

Got a new problem with a fingerprint in Hello (unfortunately, I did not erase fingerprints before deleting an account)... but this is another case.