Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)
SOLVED

Windows 10 Version 1809, Remote Desktop Connection not working from PC but working fine from macOS.

Visitor

Updated yesterday to version 1809,

Remote Desktop Connection from another Windows 10 version 1809 not working.

It looks like connected, but the whole screen is blank and the mouse cursor become hourglass then about 1 minute later, lost connection. Then trying to re-establish the connection, but the screen is still black. This time mouse cursor even stuck and not showing in the screen. 

 

75 Replies

I have the same problem. The old version of mstsc (windows 10 1709, windows 7, Android version) can connect smoothly. However, the mstsc of windows 10 1809 cannot connect. While connected, the screen freeze. 

I've got the same problem.  I tried to log into my remote PC yesterday (both local & remote have been upgraded to 1809).  Out of 5 attempts one was successful - the other 4 attempts resulted in the screen freezing in one form or another).

 

A fix for this would be gratefully received - I and my organisation are rather dependent on remote connections.

Same problem. A black screen. Can confirm that the cumulative update didn't resolve this. 

The only one solution is to, use the computer network name not the ip adress. But this is a half solution......

 

Have a nice day

As it happens I was using the machine address and not the IP address and it was not working using the machine address.  I can't check this any further at present because I've rolled back to 1803.

 

One thing that seemed odd was that I was able to remote desktop using a machine on the local network, but not over a vpn connection (and I did check the vpn was working correctly by connecting to other machines that were not updated to 1809).

Same problem here, my rdp server is behind a router with portfoward.

On my computer I can connect from my office but not from home (both places behind NAT)

I have no idea why it works from my office, before 1809 it worked from anywhere.

 

 

Exactly the same with me.

 

RDP between office computers work fine. Between computers at the house works fine. Home to the office works fine, but from the office to home, black screen.

 

Been using Remote Desktop Connection Manager in the meantime. Works okay, but not preferable.

 

Also, it makes no difference if I use the fully qualified name or the ip.

 

 

 

 

Are we talking 1809 to 1809 systems? If  so, then ignore below text. :)

 

Was the 1809 system the remote. or was it initiating the Remote Desktop? What version was the remote system?   I have an 1809 system that can connect to an 1803 system fine. And, the 1803 can connect to 1809 fine.

 

I have not tried connecting through VPN or NAT router.

Yes. Sorry, I should have mentioned that all systems were 1809.

Same issues with RDP. Cannot connect to remote session.

Also seeing this problem. When logging in remotely from a PC running 1809 to another PC running 1809 over the WAN RDP draws the first few frames and then suddenly locks up.

I do have the same problem (as Munn). The only workaround is to enable "Turn Off UDP On Client" in the group policy editor.

I have the same problem. Remote Desktop client stopped working right after this update. Very frustrating. Still reading but I hope there is a fix.
Yep, I am getting exactly the same symptom.

Ditto to all the above symptoms, 1809 version, cannot connect to any RDC enabled OS (W2008 - W2016)

Which blows, as I have several hundred RDP sessions saved. :\

 

If you are in a pinch, download the remote desktop app, at least you can connect on the fly until this is fixed or until you can try the UDP disable reg settings mentioned

RDC APP: https://www.microsoft.com/en-us/p/microsoft-remote-desktop/9wzdncrfj3ps?activetab=pivot:overviewtab

 

Just tested on 1809.

Made a connection from a windows 10 1809 client to a windows 10 1803 client, via hostname and via IP, both seem to work, so OK.

 

From the same machine, made an RDP connection to a Windows Server 2012 R2 via hostname and IP, screen stays blank for a bit longer, but eventually working. So also ok.

The problem happen only if enabled the UDP on Remote Desktop Connection in 1809

The UDP  enabled automatick

 

So how can desable the UDP ???

in case if you are still looking for a solution for this one. Enabling Turn Off UDP On Client worked for me.

Open gpedit and navigate to computer configuration\Admin Templates\ Windows Components\Remote Desktop Services\ Remote Desktop Connection Client

Enable Turn Off UDP On Client apply and try connecting again.

I hope this helps

To disable UDP on client machine.

Open gpedit and navigate to computer configuration\Admin Templates\ Windows Components\Remote Desktop Services\ Remote Desktop Connection Client

Enable Turn Off UDP On Client apply and try connecting again.

I hope this helps