Three known bugs in the latest build of Win10 version 1903

Honored Contributor

Microsoft late Thursday declared Win10 version 1903 as ready for business deployment.


  • The latest versions of Win10 1903 block installation of .NET 3.5. You may scoff that it’s an old version of .NET, but at least one large package — part of the ERP package known as SAP — requires .NET 3.5. Per Günter Born:

[.NET 3.5] installation fails with the error:

Microsoft-Windows-NetFx3-OnDemand-Package: 0x800f0954



I installed the updated Sept 2019 Cumulative Update for Win10 x64 [1903] and it broke me printing to a network HP Color LaserJet Pro MFP M180NW… What happens in my case is the screen will flash, I hear the printer start, but then nothing. And then Windows closes any open windows. Almost like Windows Explorer restart. Job is not being held in the queue, printer is not offline (but HP software monitor says it is), this is a network printer I am testing on.



  • The latest versions of Win10 1903 trigger black screens when running RDP. Per an anonymous poster:

We have HP z2 g4 mini PCs – Windows 10 Pro 1903 – we have installed the updates above and we still get a black screen on remote desktop. We tried changing the systems we are remoting to to use the MS Basic Display Driver but that did not resolve the issue. Rebooting allows the system to work for an unknown amount of time before it stops working again until the next reboot.

And confirmation, again anonymously:

I installed KB4517211 (OS Build 18362.387) and still have the RDP black screen on HP EliteDesk 800 G5 SFF and HP 800 G3 Mini desktops. I ran HP SDM on both models to ensure all OEM drivers are current as of 9/27.


rolling back the latest updates fixes the problem.



1 Reply



I'll be honest, I haven't yet seen the RDS black screen issue and I had to do alot of it today on the latest build. I haven't had the opportunity to test against the other two issues.


What I can say though is that our domain connected computers are still having the Search not responding problem, our pilot scope if 54 computers and all 54 of them have this issue. Starting with the Sept 10th update, it also rendered right click context menu on app icons (on taskbar) and Action  Center completely inoperable. This continued with the out of band IE11 patch.


But the update from last a couple of days brought back the app icon context menu's and Action Center at the second time of Microsoft trying, the search feature is still completely inoperable though. This may or may not be important, but the affected computers were all built via WDS as 1709 systems and they had several provisioned apps removed including Xbox which funnily enough break Photos (because a .Net Runtime that Photos in 1709 relies upon is also removed, an unfortunate way that Microsoft set their apps and dependencies up). Funnily enough the way Photos was broken in 1709 shows symptons identical to the way Search is broken in 1903, no error message or anything seemingly detrimental on screen except that it plainly doesn't launch.


Now after updating these 1709 builds via WSUS to 1903 the new Photos app worked (hoorah, some users were happy) but I don't think they will appreciate losing Search since Sept 10th so all cumulative updates are on hiatus. Something important to note, all 1903 builds deployed from WDS and using the same method to remove provisioned apps are not affected by the Search problem using the three cumulative updates since Sept 10th.