Sharepoint Teamsite owner can't edit the files that he is owner of.

Copper Contributor

Dear community, 


We are facing an issue with sharepoint online where a site owner can't edit the files (tried on 2 excel files) that he uploaded himself, permission inheritance is turned on. file is not checked out by any other user. this happens while other users with a lower permission set(site members) can edit the file


When he opens the file this above is what he sees (translation is: "Read-only" you don't have permission to update/edit this file)

In addition when he opens the site URL and tries to create a new file, he doesn't see the option for creating any sort of file (normally you have the option "new word file, new excel file" and so forth..) he just has the option to create a folder(see below):



Troubleshooting steps that we’ve taken:

  • checked, removed, and reassigned permissions.
  • Removed user from the team and added him back as owner(teams admin console)
  • Removed all the cached credentials from the pc so the user needs to login on the apps again (which doesn’t make any difference since the user is not able to open the file on a web browser which he already logged in with his correct account)
  • Removed him as owner and added him as member, didn’t make any difference.
  • Shared the document with a link still the same issue

at this moment I'm out of ideas, any help/idea can be useful please don't hold back.
I appreciate your ideas and participation in this thread.

8 Replies
Could it be that this user's account was deleted in the past and re-created?

Faced something similar to this the old user ID was present on the site, and I had to remove it manually

I realized after using the Help Wizard in the admin panel, it will try to diagnose and inform what is happening, so I would give it a try

So you can go to Support -> Help & Support and use these

"Unable to access Teams Files"
"Unable to access files shared in Teams chat"

and fill the information and wait for results

@Andres Gorzelany 
Hello there Andres, 
The user hasn't been removed an recreated, this issue appeared 4days ago without any changes to the site, team or user permissions. 

I tried your suggestion it didn't find any issues:


What's more frustrating is that he can do everything to the file such as copy, move, remove and..... except editing.

If you use the "Check permissions" on this library, what's showing for this particular user?

@Andres Gorzelany 

This is what I see there:


He got full control (Given through the site owners)  , and I see there beside limited access (not sure why or how or what even that means since he has full control)


and on the file itself these are the permissions:



About limited access

when you assign edit or open permissions to the single item, SharePoint automatically assigns Limited Access to other required locations, such as the site or library in which the single item is located.

Is this happening with only this library from this site? or any library in the same site?
What about other sites?

@Andres Gorzelany 


I've checked with the user and he is experiencing this issue only on this site (single library).

Since this is a sharepoint team-site, if I want to remove and reassign him the owner permissions set which way is the best to do:


Remove him from sharepoint site wait 30mins and assign him back 
Remove him from the team(teams admin center) wait 30mins and add him back to the team?

@Andres Gorzelany 

I appreciate your contribution and follow up, we've found the issue apparently somehow out of the blue the sharepoint checkbox was unchecked on his licensing page. no idea how or why, but we can't find even an event for this. it's like it happened automatically.

Thanks again for your help and Cheers!.