"Dynamically display images from a document library" is missing in Image Gallery web part

Contributor

Hi Team

 

I am unable to find "Dynamically display images from a document library" in Image Gallery web-part settings in a modern page.

 

What could be the reason ?

 

Thank you :)

5 Replies

@MadhusudanShettyMS Have you found the solution? as one of my colleagues also not able to see the "Dynamically display images from a document library" even he is the Admin on this site. On the other hand, when I log-in to the same site I can view the option to select Dynamically when edit the image gallery, not sure what other configuration or permission he may need.  

@Muzammil_Hussain has anyone found a resolution or reason for this? I have the same issue and would love to actually be able to do some work today.

@DaveGrooms @MadhusudanShettyMS Yes! I have a workaround. I added a column type "Hyperlink or Picture" in the document library as follows;

Muzammil_Hussain_0-1614793628998.png

 

I Format URL as a "picture" in the column setting, added the following JSON in the Column Formatting:

-----------------------------------------

{
"$schema": "https://developer.microsoft.com/json-schemas/sp/column-formatting.schema.json",
"elmType": "img",
"attributes": {
"src": "@thumbnail.medium"
},
"style": {
"display": "block",
"margin": "0 auto",
"max-height": "142px"
}
}

-----------------------------------------

Column setting screenshot as follows;

Muzammil_Hussain_1-1614793929002.png

 

And when I add the Image gallery web part to the modern page it displays the images.

 

I hope it helps :) best regards, ~Mo

 

@Muzammil_Hussain haha, this sounds just enough Microsoft crazy for me to actually try it!