Permission level / SharePoint Online / Lists with Modern Experience (no O365 Groups assigned)

New Contributor



I found a strange behaviour. Anybody an explanation?


In SharePoint Online (based on the teams template with no O365 group) I create a new permission level, basically a copy of Contribute. I assign it to a SPGroup and break inheritance for a list. Now the list with modern experience has a multiline text field which cannot be edited, it says SharePoint has connection issues. 

When I assign the out of the box Contribute permission level, there is no issue.


The reason for making a copy and use my own Permission Level is that I want to move away some permissions, like being able to edit a page etc.


So why is there a difference between custom permission levels and ootb's?




4 Replies



Are you saying there is no difference between Contribute and your permission level at the moment? 

@Andrew Hodges, exactly - I first created my own Permission Level and as this was not working, I started to add more and more permissions up to the point where my custom permission level was an exact copy of the standard permission level Contribute. Then I found out that when using my custom permission level it still was not working, but when chosing the Contribute (standard) permission level, it worked. 



Have you tried using the Copy permission level option at the bottom of the Contribute screen. See if that has the same result.


Andy Hodges | ThinkShare |

Sorry, for the late reply. I tested both now creating a new permission level from scratch and using the copy permission level button. Both with the same results.