Error when trying to deploy spfx package to Apps catalog From SharePoint Store

Iron Contributor

I have an SPFX App in AppSource that is working perfectly on existing deployment. The App was approved by the validation team May this year. So, the App is quite newly updated.

I am working on a new deployment for a new customer. However, I am not able to deploy the App from the Store now? The user I am using is primary admin on the App catalog site. 

I have tried deploying from the Store and also to upload directly but I keep running into the same issue. The deployment seems to be ok. However, the status keeps being “Disabled”, that even if I try to enable the App. 

Question is if this is a general error or has there been made updates since May that we need to make to the spfx package? 

Thank you

2 Replies

@Alon Ekelund Try these:

  1. Select the SPFx package in app catalog and Enable from top command bar
  2. If you have latest SPFx package (sppkg file) with you, upload it to app catalog and replace previous file. 

Note: Perform above operations using Site collection administrator (SCA) account (for that specific site collection) if it is a site collection level app catalog and SharePoint tenant administrator  account if it is a tenant level app catalog.

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.


I tried that. When I do it tells me that it has been enabled successfully. However, the status remains "Disabled" and the App is not available on any sites.

As mentioned, I also tried both sideloading and from AppSource. Same result :(

The user I am using it primary Admin on the App catalog and is even global admin. Should that be sufficient?

Thank you