Document template of content type (in content type hub) not found when creating new document

Copper Contributor

Hi all,


I'm running into a problem when trying to maintain document templates in a centralized place. Hope someone can help. I'm using SharePoint online.


I've activated the content type hub service and created a content type following this instruction. Also associated a document template, as described in the instruction, published it, etc. Also added the content type to the Shared document library on my SP site (as described here).


Now, when I create a New document, nothing happens, the screen just flashes. Inspecting the console output, shows an error stating that the template file is not found. It turns out that it tries to locate the template document in the Shared documents library of the SP site, not on the content type hub!

What is the use of adding the document template to the hub? If I also have to add it to all documents libraries in which I want to use it?

Am I missing something? Is there a smarter way of achieving what I want (e.g. centralized document templates)?

5 Replies

@marco_du_cato I managed to reproduce the behavior on 4 different tenants.

Seems like a general problem with synchronization between the Content Type Hub and a site's document library.


Steps to reproduce:
1. Go to SharePoint Admin Center > Content Services > Content Type Gallery

2. Create new Content Type > Inherit from "Document" parent Content Type
3. Attach a custom document template to the above Content Type and Publish

4. Create a new site (or use existing one) > Go to any document library

5. Add above Content Type to library

6. Trying to create a new document based on the above content type results in a 404 Not Found error.

From my observations the file is not being correctly uploaded to the document library's Forms folder, where SharePoint keeps the document templates.


Anybody else have this or knows what's happening? 

I don't have a solution but I have this exact problem in my tenant.

@marco_du_cato This seems to be a bug, we've opened a support ticket with Microsoft and I would encourage you to do the same. There's another Tech Community post reporting the same issue here:

Unable to create document from custom content type, using document template 

@marco_du_cato I opened a ticket with MS support and they've already solved this for me, so it seems to have been on their side.


Good luck!

@marsobkow, @CallumCrowley Thanks for your suggestions. Worked this way for me as well!