Bug: Comments Section Showing on All Pages When It's Not Enabled...

%3CLINGO-SUB%20id%3D%22lingo-sub-1631852%22%20slang%3D%22en-US%22%3EBug%3A%20Comments%20Section%20Showing%20on%20All%20Pages%20When%20It's%20Not%20Enabled...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1631852%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anyone%20tell%20me%20why%20this%20%3CSTRONG%3Ecomments%20wrapper%3C%2FSTRONG%3E%20shows%20up%20even%20when%20comments%20are%20turned%20off%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22CommentBar.PNG%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F216310i2D298C396DBE587D%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22CommentBar.PNG%22%20alt%3D%22CommentBar.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20worked%20really%20hard%20on%20our%20internal%20knowledgebase%20only%20to%20have%20this%20problem%20pop%20up.%20It's%20a%20problem%20on%20each%20of%20our%20SharePoint%20sites%20that%20I%20work%20on...%20It%20is%20just%20blank%20white%20space%2C%20and%20if%20I%20delete%20the%20DIV%20using%20Chrome%20developer%20tools%2C%20it%20looks%20perfect%20(%3CEM%3Ebecause%20this%20wrapper%20shouldn't%20even%20generate%20when%20the%20comments%20are%20disabled...%3C%2FEM%3E).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22CommentBarSourceCodeFinal.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F216306i89CF48315CEBBB1E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22CommentBarSourceCodeFinal.png%22%20alt%3D%22CommentBarSourceCodeFinal.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20many%20things%20like%2C%20enable%20the%20comments%2C%20then%20turn%20them%20off%20again%2C%20rebuilding%20the%20page%2C%20etc.%20and%20I'm%20not%20sure%20there%20is%20much%20else%20I%20can%20do.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22CommentsTurnedOff.PNG%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F216312i5CFE9CB5164B1EA1%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22CommentsTurnedOff.PNG%22%20alt%3D%22CommentsTurnedOff.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1631852%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EResponsive%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESites%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1635607%22%20slang%3D%22en-US%22%3ERe%3A%20Bug%3A%20Comments%20Section%20Showing%20on%20All%20Pages%20When%20It's%20Not%20Enabled...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1635607%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSTRONG%3EBump%3C%2FSTRONG%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1636152%22%20slang%3D%22en-US%22%3ERe%3A%20Bug%3A%20Comments%20Section%20Showing%20on%20All%20Pages%20When%20It's%20Not%20Enabled...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1636152%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F780923%22%20target%3D%22_blank%22%3E%40CasualSharePointUser1080%3C%2FA%3E%26nbsp%3BI'm%20not%20being%20flippant%20but%20I'm%20afraid%20the%20answer%20is%20%22%3CEM%3Ebecause%20Microsoft%20have%20built%20it%20that%20way%3C%2FEM%3E%22.%20As%20we%20don't%20have%20access%20to%20change%20the%20CSS%20I%20don't%20think%20there'll%20be%20anything%20you%20can%20do%20to%20fix%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERob%3CBR%20%2F%3ELos%20Gallardos%3CBR%20%2F%3E%3CFONT%20size%3D%222%22%20color%3D%22%23006400%22%3EMicrosoft%20Power%20Automate%20Community%20Super%20User%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

 

Can anyone tell me why this comments wrapper shows up even when comments are turned off?

 

CommentBar.PNG

 

I've worked really hard on our internal knowledgebase only to have this problem pop up. It's a problem on each of our SharePoint sites that I work on... It is just blank white space, and if I delete the DIV using Chrome developer tools, it looks perfect (because this wrapper shouldn't even generate when the comments are disabled...).

 

CommentBarSourceCodeFinal.png

 

I've tried many things like, enable the comments, then turn them off again, rebuilding the page, etc. and I'm not sure there is much else I can do.

 

CommentsTurnedOff.PNG

 

3 Replies
Highlighted
Highlighted

@CasualSharePointUser1080 I'm not being flippant but I'm afraid the answer is "because Microsoft have built it that way". As we don't have access to change the CSS I don't think there'll be anything you can do to fix it.

 

Rob
Los Gallardos
Microsoft Power Automate Community Super User

Highlighted

@Rob Elliott I could 100% see you being right on the money with this one. :smile: It is unfortunate since it does have a sleek design. I wish we could edit the CSS because I wouldn't likely be getting this problem either, the footer just doesn't show up, and there is a large white space at the bottom of the page...? :cryingwithlaughter:

 

FooterGone.PNG