Planner access issues.

%3CLINGO-SUB%20id%3D%22lingo-sub-9267%22%20slang%3D%22en-US%22%3EPlanner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-9267%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20faced%20a%20problem%20with%20access%20to%20Planner.%3CBR%20%2F%3EWe%20disabled%26nbsp%3BGroups%20and%20Plan%20creation%20in%20our%20tenant%20and%20during%20pilot%20fase%20we%20made%20groups%20using%20PowerShall%20with%20one%20owner.%20In%20some%20of%20this%20Groups%20owner%20can't%20access%20their%20Plan%20in%20Planner%20with%20error%20message%3A%3CBR%20%2F%3E%22Oops%2C%20something%20went%20wrong%20...%3CBR%20%2F%3EThis%20plan%20is%20not%20available.%20The%20plan%20may%20have%20been%20deleted%2C%20or%20you%20no%20longer%20have%20access%20to%20it.%22%3CBR%20%2F%3Ewith%20%3CSPAN%3Ecorrelation%3C%2FSPAN%3E%20number%2C%20time%20and%20Planner%20version%3CBR%20%2F%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOwner%20can%20add%20members%20and%20owners%20to%20Group%20and%20they%26nbsp%3Bdon't%20have%20any%20problem%20with%20Planner.%3CBR%20%2F%3EFirst%20owner%20is%20listed%20in%20the%20Group%20but%20isn't%20a%20member%20in%20the%20Plan.%20When%20new%20owner%20add%20him%20in%20Plan%20access%26nbsp%3Bget%20back%20on%20track.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EDid%20anyone%20face%20something%20similar%3F%20How%20to%20prevent%20from%20this%20bug%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-354287%22%20slang%3D%22en-US%22%3ERe%3A%20Planner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-354287%22%20slang%3D%22en-US%22%3EI%20should%20add%20that%20I%20am%20using%20the%20Microsoft%20Graph%20to%20assign%20owners%20and%20members%20to%20Groups%20via%20Flow.%20Also%2C%20one%20thing%20I%20have%20also%20noticed%20is%20that%20when%20I%20try%20to%20add%20a%20'New%20Plan'%2C%20I%20cannot%20select%20the%20group%20that%20was%20created%20via%20Flow.%20Whether%20this%20is%20because%20I'm%20not%20recognised%20as%20an%20Owner%20or%20not%20(when%20I%20look%20at%20Group%20settings%20in%20Admin%20I%20am%20listed%20as%20an%20Owner)%2C%20I've%20yet%20to%20determine.%3CBR%20%2F%3E%3CBR%20%2F%3EDefinitely%20some%20bugs%20in%20the%20Office%20365%20apps%20though%20which%2C%20given%20the%20rate%20of%20change%2C%20is%20expected%20I%20suppose.%20As%20long%20as%20Microsoft%20react%20quick%20enough%2C%20and%20the%20bugs%20aren't%20severe%20enough%2C%20it's%20ok.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-354261%22%20slang%3D%22en-US%22%3ERe%3A%20Planner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-354261%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20similar%20issue.%20I'm%20creating%20a%20group%20via%20Flow%20and%20despite%20being%20added%20as%20the%20group%20owner%2C%20when%20I%20go%20to%20the%20related%20Planner%20I%20get%20the%20same%20error%20with%20a%20(very%20useful%5E)%20correlation%20ID%20for%20my%20troubles.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20go%20to%20the%20Group%20setting%20and%20then%20add%20myself%20as%20a%20member%2C%20I%20can%20then%20access%20the%20Planner%20board%20no%20problem%20but%20obviously%20this%20seems%20a%20bit%20backward%20i.e.%20Owner%20can't%20see%20the%20board%20but%20Member%20can.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20suspicion%20is%20that%20adding%20myself%20manually%20as%20a%20member%20gives%20everything%20a%20kick%2C%20and%20the%20mechanics%20behind%20the%20access%20to%20Planner%20is%20re-triggered%20(or%20something%20similar).%20This%20is%20just%20a%20guess%20of%20course!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBe%20interesting%20to%20see%20if%20anyone%20else%20has%20the%20same%20problem%20and%20if%20so%2C%20how%20they%20resolve%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-152526%22%20slang%3D%22en-US%22%3ERe%3A%20Planner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-152526%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20issue!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-9277%22%20slang%3D%22en-US%22%3ERe%3A%20Planner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-9277%22%20slang%3D%22en-US%22%3E%3CP%3ENot%20yet.%20Yes%20you%20are%20right%20we%20used%26nbsp%3B%3CSPAN%3EAzure%20AD%20policy%20to%20prevent%20groups%20creation.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-9273%22%20slang%3D%22en-US%22%3ERe%3A%20Planner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-9273%22%20slang%3D%22en-US%22%3EDid%20you%20open%20a%20ticket%3F%20I%20assume%20you%20have%20used%20the%20Azure%20AD%20policicy%20to%20prevent%20groups%20creation%2C%20don't%20you%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1136152%22%20slang%3D%22en-US%22%3ERe%3A%20Planner%20access%20issues.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1136152%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F172271%22%20target%3D%22_blank%22%3E%40Joe%20Ayre%20Work%3C%2FA%3Ethis%20really%20helped%20me%2C%20thank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

We faced a problem with access to Planner.
We disabled Groups and Plan creation in our tenant and during pilot fase we made groups using PowerShall with one owner. In some of this Groups owner can't access their Plan in Planner with error message:
"Oops, something went wrong ...
This plan is not available. The plan may have been deleted, or you no longer have access to it."
with correlation number, time and Planner version
 

Owner can add members and owners to Group and they don't have any problem with Planner.
First owner is listed in the Group but isn't a member in the Plan. When new owner add him in Plan access get back on track. 

Did anyone face something similar? How to prevent from this bug?

6 Replies
Highlighted
Did you open a ticket? I assume you have used the Azure AD policicy to prevent groups creation, don't you?
Highlighted

Not yet. Yes you are right we used Azure AD policy to prevent groups creation.

Highlighted

Same issue!

Highlighted

I have a similar issue. I'm creating a group via Flow and despite being added as the group owner, when I go to the related Planner I get the same error with a (very useful^) correlation ID for my troubles.

 

If I go to the Group setting and then add myself as a member, I can then access the Planner board no problem but obviously this seems a bit backward i.e. Owner can't see the board but Member can. 

 

My suspicion is that adding myself manually as a member gives everything a kick, and the mechanics behind the access to Planner is re-triggered (or something similar). This is just a guess of course!

 

Be interesting to see if anyone else has the same problem and if so, how they resolve it.

Highlighted
I should add that I am using the Microsoft Graph to assign owners and members to Groups via Flow. Also, one thing I have also noticed is that when I try to add a 'New Plan', I cannot select the group that was created via Flow. Whether this is because I'm not recognised as an Owner or not (when I look at Group settings in Admin I am listed as an Owner), I've yet to determine.

Definitely some bugs in the Office 365 apps though which, given the rate of change, is expected I suppose. As long as Microsoft react quick enough, and the bugs aren't severe enough, it's ok.
Highlighted

@Joe Ayre Workthis really helped me, thank you!