Once more: Edit Labels

New Contributor

One of the updates of Planner in 2020 has removed the ability to edit the labels. Now they are called RED, GREEN and so on. Without a description was RED means for the owner of a plan, labels makes no sense. Please re-introduce this feature as soon as possible. A further implementation of creating new labels with custom colors would be the cherry on the cake.


Proof that it was working before:

8 Replies

Hi @KristofZ Maybe I am misunderstanding, but changing the labels still works fine for me. Just click on the label and start writing whatever you want to name them. 


i can confirm, it's not editable for me. Tried it with firefox and edge, and in teams.

Any suggestions?

Nope ... until now, it is not possible and makes the feature useless...
best response confirmed by jackieduong (Microsoft)

@KristofZ @zalu_de Hello! If you open up a task (click on the task) and hover over the side of the details pop up (where the labels are), you can change the names of the labels. Please let me know if this helps!



Thank you for your feedback - we are improving our labels experience - you can follow along here.


@jackieduong No, its not editable. I'm able to set the cursor, right (like your screenshot), but it doesn't react on any keystroke and you can't mark the text or do anything there. Doesn't matter, if you are using TEAMS or the PLANNER website.


Oh it is a visual thing ... I always tried to replace the text thats given. A short look into the dev tools told me that they are (technically) placeholders and placeholders are not editable for sure. It never occured to me, just to type in my new label text. Shame on me... :D


P.S. Maybe it would be an improvement to hide or dim the placeholder, when the user sets the cursor into the INPUT...

@KristofZ glad this is resolved :smile: thanks for this feedback! look out for some more improvements, and please continue to share what you're thinking of the product! 


@jackieduong - thank you for the image.  


I am still struggling with this because my labels do not stick out to the side as in this image. I have to choose "labels" from the 3-dots menu and I cannot find any way to edit the names of the labels at this time.  Hovering over one of the labels just shows the name in a small white tool-tip box.  Clicking applies the label.  I cannot find any way to edit.  I am using Planner in Edge.  Any suggestions?  I wonder if it has changed since 2020.