Unable to Remove Deleted File from Shared With Me

Copper Contributor

We ran into a scenario where Person-A shared a OneDrive for Business document with Person-B.  Person-A then deleted the document and emptied their recycle bin.  Person-B could still see the document listed under "Shared with me" via their own OneDrive, however they cannot remove that document from "Shared with me."  Selecting the document from within "Shared with me" and clicking on "Remove from shared list", results in an error stating "Sorry, we weren't able to remove this item from your view."


Has anyone else experienced this?  It seems that we could eventually end up with many orphaned links in users' "Shared with me" lists.  



26 Replies

@UH123640 - I was wondering - can you just right click on the files (In Office.com) instead of trying to open them? Maybe there is an option to remove them without opening.


It's just a guess on my part as I no longer have any shared files to test.



Hi Smiddy,

I’ve tried this too. There’s nothing you can do from your end unfortunately.

I’ve even reported this to the Microsoft support team and they’ve noted it as “feedback”, but haven’t heard anything since.
Same problem here! Microsoft, please fix asap! This problem has forst been reportet 4(!) years ago!

@Catherine Feldman 
Hello Catherine,

I have same problem. I have in list "Share with me"  file, and I cannot delete it.

this file was few years back in one email what I received on my outlook.com
email where was this file was is year back deleted.


But this file is still showing in my Online Word app, Desktop Word app, Android Office app in list "Share with me"
and I haven't any option how delete it. Please can someone help me with remove this file from list "Share with me".

I created ticket where is screenshot from Onlne Word app and Desktop Word app, where is showed this file, what I want remove, but I havent any option how remove it because here not exist any button remove/delete.

Thank you for your help.

URL from not exist and not working file is:

I also have the same problem. No solution yet.
Hello, Still not exist any fix? Or help from Microsoft side?

It's still happening 6 years later! What have you done?

@Stephen Rice