Files On-Demand Option Missing

Copper Contributor

I know this topic has come up time and time again. I'm finding it really hard to identify why several computers our business has, will not display the files on-demand check box at all... This issue was present with Windows 10 1803, 1809, and still present on these two computers at 1903.

Recently I decided, well, lets just install OneDrive Per Computer model and that should make sure we're at the latest version. So I ran the OneDriveSetup.exe /AllUsers verified it installed, rebooted, and still no option for Files On-Demand. 

Currently OneDrive Version 2019 (Build 19.086.0502.0005).


Came across an article by Microsoft that made me hopeful when it said that if the "windows cloud files filter" service was in any state besides auto-start it would not allow Files On-Demand check box to show. Surprisingly enough that service does not appear to be visible in the services list. However, if you sc query the service name, it shows as started and a check on the registry shows it's set to 2, meaning auto-start. 


Any further suggestions anyone can give would be GREATLY APPRECIATED! Thanks in Advance!

3 Replies

Did you ever make any progress on this?  We're seeing the same thing on a 2019 RDS server, but the odd part is it works for some users, but not all of them.

@abond1155 still same issue here with the latest Ondedrive production version 20.143.0716.0003

It must has someting to do with using 2 instances/accounts in Onedrive:

1 client is syncing my personal Onedrive account

1 client is syncing my business Onedrive account

With the personal account I have the option files on demand.

with the  work account I do not have the option files on demand.

Tried resetting onedrive relinking account en resyncing, nothing worked.

It worked before with two accounts till I solved the "Onedrive can not connect to Windows" error when starting Windows (each day) This was solved by choosing the Download files option in the prompt.

@Bart Korn Did you ever find a solution for this?

We have the exact same issue, I've spoken to 3 support representatives now and nobody at MS seems to be able to fix this issue.

Please let me know.